Results 1 to 7 of 7
  1. #1
    New ROGer Array
    Join Date
    May 2013
    Reputation
    10
    Posts
    3

    G55VW Boots only into BIOS - Hard drive / CD drive are gone as boot options. Help!

    I bought this beast today actually. I took off Windows 8 and put on Windows 7. Everything was working fine until i noticed the keyboard didn't backlight itself.

    I checked out the bios and realized i had a new update to flash on the bios (217). I proceeded to flash 217 with no errors. As soon as i rebooted, the laptop would only boot into the bios every time. The hard drive and dvd drive have disappeared as boot options(the bios recognizes them in the SATA options though). I tried to flash back but the utility prevents me from flashing anything else. (it won't let previous versions flash because it is an outdated version, i tried re-flashing 217 and it said it couldn't flash it as well for being too outdated)

    I've cleared the capacitors/cmos, messed with every option i could in the BIOS and done a bit of googling. I am trying a bootable USB disk as we speak. Any and all help is appreciated. Thanks.
    Last edited by petezilla; 05-16-2013 at 02:43 AM.

  2. #2
    ROG Guru: Black Belt Array rewben PC Specs
    rewben PC Specs
    Laptop (Model)G55VW-3D
    MotherboardASROCK Z97 EXTREME 6
    ProcessorINTEL 4790K
    Memory (part number)G.SKILL RIPJAWZ 2400MHZ (F3-19200CL10Q-32GBZHD)
    Graphics Card #1ASUS STRIX-GTX980-DC2OC-4GD5
    Graphics Card #2ASUS STRIX-GTX980-DC2OC-4GD5
    MonitorDELL U2713HM
    Storage #1SAMSUNG SM843 480GB X2
    Storage #2WD GREEN 3TB X2
    CPU CoolerSWIFTECH H240-X
    CaseNZXT H440
    Power SupplyTHERMALTAKE TOUGHPOWER XT PLATINUM 1275W
    Keyboard CORSAIR K70 RGB
    Mouse STEELSERIES KINZU V3
    Headset STEELSERIES 9H
    Mouse Pad STEELSERIES QCK+
    Headset/Speakers LOGITECH Z506
    OS WINDOWS 10 PRO AU
    Network RouterASUS RT-AC66U

    Join Date
    Jun 2012
    Reputation
    178
    Posts
    2,229

    @petezilla, check these in bios:

    1. disabled the secureboot and fast boot;
    2. enabled launch csm;
    3. boot order.

    one thing at a time. just don't panic yet. to revert the bios you can use ctrl+home combo, with the stock bios in your stock drive (if you haven't formatted it yet)

  3. #3
    New ROGer Array
    Join Date
    May 2013
    Reputation
    10
    Posts
    3

    Secure and fast boot have been disabled. CSM is launched. Boot order only shows my USB stick, when i take it out there is nothing under the boot order.

    I've tried manually adding the hard drive path as a boot option but its a bit confusing and im not sure if its even possible without it being detected as a boot option. Are there any third party flashing tools i could use to force a flash back to 214?
    Last edited by petezilla; 05-16-2013 at 02:59 AM.

  4. #4
    New ROGer Array
    Join Date
    May 2013
    Reputation
    10
    Posts
    3

    USB disk seemed to fix it! The old boot options are back. Thank you for the help! Now if you can tell me how to get the keyboard backlight working, ill be 100%

  5. #5
    ROG Guru: Black Belt Array rewben PC Specs
    rewben PC Specs
    Laptop (Model)G55VW-3D
    MotherboardASROCK Z97 EXTREME 6
    ProcessorINTEL 4790K
    Memory (part number)G.SKILL RIPJAWZ 2400MHZ (F3-19200CL10Q-32GBZHD)
    Graphics Card #1ASUS STRIX-GTX980-DC2OC-4GD5
    Graphics Card #2ASUS STRIX-GTX980-DC2OC-4GD5
    MonitorDELL U2713HM
    Storage #1SAMSUNG SM843 480GB X2
    Storage #2WD GREEN 3TB X2
    CPU CoolerSWIFTECH H240-X
    CaseNZXT H440
    Power SupplyTHERMALTAKE TOUGHPOWER XT PLATINUM 1275W
    Keyboard CORSAIR K70 RGB
    Mouse STEELSERIES KINZU V3
    Headset STEELSERIES 9H
    Mouse Pad STEELSERIES QCK+
    Headset/Speakers LOGITECH Z506
    OS WINDOWS 10 PRO AU
    Network RouterASUS RT-AC66U

    Join Date
    Jun 2012
    Reputation
    178
    Posts
    2,229

    install atk package. reboot. try playing with fn+f3/f4. normally after you flash the bios, the backlight is off by default.

    how did you fix it with usb stick? can you please share with us?

  6. #6
    New ROGer Array
    Join Date
    Sep 2013
    Reputation
    10
    Posts
    1

    Hello, I have a G75VW and I am having the EXACT same issue. PLEASE tell us how you fixed it! I am ready to throw this thing out of the window!

  7. #7
    New ROGer Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    1

    hi. i have same problem from yesterday... please give us a fix with usb or something else....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •