Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1
    ROG Guru: Yellow Belt Array broken pixel's Avatar
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    157

    Angry ASUS Advanced RMA is a joke, slow and archaic.

    I would like to state the advanced RMA service sucks. For one it takes forever for them to process the credit card info you have to fax to them, 48hrs. (EVGA instant 1.00 hold) Second the guy who initially sent out the form did not attached the form, so I had to call again to get the form sent to me. It has been 48 hrs since they have received my form and no word yet, I call ASUS they don't have any info on the credit card processing time for the hold. Slow, slow, slow.

    Note to ASUS- I started a thread about an NEX1500 power supply having some coil wine on the EVGA forums. The next day I had an email with instructions giving me a complimentary RMA service with PSU dropped ship with only a 1.00 hold on my credit card. Everything is on there website. Customer products, credit card info for drop ship etc.

    Good afternoon,

    I am following up with you regarding your EVGA NEX1500 power supply and your forum thread: http://www.evga.com/forums/tm.aspx?h...page=1#1936695.
    I can assist with a complimentary Advance RMA to replace the power supply and sine your current one works, minus the coil whine, we can eliminate any down time. Also I will request the new unit be tested 24 hours prior to shipping to ensure 100% functionality. If you would like me to start this up please verify your shipping address and send me a copy of the receipt from Micro Center. Also more details of the Advance RMA program can be found here: http://www.evga.com/support/ear/Default.asp.

    Thank you and have a nice day J



    As for ASUS advanced RMA procedure, it is slow, archaic and inefficient. I feel sorry for small bushinesses who have to use this so called advanced RMA service to get back up and running. So basically I will get my board replacement in over 1.5 weeks time with next day air selected. A few years ago I used the normal RMA process and relieved a placement in a week. WTF ASUS ADVANCED RMA.

    I am now officially an X ASUS customer. Out of all the mainboards I have owned in my life my most expensive board, an ASUS RE4 almost catches fire. I have never had a board almost catch fire, prob fired my memory too.

    One last rant why do you have to go to an external ASUS site to log into these forums? Again more inefficiency coming from ASUS.
    Last edited by broken pixel; 05-24-2013 at 04:22 PM.
    R4BE BIOS 0701 3930K @ 4.7GHz +0.005 XSPC Raystorm H20 block 16GB Corsair Dominator GT @ 2133MHz 9-11-10-27-1N SuperNOVA 1600 G2 XFX 290x XFX 290x 2x CL4100 240GB Intel RAID 0 Revo3 240GB XFI Win10 Enterprise TM HOTAS Warthog Slaw device BF-109 pedals TrackIR 5X270OC @ 2560x1440 @ 100Hz



  2. #2
    ‎‎‎‎‎‎‎‎‎‎ Array Gorman's Avatar
    Join Date
    Apr 2012
    Reputation
    90
    Posts
    627

    Complaining about ASUS support?

    Mate my laptop broke in november last year, and a few days ago I got it back finally in working order!

  3. #3
    ROG Enthusiast Array
    Join Date
    Apr 2012
    Reputation
    10
    Posts
    38

    Been there before. Remember this before you make your next product purchase. After dealing with their RMA process for 3 motherboards I remembered it when I bought 3 Titans. Even though the Asus versions were in stock I waited until EVGA had their product in stock because I wanted to be sure that I never had to deal with Asus RMA service again.

    But there are a lot of knowledgeable, helpful, and friendly people on these boards its just too bad the RMA service is lacking.
    MB: Rampage V Extreme
    CPU: i7 5930k - 4.6 @ 1.36
    RAM: 16gb G Skill 2666mhz - 15-15-15-35 2T
    PSU: Lepa 1600
    GFX: 4 x EVGA SC Titans
    Disks: 4 x Samsung 840 Pro
    Monitors: 3 x Rog Swift

    CaseLabs STH10 Custom Loop, 2040mm of Cooling Goodness

  4. #4
    ROG Guru: Yellow Belt Array broken pixel's Avatar
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    157

    Angry

    Check out what I received for my Advanced RMA. . . . . . . . . a ****ing dead board. . . . .

    Click image for larger version. 

Name:	IMG_20130531_142402_525.jpg 
Views:	39 
Size:	626.0 KB 
ID:	21104
    Click image for larger version. 

Name:	IMG_20130531_111954_903.jpg 
Views:	37 
Size:	376.0 KB 
ID:	21105

    I even spoke with the manager of the cubical slave center in Indiana about the delay. He assured me they need to check the replacement board before they ship. Huh! Must of been checked by a blind person? I got a board that had a bent heatsink sink and a broken off CMOS reset button. Way to go ASSUS you officially suck as a multi national company. **** YOU your customer service is the worst in hardware history.

    JmA
    R4BE BIOS 0701 3930K @ 4.7GHz +0.005 XSPC Raystorm H20 block 16GB Corsair Dominator GT @ 2133MHz 9-11-10-27-1N SuperNOVA 1600 G2 XFX 290x XFX 290x 2x CL4100 240GB Intel RAID 0 Revo3 240GB XFI Win10 Enterprise TM HOTAS Warthog Slaw device BF-109 pedals TrackIR 5X270OC @ 2560x1440 @ 100Hz



  5. #5
    ROG Guru: Yellow Belt Array broken pixel's Avatar
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    157

    double post
    Last edited by broken pixel; 06-12-2013 at 11:03 PM.
    R4BE BIOS 0701 3930K @ 4.7GHz +0.005 XSPC Raystorm H20 block 16GB Corsair Dominator GT @ 2133MHz 9-11-10-27-1N SuperNOVA 1600 G2 XFX 290x XFX 290x 2x CL4100 240GB Intel RAID 0 Revo3 240GB XFI Win10 Enterprise TM HOTAS Warthog Slaw device BF-109 pedals TrackIR 5X270OC @ 2560x1440 @ 100Hz



  6. #6
    AntiMatter Guru ROG Array chrsplmr's Avatar
    Join Date
    Jul 2011
    Reputation
    295
    Posts
    6,113

    broken pixel ... sorry to hear this .. there is simply no excuse for this.

    PM [private messege] cl-Albert ASAP with the particulars and a link to this thread ..
    see what can be done .. something, i trust. As it should be.c.

  7. #7
    ROG Guru: Yellow Belt Array broken pixel's Avatar
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    157

    7 more days and they still have not sent me a board back They have both of my boards now . chrsplm I can't find the Albert guy to PM?
    R4BE BIOS 0701 3930K @ 4.7GHz +0.005 XSPC Raystorm H20 block 16GB Corsair Dominator GT @ 2133MHz 9-11-10-27-1N SuperNOVA 1600 G2 XFX 290x XFX 290x 2x CL4100 240GB Intel RAID 0 Revo3 240GB XFI Win10 Enterprise TM HOTAS Warthog Slaw device BF-109 pedals TrackIR 5X270OC @ 2560x1440 @ 100Hz



  8. #8
    ASUS Reseller Array Shawnnepc's Avatar
    Join Date
    Jul 2012
    Reputation
    128
    Posts
    886

    Quote Originally Posted by broken pixel View Post
    7 more days and they still have not sent me a board back They have both of my boards now . chrsplm I can't find the Albert guy to PM?
    I just sent you a PM with some information, please get back to me as soon as you can.
    USA ASUS Reseller
    http://www.neteffectspc.com

  9. #9
    Super Moderator Array
    Join Date
    Jan 2013
    Reputation
    99
    Posts
    2,134

    Quote Originally Posted by broken pixel View Post
    7 more days and they still have not sent me a board back They have both of my boards now . chrsplm I can't find the Albert guy to PM?
    Just sent you a PM broken pixel (from cl-Albert), so if there are still problems and you haven't seen my message, please let us know. Thanks.

  10. #10
    AntiMatter Guru ROG Array chrsplmr's Avatar
    Join Date
    Jul 2011
    Reputation
    295
    Posts
    6,113

    worry not of this .. you have caught the eye of the best of the best .. whatever can be done .. will be.
    answer here .. PM .. those that have asked, then answer here, it will be seen.c.

Page 1 of 3 1 2 3 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •