Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    New ROGer Array
    Join Date
    Jun 2013
    Reputation
    10
    Posts
    3

    Exclamation Z87-A - bug in Asus Fan Xpert 2 - CPU fan is always at max speed.

    Hello,

    I've built a system with the Asus Z87-A motherboard. The system has 3 PWM case fans and the Arctic Freezer 13 as the CPU fan. The CPU fan is a 4-pin PWM fan as well.

    I have a problem with the Asus Fan Xpert 2 software (part of the AI suit 3). I can control the 3 PWM case fans, but I cannot control the CPU fan through the software. While the software is installed, the CPU fan is always running at max speed. The speed-temperature graph through which you control the fan speed at different temperatures is grey, and I cannot change the speed of the fan in any way. However, I can see the RPM of the fan.

    I've tried running the auto tuning from the xpert multiple times, but nothing changes. It does recognize the case fans and modifies their speed graphs, but the CPU fan remain at max speed all the time.

    I can control the CPU fan speed through the bios just fine, so its not a hardware issue. However, the Fan Xpert overrides the Bios settings, so even if I modify the fan speed at the Bios, as soon as I go to windows the CPU fan is back to full speed.

    I had to uninstall the fan xpert, and disable the asus fan control service, to prevent the CPU fan from spinning at max speed all the time. Now the fan's speed is dependent on the CPU temperature, as it should be.

    I tried updating the Bios to the latest version, as well as installing the latest version of the AI suit, but that didn't help.

  2. #2
    ROG Guru: Grand Master Array HiVizMan's Avatar
    Join Date
    Dec 2011
    Reputation
    354
    Posts
    25,742

    You can control the CPU fan via the bios.
    To help us help you - please provide as much information about your system and the problem as possible.

  3. #3
    New ROGer Array
    Join Date
    Jun 2013
    Reputation
    10
    Posts
    3

    Quote Originally Posted by HiVizMan View Post
    You can control the CPU fan via the bios.
    I know that, I wrote it in my post: "I can control the CPU fan speed through the bios just fine".

    The problem is that I cant control it through the Fan Xpert. Not only that, but I had to uninstall the fan xpert, and disable the asus fan control service because the CPU fan was forced back into full speed as soon as windows loaded. This means I cant use the fan xpert without having my CPU fan running at full speed.

    I hope Asus sees this thread and fixes this bug in the next update.
    Last edited by MikeL1; 06-30-2013 at 03:50 AM.

  4. #4
    ROG Guru: Grand Master Array HiVizMan's Avatar
    Join Date
    Dec 2011
    Reputation
    354
    Posts
    25,742

    Ok I hear you, will ask one of the guys here on the forum that use fanexpert to post up.
    To help us help you - please provide as much information about your system and the problem as possible.

  5. #5
    New ROGer Array
    Join Date
    Jun 2013
    Reputation
    10
    Posts
    3

    Just tested this again:

    I installed the fan xpert again (since I couldn't find the option to install/uninstall only part of the software, I had to uninstall all the performance utilities of the AI suite to uninstall the fan xpert), but did not run the fan tuning, and now I can control the fan again! But as soon as I run the auto tuning, I lose all control of the CPU fan, and it continues to spin at max speed at all times.

    The only way to gain control again is to reinstall the fan Xpert, and not run the fan tuning.

    Apparently the problem is in the auto tuning part of the fan xpert.

    TLDR, I can control the CPU fan perfectly until I ran the fan tuning in the fan xpert. If I ran the fan tuning, I lose all control of the fan through the fan xpert, and the fan always runs at max speed (regardless of any bios settings).

    Hope this will help deal with the bug.

  6. #6
    New ROGer Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    4

    Quote Originally Posted by MikeL1 View Post
    Just tested this again:

    I installed the fan xpert again (since I couldn't find the option to install/uninstall only part of the software, I had to uninstall all the performance utilities of the AI suite to uninstall the fan xpert), but did not run the fan tuning, and now I can control the fan again! But as soon as I run the auto tuning, I lose all control of the CPU fan, and it continues to spin at max speed at all times.

    The only way to gain control again is to reinstall the fan Xpert, and not run the fan tuning.

    Apparently the problem is in the auto tuning part of the fan xpert.

    TLDR, I can control the CPU fan perfectly until I ran the fan tuning in the fan xpert. If I ran the fan tuning, I lose all control of the fan through the fan xpert, and the fan always runs at max speed (regardless of any bios settings).

    Hope this will help deal with the bug.
    Any luck? since i'm having the same issue.

  7. #7
    untouched Array Praz's Avatar
    Join Date
    Apr 2011
    Reputation
    137
    Posts
    4,038

    The CPU fan setting needs to be on auto in the UEFI for PWM control. Is this how it is set?

  8. #8
    ROG Member Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    9

    Or you can try AISuite III 10054? On my Z87-A MB just Works fine.
    https://drive.google.com/folderview?...k0&usp=sharing

  9. #9
    New ROGer Array
    Join Date
    Sep 2013
    Reputation
    10
    Posts
    1

    I had the same problem, seems like the auto tuning does not go really well with arctic cooling CPU PWM fans. For me the cure was simple, just open the file:

    C:\ProgramData\ASUS\FanXpert\FanCalibrationData.xm l

    Locate the CPU Fan data and modify to sane values. My calibration data had max fan setting (2200 rpm) for 0%, I adjusted this to a more sane value (670 rpm). Also the values below needed adjustment, I used the settings below (your mileage may vary):

    <maxdutytokeepstill>20</maxdutytokeepstill>
    <mindutytokeepruning>20</mindutytokeepruning>
    <rpmofmaxdutytokeepstill>0</rpmofmaxdutytokeepstill>
    <rpmofmindutytokeepruning>670</rpmofmindutytokeepruning>

    Then you need to restart the ASUS fan service and also restart AI suite (or simply reboot the machine). The preset curves from ASUS (Silent, Standard and Turbo) was also not properly configured after auto-tuning, so you just need to configure a proper curve for yourself in the GUI (no need to modify the XML files for the fan curves)
    Last edited by mrmagg; 09-22-2013 at 03:06 PM.

  10. #10
    ROG Guru: Grand Master Array HiVizMan's Avatar
    Join Date
    Dec 2011
    Reputation
    354
    Posts
    25,742

    Thank mrmagg
    To help us help you - please provide as much information about your system and the problem as possible.

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •