Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    1

    G74sx Will not turn on! Fried or not? PLEASE HELP

    So I bought an ASUS g74sx on Newegg a few days ago. When I recieved it, everything worked fine. I booted it up intially, installed a few games and software, THEN......... I installed the Nvidia GTX 560m graphics driver which required a restart after the install. So when I restarted it, the computer turn off. When I pressed the on button, all the lights and fans turn on but nothing else. The screen was black and sat still (no hardrive churns no nothing.) I tried hard restarting it by holding the on/off button and starting it back up but still the same thing.

    Then I decided to do a static drain. (What everyone said to do on the internet.) I powered it off, remove the a/c cord and battery, and held down the on/off button for 45 seconds. (Light when on for a millisecond). After 45 seconds, I plugged it back in and reinserted the battery.= and hit the on/off button. NOTHING HAPPENED!! The laptop seem 100% dead! no lights no nothing. I tried the static drain multiple times over and nothing happens! I tried removing the HDD and RAM and reinserting it but still nothing....... WORST CASE SCENARIO IS THE MOTHERBOARD OR ANY OTHER INTERALS ARE FRIED OR BURNT. But I doubt any is fried because a small amount of static isnt enough energy to burn or melt anything. Please help!

    I know some of you are going to tell me to get it exchanged or something but I want to see what you guys can help me with before I attept to get it exchanged.

  2. #2
    ROG Guru: Green Belt Array Dreamonic PC Specs
    Dreamonic PC Specs
    Laptop (Model)ASUS GX800VH-XS79K
    MotherboardASUS GX800VHK (Intel CM238/IDA154) w/Custom BIOS
    ProcessorIntel Core i7-7820HK @ 4.8Ghz (+150mV) FCBGA 1440
    Memory (part number)64GB (PC4-22400) @ 18-18-18-38-53 (76.D305G.D060B)
    Graphics Card #1NVIDIA GeForce GTX 1080 8GB (GP104) OC @ +200/+800 w/Custom VBIOS
    Graphics Card #2NVIDIA GeForce GTX 1080 8GB (GP104) OC @ +200/+800 w/Custom VBIOS
    MonitorASUS PG348Q 34" 3440x1440 @ 100Hz w/G-SYNC (mDP-to-DP)
    Storage #13x Samsung 512GB NVMe SSD RAID0 (S316NY0HA00959)
    CPU CoolerASUS GX800VHK Water Cooling Dock
    CaseASUS GX800VHK Chassis
    Power SupplyASUS 2x 330W Power Adapter (AC 100~240V, 50/60Hz, 16.9A/19.5V)
    Keyboard ASUS ROG Claymore
    Mouse ASUS ROG Spatha
    Headset ASUS STRIX 7.1 Gaming Headset
    Mouse Pad ASUS ROG Whetstone
    OS Windows 10 Pro x64 / Arch Linux w/KDE Plasma
    Network RouterAsus ROG Rapture GT-AX11000 + GT-AC5300
    Accessory #1 Kensington 4 Port USB 3.0 Hub (K33978WW)
    Dreamonic's Avatar
    Join Date
    Dec 2012
    Reputation
    65
    Posts
    618

    How much of a charge did the battery have when you were in Windows?

    This is why I'm asking,

    I'm thinking the AC adapter might have went or possibly the power connector pin inside loosened up in the laptop. If the battery is completely drained with no power from the adapter, then you'll get no power at all.

    It was just coincidence that it happened during clearing, but from what I gathered the unplugging and plugging in again changed to no power at all on the second try, so my guess is the power jack pin broke or it's loose or possibly faulty adapter plug.

    I would verify it before wiggling the cord slightly around while pushing the power button down in short intervals.

    You could try purchasing a universal adapter to weigh out the adapter you are using as a possible culprit.
    Last edited by Dreamonic; 07-11-2013 at 12:13 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •