Results 1 to 10 of 1063

Threaded View

  1. #11
    New ROGer Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    4

    I flashed to the new BIOS (1203) day before yesterday and it has been a trainwreck. I have a 4770K, Maximus VI Formula, 32GB G.Skill TridentX DDR3-2666 with an Nvidia GTX 560. Have had no issues the past few months playing SWTOR, Batman Arkham City, Saints Row 3 or 4, etc. After flashing the new BIOS (I know that it's bad practice to dive in head first to new firmware, but I'm on vacation so have time to play around) my games were crashing randomly. I reconfigured every detail in the bios and reset it, still no go. It had been awhile since I had wiped my system so went ahead and did a full wipe, clean start.

    Still having the same issues with crashing. Each BSOD is a different error, but all seem to boil down to how the board is dealing with the RAM, which I am using an XMP profile to make work at 2666. I have tried manually configuring the RAM, also a bust. Will be rolling back to 1102 as I had no issues. I don't overclock or anything and don't use the AI Suite. I have Windows 8.1 and all drivers are up to date. The only erroneous item was the firmware update that seems to have borked how the board deals with the RAM. Anyway, thought I would give my experience here. I wish you better luck than I had if you flash to 1203.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •