Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    1

    Any problems with Vulcan Pro headset?

    I've searched around the web abit and some people are saying that the gaming noises and so are hearing through the mic on for example Skype / Teamspeak so is there the same problems still going on?

  2. #2
    ROG Guru: Yellow Belt Array adamsyes's Avatar
    Join Date
    Dec 2011
    Reputation
    11
    Posts
    169

    Yeah, that's an issue with Realtek sound cards and the mic. although it is fixable with tweaking speaker settings on sound card.

    sadly this occurs in certain models. some don't have this issue.

  3. #3
    ROG Member Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    9

    I got some scraping sound in skype when i used them, i think it was from the mic mute interface, so i brought them back to the shop and got a pair of new one, since then it working fine

    Some thing is curios also, the first pair had battery in them, is it supposed to be delivered with battery?? Or could it be a replacement pair i bought at first.
    CM HAF XB MidTower | Intel i7-4770K | MAXIMUS VI GENE | EVGA GeForce GTX 780 3GB PhysX CUDA | Corsair Dominator DDR3 1866MHz 16GB | 2 Samsung SSD 840 PROSeries 256GB 2.5" | Lite-On DVD±RW Writer | Corsair CX 750M| 2 CM Blade Master 80mm Fan | CM MegaFlow 200 Red LED | CM SickleFlow 120mm Red LED | Combo mPCIe, Intel Centrino 6235 advanced |Asus 24" LED VN247H| Win 7 HP.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •