Page 4 of 4 FirstFirst ... 2 3 4
Results 31 to 33 of 33
  1. #31
    ROG Enthusiast Array Kelusion PC Specs
    Kelusion PC Specs
    Laptop (Model)Asus ROG G750JZ
    MotherboardASUSTeK COMPUTER INC. G750JZA
    ProcessorIntel® Core™ i7 2.5GHZ - 3.5GHZ 4710HQ Processor
    Memory (part number)Samsung M471B1G73QH0-YK0 - 32GB DDR3L SDRAM
    Graphics Card #1NVIDIA® GeForce® GTX880M 4GB GDDR5 VRAM (Auto-Overclocked)
    Sound CardRealtek High Definition Audio
    MonitorSasmung 55' Smart U9000, Samsung Syncmaster S24B300
    Storage #1512GB SSD
    Storage #21.5 TB HDD 7200 RPM
    CPU CoolerStock
    CaseStock
    Power SupplyStock
    Keyboard Corsair RGB K70 (2014)
    Mouse Logitech G502 Proteus Core Gaming Mouse
    Headset Beats Studio Pro
    OS Windows 8.1 Pro - 64Bit
    Network RouterCisco
    Kelusion's Avatar
    Join Date
    Jul 2014
    Reputation
    10
    Posts
    74

    I have a JZ, and have no problems with any USB 3.0 Ports as stated here with it, nor have it in my other JS model too. However a friend actually had the right side one's having the same problem as some described above me, updating to the latest chipset resolved that from the Asus Support Page, so would advise users to try the same in case if helps, one thing to add he had Windows 8, never upgraded to 8.1, so am pretty much sure, much issues are being cleaned over by being on Windows 8.1 and having the chipset drivers updated from the latest Asus Support Page installed.

    http://support.asus.com/download.asp...l3Rpr80XDgQJbl
    Where to find latest Asus Rog G750/751 drivers?

    Please use search in the forums, there might be alot of threads which have similar answers to what you are looking for!

  2. #32
    ROG Member Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    18

    I noticed this problem with my Asus G75VX-TS72 64 Bit OS and immediately contacted ASUS with very little support. They wanted me to reformat the hard drive first :-) ... then they wanted me to return the Laptop in a new box and would not assure me that I would get the same machine back. This is my first and last ASUS machine. The machine is slow anyway for 16 GB of RAM and a 3 GB grahics card... I expected much more and I don't even use it for gaming, just for graphics and video work. My 8GB Dell XPS is just as fast.

  3. #33
    New ROGer Array
    Join Date
    Feb 2014
    Reputation
    10
    Posts
    2

    I too have a USB3 issue with my G750JX Win8.1, I emailed customer support and they are asking me to send the laptop off to a service centre. I'm in Ireland and I don't think there is one here and I use the machine for work so it would be a big inconvenience to have to ship the laptop abroad if there is a potential software/driver/bios related solution floating around out there.

    I have BIOS v 209 on my laptop. I've installed the latest chipset driver I could find which is Version V9.4.0.1022 (perhaps there is another better one somewhere else on the web)

    My Seagate USB 3 mass storage drive is definitely working as I can access it from several other PCs. It was showing up initially on my G750 but then I noticed it would sometimes disappear from explorer. Eventually it was gone completely and I could not get it to detect on the g750 on any USB port! (when plugged into any USB port on the laptop the drive spins up but will not show up in windows explorer)

    One user said he disabled XHCI pre boot mode in the BIOS and that had fixed his problem.
    I tried this and the drive does show up again but the access speed appears to be on the slower side of a USB2 drive (Sequential Read: 27.089 MB/s Sequential Write: 20.308 MB/s via crystaldiskmark). At least I have access but it defeats the purpose of having bought a USB3 drive and a laptop that is sold as supporting USB 3.

    Can anyone suggest something software/driver/bios related that I haven't tried? Can provide other detailed info on request.

    Hope someone on here can help me trouble shoot this.
    Last edited by ctasker; 10-27-2014 at 01:06 PM.

Page 4 of 4 FirstFirst ... 2 3 4

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •