Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    2

    Connection issues with asus g75vx laptop

    (this is my first post so bear with me here )in the last 2-3 months iv'e been having a connection issue, that has me frustrated. I usually play a lot of multiplayer games but every time i play it ALWAYS LAGS! I thought it was temporary prior to the games i play but it has been like this for months i cant take it! it happens to me on the browser too, for example when i watch a video it always crashes and it takes sooo long to load, same thing for the photos, it's not my internet connection because iv'e connected to different places and it's the same problem, triead to update my drivers but it the driver stays the same *sigh i really dont know what to do if it's the wirelees that is damaged on the laptop, please i need help!

  2. #2
    New ROGer Array
    Join Date
    Oct 2012
    Reputation
    13
    Posts
    2,441

    you just have problem with wlan, cable is no problem? what driver are you install from asus support site or vander driver? if not driver problem, i think you can try press f9 to resote OS, if not help, you send to asus service center to check it.

  3. #3
    New ROGer Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    2

    umm i dont understand the wlan thingy, but my driver is broadcom 802.11ac, but the driver date is 12/5/2012(i dont know if it's outdated) i tried to update it but it says that is up to date, but when i check asus's site there's a broadcom driver that's from 2013 , i downloaded and instaled it but nothing happened, haven't tried with a cable

  4. #4
    New ROGer Array Zygomorphic's Avatar
    Join Date
    Mar 2012
    Reputation
    176
    Posts
    4,761

    I would try uninstalling the driver from your machine (Device Manager) and rebooting the computer. This will allow Windows to automatically find and identify the appropriate driver. If Windows doesn't autoinstall anything, then try manually installing the latest vendor driver.
    I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
    http://rog.asus.com/forum/group.php?groupid=16
    We now have 178 people whose systems will not break! Yippee!
    LINUX Users, we have a group!
    http://rog.asus.com/forum/group.php?groupid=23

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •