Results 1 to 3 of 3
  1. #1
    ROG Member Array
    Join Date
    Jun 2013

    Cool Fix Nvidia driver update

    I just tried to download the newest Nividia driver version supported by Asus (V9.18.13.1188 )

    Or from direct link:

    After installing the driver + Geforce Experience, the Geforce Experience automatically updated the driver to the lastest version (327.23). Surprisingly it works now.

    Click image for larger version. 

Name:	Untitled.jpg 
Views:	0 
Size:	65.9 KB 
ID:	26596

    Click image for larger version. 

Name:	Untitled1.jpg 
Views:	1 
Size:	131.8 KB 
ID:	26593

    So I think Asus has fixed the update issue of Geforce Experience from the version V9.18.13.1188.

    Has anyone else tried it and succeeded?
    Last edited by demonz500; 09-22-2013 at 11:24 AM.

  2. #2
    ROG Enthusiast Array
    Join Date
    Sep 2013

    Nah, its a newly released driver by Nvidia.... New official driver that is.
    I hate Geforce Experiance.... it always downgrades the qualitys of all my games f that! Ill decide myself whats best for me.

    Anyway, i just downloaded the (latest) official driver from the Nvidia website as i have done for years and years to come.

    Installed great like it should. So Please dont install a Geforce Wanksperiance only if u need drivers.......

    Previous Beta driver installed great aswell... only previous official driver gave problems with GTX 770M.

    On another note, that was the first, and only time i ever had this issue with Nvidia.. ever.. And i have had Nvidia cards from Ti4200 Lmao till now.

    EDIT: So that u know... u dont need, or want Geforce Experiance Bullcrap.

    Just check de official Nvidia site every week or now and then, and just search for Drivers 700M series? I dont need a program for me to tell me that there might be somethng new? And its also autostart intergraten in windows? U Really want that? I wonder why anybody would want that

    Have a nice sunday all!!
    Last edited by BlapX; 09-22-2013 at 02:38 PM.

  3. #3
    ROG Guru: Yellow Belt Array Flea0's Avatar
    Join Date
    Jun 2013

    hmm 3d stopped working ingame for me. the demo app works but it doesn't actually enable itself when i launch a game.
    ASUS G750JX -- i7-4700 - 16GB - 128GB 840 PRO SSD + 1TB HDD - Nvidia GTX 770M - 120Hz 3D glossy display

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts