Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 21
  1. #11
    ROG Member Array
    Join Date
    Sep 2012
    Reputation
    10
    Posts
    5

    I played BF4 for the first time today. I used the default auto settings, full screen on the G75's own display. I didn't measure FPS but the frame rate felt OK. My rig is a G75V with the 3610QM i7 and GTX660M, not overclocked.

    *update* I now measured the FPS and it stayed between 35-50 most of the time.
    Last edited by Perret; 11-02-2013 at 11:36 AM.

  2. #12
    ROG Enthusiast Array AgenBlaze's Avatar
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    43

    Feels laggy until I lower the shadowmap. I heard it runs better on win 8.1
    I have the G75VW with 670M and I7-3630QM
    8GB ram

  3. #13
    New ROGer Array
    Join Date
    Jun 2013
    Reputation
    10
    Posts
    1

    G75VX
    12GIG
    670mx 3gb OC 135/1200 max temp 68 degree C.

    60-65 FPS on medium

    I won't play at lower framerate then 60 fps so no HIGH

    i need a Desktop
    AMD FX-8350 / r9 290x combo

  4. #14
    ROG Member Array Bosch164's Avatar
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    20

    I have the G75VX with GTX 670mx, 16 GBs ram, and a Core™ i7 3630QM. I've been outputting the video onto a 50 inch Sony tv on ultra settings and still getting fluent gameplay online with 64 players. I cant say the fps since MSI Afterburner is not showing any on screen display icons in game and I don't have any other way of showing fps.

  5. #15
    ROG Guru: White Belt Array UnAimed's Avatar
    Join Date
    Feb 2013
    Reputation
    13
    Posts
    93

    I'm playing on High settings on 1080P and getting 30-35 FPS on my G55VW

  6. #16
    ROG Member Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    11

    I do exactly the same as dubonfire OC/Settings and i get the same result 670mx, i can not play if i drop below 60FPS

  7. #17
    ROG Enthusiast Array
    Join Date
    Sep 2012
    Reputation
    10
    Posts
    46

    Quote Originally Posted by UnAimed View Post
    I'm playing on High settings on 1080P and getting 30-35 FPS on my G55VW
    Is it playable? I mean with 30-35FPS do you notice any lag?

  8. #18
    New ROGer Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    3

    I get 30-35 on Ultra settings on the G75VW, and some people seem to think theres some huge difference between 30 and 60 but I see none. Atleast not significantly. I know when a game lags cause my computer can't handle it, but I have not experienced that with 30 fps. And I lower the settings and get 100 I think it was, or close to it I didn't notice a bit of difference except the game was uglier.

  9. #19
    New ROGer Array
    Join Date
    Nov 2012
    Reputation
    10
    Posts
    2

    I am currently playing Battlefield 4 on my G75VW with full resolution and Ultra settings and it's been absolutely seamless. No framerate loss, no video lagging and mind you, I'm on the campaign portion of the game and haven't tried multiplayer yet but so far, it's been a glorious time. One key note the driver update made go from absolutely unplayable to seamless. The driver update was version 331.65. You MUST update to this version in order to play this with any remote playabilty.

  10. #20
    ROG Guru: White Belt Array UnAimed's Avatar
    Join Date
    Feb 2013
    Reputation
    13
    Posts
    93

    Quote Originally Posted by adham_dehe View Post
    Is it playable? I mean with 30-35FPS do you notice any lag?

    No lag, 30FPS is perfectly acceptable, all current gen consoles run on 30FPS and movies run on 24FPS. You won't have any issues.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •