Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    May 2013
    Reputation
    10
    Posts
    2

    G55 Not able to run games on best settings

    Hello tech gurus. Have an issue with my G55VW gaming laptop. I don't really game, just watch movies on it and use it for AutoCad and Solid Works type stuff. I recently have been interested in playing some games, so I got a couple and I am having very annoying stuttering, low fps, etc. I ran a couple benchmark test I found through Google and was surprised at how terrible my laptop was performing. On one test (#d Mark free version) at the end it didn't even rank in the "gaming laptop" scale it was so bad. On another free benchmark program (Haven) it showed consistent low fps (12-25) even when just running on "high" and not "ultra" or whatever.

    My questions to you would be does this sound like what you expect, or do you think I have something screwed up? I'm not a tech guru, far from it, so I am not sure what I should be looking into. My computer specs are as follows:

    Core i7-3610QM CPU @ 2.3Ghz
    Ram: 12 GB
    Nvidia Geforce 660M 2GB video card
    Runing Windows 7

    Any direction you guys could offer would be most appreciated.

    Thank you!

  2. #2
    imMortal Kombatant Array Myk SilentShadow PC Specs
    Myk SilentShadow PC Specs
    MotherboardASUS Rampage IV Formula
    ProcessorIntel i7 3930K
    Memory (part number)8GB Corsair XMS3 1600
    Graphics Card #1ASUS Radeon 7970 3GD5
    Sound CardROG Xonar Phoebus
    MonitorSamsung SyncMaster SA300
    Storage #1Corsair Neutron 128GB
    Storage #2Seagate 2TB
    CPU CoolerCorsair A50 Pro Air Cooler
    CaseBitFenix Merc Alpha
    Power SupplyThermaltake Litepower 700W
    Keyboard Alienware TactX Keyboard
    Mouse Tesoro Gandiva H1L
    OS Win7 Ultimate x64
    Myk SilentShadow's Avatar
    Join Date
    Jan 2012
    Reputation
    266
    Posts
    5,241

    Are you gaming/running the bench marks on battery, or is it plugged in at all times?

  3. #3
    New ROGer Array
    Join Date
    May 2013
    Reputation
    10
    Posts
    2

    It has been plugged in for every test except for one, I wanted to see if there was a difference. If there was it wasn't noticeable.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •