Page 86 of 89 FirstFirst ... 36 76 84 85 86 87 88 ... LastLast
Results 851 to 860 of 881
  1. #851
    New ROGer Array
    Join Date
    May 2015
    Reputation
    10
    Posts
    2

    Unhappy Help Please

    Hi everyone, got my G750JX-CV030H on Mac OS X El Capitan 10.11.6, unfortunately, I managed to get everything working except the sound card, can someone help me ?
    I'm going mad, it's been almost a week since I try to get the ALC282 working here haha..

    Thanks everybody !

  2. #852
    New ROGer Array
    Join Date
    Jun 2014
    Reputation
    10
    Posts
    1

    Quote Originally Posted by pcfr33k View Post
    I updated the Patch kext the info.plist should be there? Been real busy not checking in but I have 10.11.6 working fine with those files I uploaded for 10.11.4. I'll look but you have to place that kext in /library/extensions instead of the EFI/kexts but I will verify!!

    Its there but make sure you use the correct clover config file because it contains the rest of the needed binary hacks to make the audio work.

    Edited: 8-28-2016

    Sorry I mislabeled the folder with the audiopatch. I had it 10.10.4 that should have been 10.11.4 and on up. It works up to 10.11.6 but not tested on Sierra Beta.
    Tried using the PatchedHDA in both L/E and S/L/E. Also have vanilla AppleHDA in S/L/E but still can't detect sound card in 10.11.6.

  3. #853
    ROG Member Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    12

    Question

    Does anyone have a solution for working sound, trackpad and keyboard in Sierra/OSX 10.12? I have installed but Elmydinesh PS2 kext and Patched appleHDA don't work as was in El Cap 10.11.6 ... Any clues?

  4. #854
    ROG Guru: Yellow Belt Array
    Join Date
    Jun 2014
    Reputation
    11
    Posts
    183

    Quote Originally Posted by Evablazer View Post
    Does anyone have a solution for working sound, trackpad and keyboard in Sierra/OSX 10.12? I have installed but Elmydinesh PS2 kext and Patched appleHDA don't work as was in El Cap 10.11.6 ... Any clues?
    I have everything working perfectly in Sierra 10.12.1. I have 5 of these laptops so I keep up but have not updated my dropbox yet. The patchAppleHDA.kext must go in /library /extensions and use speedy kext for Sierra to fix permissions. Speedy kext will install kexts as well but it will want to install into /S/L/E so manually copy it into /S/E.

    For clover to get wifi to work there are new binary patches and same for audio they need to be changed. I will upload my config and link it here for now until I complete my update. You will need the latest version of clover installer and you need all of the new files it installs in Drivers64UEFI and make sure you instal HFSPlus UEFI also or none of your drives will be seen on the clover boot. Vbox will work to but its slower.

    Use the same DSDT, USB injector and legacy GPU kext I have in my drop box files listed in my signature further below. Its a must to have these files or it will not boot or work properly. They need to be located in your EFI clover directory in proper folders which is explained in the dropbox link in my signature.

    New Clover config and just put PatchAudio kext in here for convenience:

    https://www.dropbox.com/s/gsrtao520z...onfig.zip?dl=0

    Speedy Kext a must have:

    http://www.insanelymac.com/forum/top...speed-edition/


    Clover Configurator a GUI to modify your clover config file but some say it can be buggy. Not for me so far. Use this to install the latest clover versions and to view the changes I made in kernel and kexts patches section:

    http://mackie100projects.altervista....-configurator/

    Sorry one more link ALXethernet although it works in Sierra, the system reboots when it starts to sleep and the issue is due to the ethernet driver, ALXethernet kext. Go to this link and download the e220x kext and place that into clover/kexts, remove the ALXethernet. This driver may also work in Yosemite and El Capitan but I have not tested that yet.

    http://www.insanelymac.com/forum/top...-killer-e220x/

    Eventually I will update my dropbox link and clean it up somewhat and create a text file on how to install for Yosemite, El Capitan and Sierra. Also in the plans is to get all the DSDT patches for you in case your system is somewhat different you can apply the patches yourself to your own DSDT using Rehabman's version of MacIASL. Google it!!

    You will need Emly's touchpad, Asus FN keys and possible the EAPD fix for audio after sleep/wake. Codec Commander also works for that prepared by Rehabman. Osxlatitude will reuqire you to register in order to download there drivers. For the FN Keys I made some modifications to the plist for LCD and backlight so I get 16 levels, also turining on a few features auto backlight off etc etc. You can do this yourself using Plist Editor Pro. Google for it.

    Links:

    Touchpad:

    http://forum.osxlatitude.com/index.p...iver-mac-os-x/

    FN Keys:

    http://forum.osxlatitude.com/index.p...sus-notebooks/

    EAX audio driver:

    EAPDFix or Codec Commander:

    EAPDFix:

    http://forum.osxlatitude.com/index.p...e-after-sleep/

    Codec Commander:

    https://bitbucket.org/RehabMan/os-x-...nder/downloads
    Last edited by pcfr33k; 11-13-2016 at 05:47 PM.

  5. #855
    ROG Guru: Yellow Belt Array
    Join Date
    Jun 2014
    Reputation
    11
    Posts
    183

    Quote Originally Posted by Hackirche View Post
    Hi everyone, got my G750JX-CV030H on Mac OS X El Capitan 10.11.6, unfortunately, I managed to get everything working except the sound card, can someone help me ?
    I'm going mad, it's been almost a week since I try to get the ALC282 working here haha..

    Thanks everybody !
    You need my DSDT or the Audio patch in DSDT or it will not work along with my clover file which has the binaries patched for AppleHDA. Look at my signature and the post I prepared above.
    Last edited by pcfr33k; 11-05-2016 at 02:56 PM.

  6. #856
    ROG Guru: Yellow Belt Array
    Join Date
    Jun 2014
    Reputation
    11
    Posts
    183

    Quote Originally Posted by Evablazer View Post
    Does anyone have a solution for working sound, trackpad and keyboard in Sierra/OSX 10.12? I have installed but Elmydinesh PS2 kext and Patched appleHDA don't work as was in El Cap 10.11.6 ... Any clues?
    See my posts above. Its working!! You have to have my DSDT or add the section for Audio in my DSDT to your DSDT and must have the clover config because it has the AppleHDA binary patches to make the card work.

    I don't understand why people are having a hard time getting this to work. I have it working since Yosemite all the way up until now in Sierra 10.12.1. You not using my files or have them placed incorrectly. Make sure you use Speedy Kext to fix permissions listed in a post above.

    Edited:

    Also make sure you use the Clover config I have for either Yosemite, El Capitan or Sierra whichever version you are on. Yosemite Clover config.plist which contains the audio binary patch will not work in El Capitan or Sierra and same thing if your on El Capitan that CLover config.plist will not work on Yosemite or Sierra. Use Clover Configurator and look in the section Kernel and kext patches you will see AppleHDA patches, see how the hex code is different in each OSX version.

    PatchAudio kext will pretty much remain the same from Yosemite to El Capitan to Sierra. Only thing you must do is use the Clover Config I have for the OSX version you are on.
    Last edited by pcfr33k; 11-06-2016 at 03:06 PM.

  7. #857
    ROG Member Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    12

    Quote Originally Posted by pcfr33k View Post
    See my posts above. Its working!! You have to have my DSDT or add the section for Audio in my DSDT to your DSDT and must have the clover config because it has the AppleHDA binary patches to make the card work.

    I don't understand why people are having a hard time getting this to work. I have it working since Yosemite all the way up until now in Sierra 10.12.1. You not using my files or have them placed incorrectly. Make sure you use Speedy Kext to fix permissions listed in a post above.

    Edited:

    Also make sure you use the Clover config I have for either Yosemite, El Capitan or Sierra whichever version you are on. Yosemite Clover config.plist which contains the audio binary patch will not work in El Capitan or Sierra and same thing if your on El Capitan that CLover config.plist will not work on Yosemite or Sierra. Use Clover Configurator and look in the section Kernel and kext patches you will see AppleHDA patches, see how the hex code is different in each OSX version.

    PatchAudio kext will pretty much remain the same from Yosemite to El Capitan to Sierra. Only thing you must do is use the Clover Config I have for the OSX version you are on.
    I have patchaudio in L/E, I have a work config file, latest Clover and Wifi + PS/2 working, only sound and the correct values for my config.plist are still a challenge
    Still stuck on 10.11.6

  8. #858
    ROG Guru: Yellow Belt Array
    Join Date
    Jun 2014
    Reputation
    11
    Posts
    183

    Quote Originally Posted by Evablazer View Post
    I have patchaudio in L/E, I have a work config file, latest Clover and Wifi + PS/2 working, only sound and the correct values for my config.plist are still a challenge
    Still stuck on 10.11.6
    One more thing make sure you use my DSDT because it also has the Layout ID patch. Try this to see if this is why it is not working. In CLover COnfigurator look to the left for Device then under Audio field put a 3 there. Inject is also right under that field. Click save then reboot see if that works. If it does then you don't have the layout ID in your DSDT that prove's it, but you can use clover to inject the layout ID as you have just done. If it still does not work you may not have the right binary patch in Clover. Check my dropbox for the Clover file for El Capitan. I have to look at it again to make sure it has the correct binary.

    If it still does not work run this app:

    http://www.insanelymac.com/forum/fil...lehda-patcher/

    Run that and under laptop choose ALC282 v1 or v2 doesn't matter. It will create a MironeAudio folder on the desktop find the clover folder under the 10ec0282 folder and open the config.plist with Clover Configurator and look under kernel and kext patches and check the binaries hex patches make sure they match if not change them in your config and test again!!

    Edited:

    Check Bios settings, make sure USB is not set to smart detection but auto instead, actually if that is not set correctly it won't boot in Yosemite, El Capitan or Sierra. What model do you have? Is it the G750JX? If not your audio codec may be different. I wish people would put there model number(s) in their signature. Did your audio ever work with my files? If after trying everything I have posted your out of luck, so only thing I can suggest is links below work great on a couple my Desktops that don't support any audio or possibly try Bluetooth audio powered speakers, or the second link, try VoodooHDA. If you do try VoodooHDA you MUST get AppleHDA disabler or you will get kernel panics. You can put VoodooHDA and AppleHDA disabler in /clover/kexts. There is also a Prefpane, which should be in found in that thread that must be installed for your audio mix settings. Search for Apple HDA disabler its easy to find.

    https://www.amazon.com/Logitech-S150...audio+speakers

    http://www.insanelymac.com/forum/top...voodoohda-289/
    Last edited by pcfr33k; 11-08-2016 at 02:24 PM.

  9. #859
    ROG Member Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    12

    Quote Originally Posted by pcfr33k View Post
    One more thing make sure you use my DSDT because it also has the Layout ID patch. Try this to see if this is why it is not working. In CLover COnfigurator look to the left for Device then under Audio field put a 3 there. Inject is also right under that field. Click save then reboot see if that works. If it does then you don't have the layout ID in your DSDT that prove's it, but you can use clover to inject the layout ID as you have just done. If it still does not work you may not have the right binary patch in Clover. Check my dropbox for the Clover file for El Capitan. I have to look at it again to make sure it has the correct binary.

    If it still does not work run this app:

    http://www.insanelymac.com/forum/fil...lehda-patcher/

    Run that and under laptop choose ALC282 v1 or v2 doesn't matter. It will create a MironeAudio folder on the desktop find the clover folder under the 10ec0282 folder and open the config.plist with Clover Configurator and look under kernel and kext patches and check the binaries hex patches make sure they match if not change them in your config and test again!!

    Edited:

    Check Bios settings, make sure USB is not set to smart detection but auto instead, actually if that is not set correctly it won't boot in Yosemite, El Capitan or Sierra. What model do you have? Is it the G750JX? If not your audio codec may be different. I wish people would put there model number(s) in their signature. Did your audio ever work with my files? If after trying everything I have posted your out of luck, so only thing I can suggest is links below work great on a couple my Desktops that don't support any audio or possibly try Bluetooth audio powered speakers, or the second link, try VoodooHDA. If you do try VoodooHDA you MUST get AppleHDA disabler or you will get kernel panics. You can put VoodooHDA and AppleHDA disabler in /clover/kexts. There is also a Prefpane, which should be in found in that thread that must be installed for your audio mix settings. Search for Apple HDA disabler its easy to find.

    https://www.amazon.com/Logitech-S150...audio+speakers

    http://www.insanelymac.com/forum/top...voodoohda-289/
    Please help me with a fully working configuration.plist for clover in Sierra. I keep having kernel panics and verbose boot ends in white circle with diagonal line. El Capitan is stable as always

    Regards*

  10. #860
    ROG Guru: Yellow Belt Array
    Join Date
    Jun 2014
    Reputation
    11
    Posts
    183

    Quote Originally Posted by Evablazer View Post
    Please help me with a fully working configuration.plist for clover in Sierra. I keep having kernel panics and verbose boot ends in white circle with diagonal line. El Capitan is stable as always

    Regards*
    Which model do you have. I have asked you to post that. I linked a Sierra Config up a couple posts grab that one. If your model is not exactly as mine then there could be issues if your using my DSDT.

    Another helpful link if you don't want to use Clover Configurator you can use a web based version of it:

    http://www.insanelymac.com/forum/top...er-editor-cce/
    Last edited by pcfr33k; 11-09-2016 at 06:11 PM.

Page 86 of 89 FirstFirst ... 36 76 84 85 86 87 88 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •