Results 1 to 6 of 6
  1. #1
    New ROGer Array
    Join Date
    Sep 2013
    Reputation
    10
    Posts
    1

    Razer tiamat 7.1 problems

    So i just got the Xonar phoebus solo 7.1 soundcard, and i plugged my razer tiamat 7.1 in and the sound of the headset currently is just ****. now this is my first 7.1 headset that i own and im pretty confused because i have never worked with any 7.1 sounds before. i have played around with the flex bass in the drivers. the sound for music becomes pretty okay but the sound in a game (i have only tried LoL and sc2 so far) is just terrible, sc2 is "okay" but in LoL the sounds just become TERRIBLE.
    any help would be great. Thanks for reading!

  2. #2
    ROG Member Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    8

    tiamat have small drivers and are dependent on subwoofer, so if source audio is not great, like bf3 it will sound worse then on mid range headset, look at it like this, bad sound in game with tiamat is like watching bad divx movie on 55 inch screen

  3. #3
    ROG Guru: Orange Belt Array
    Join Date
    Oct 2012
    Reputation
    12
    Posts
    272

    It works fine with my 5.1 kave. The general problem with true surround headsets is that they sound like a pair of tin cans in stereo, one way to avoid that is to use surround max and make sure games are set perfectly to use 5.1 or 7.1 setups.

  4. #4
    ROG Guru: Yellow Belt Array heichalot PC Specs
    heichalot PC Specs
    MotherboardRampage V Extreme
    Processor5930k
    Memory (part number)HyperX DDR4 16Gb
    Graphics Card #1Asus Ares II - 789
    Graphics Card #2Asus Ares II - 789
    Graphics Card #3Asus Ares II - 179
    Graphics Card #4Asus Ares II - 179
    Sound CardBose Companion 5
    Monitor60LN54000
    Storage #1Black 240Gb SSD
    Storage #2Red 120Gb SSD
    CPU CoolerNZXT x60
    CaseHafX
    Power SupplyAX1200
    Keyboard Vengeance K95
    Mouse G500
    Headset Sennheiser HD600
    OS 8.1 Pro 64-bit
    heichalot's Avatar
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    134

    Quote Originally Posted by ferahn View Post
    So i just got the Xonar phoebus solo 7.1 soundcard, and i plugged my razer tiamat 7.1 in and the sound of the headset currently is just ****. now this is my first 7.1 headset that i own and im pretty confused because i have never worked with any 7.1 sounds before. i have played around with the flex bass in the drivers. the sound for music becomes pretty okay but the sound in a game (i have only tried LoL and sc2 so far) is just terrible, sc2 is "okay" but in LoL the sounds just become TERRIBLE.
    any help would be great. Thanks for reading!
    sorry to hear that,
    phoebus sound quality is fine (regardless of so many problems it has).
    While tiamat 7.1 is probably the worst headset IMO. its decent for gaming, and really bad for music.

    I tried enabling speaker fill for music, enchanced bass, srs wow, etc
    it is just bad...

    if you want a better gaming headset, try razer megalodon.

    if you want a good sound quality headset, well that depends on your budget & ear (audiophile) ofcourse
    Aristo, an Enthusiast Gamer
    Play on Steam? Add me http://steamcommunity.com/id/heichalot/

    "Everytime my setting passes HyperPi or Prime95, I get a boner"
    -me


    LG 60UN5400 Asus Rampage V Extreme Intel i7-5930k Haswell-E Kingston HyperX DDR4 2800 16Gb (4x4)
    Asus RoG Ares II no. 789 & 179 Corsair AX1200 NZXT Kraken x60 Bose Companion 5 Sennheiser HD600 Logitech G13 Corsair K95 Logitech G500 Logitech HD Pro C920 Coolermaster Haf X

  5. #5
    ROG Member Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    18

    You have to configure the sound card and ensure youve plugged the tiamats cables into the right ports on the sound card. Additionally for the Phoebus to work properly you have to disable your motherboard sound chip via bios and uninstall the sound chips drivers.

    Once the above has been done you next have you ensure windows and the sound card are outputting at 7 channel 24 bit 192khz not xear 7.1
    .
    To configure windows sound
    right click on the speaker icon in the system tray select Playback Devices
    in the menu that appears right click on your headset and select properties
    Next in the new menu click the tab labeled Advanced
    From here youll will change your default format to 7 channel 24 bit 192khz (Studio Quality)

    Do the same thing as above but at the start select recording devices to set your micrphone sound quality that others will hear. That optimal best setting is 2 channel 24 bit 192khz

    The other thing to note is the music files youre listening, what is their quality? AAC vs MP3 is night and day for example, so if youve downloaded yours a while ago "for free" they might not be that great of quality to begin with. To compare use Itunes to preview songs vs the ones you have to make sure they sound right.

  6. #6
    ROG Guru: Orange Belt Array
    Join Date
    Oct 2012
    Reputation
    12
    Posts
    272

    Nuh uh, 24bits @ 48Khz, going above that is useless.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •