Results 1 to 3 of 3
  1. #1
    Roach
    Guest

    RMA did more damage than good.

    Well I posted on here a few days back about some GPU problems I was having with my G73jh. I ended up RMA'ing it, and to my surprise I got a call 2 days later saying it was repaired, though when I got it home and went to test it out I wasn't surprised it had taken so little time.

    To start off I couldn't even use the trackpad, it would jump all over the place so I made sure I had all the latest "fixes" for it installed, it almost seems like the left key is actually getting stuck down, as if I click the right key the problem seems to go away momentarily. When searching for answers for this online I found that the spacebar wouldnt work if it was clicked on the left side, but would work in the middle or the right side.

    I gave up trying to fix those problems and went to reinstall the GPU drivers (full clean install, also updated Intel INF) I went to restart the machine after running the ATI Crap Cleaner, only to find again that it wouldn't restart (it would go through the shutdown process and the screen would turn off, but it wouldn't power down, the fans stayed on and the power & PFG buttons would stay lit) I had to force a shutdown by holding the power button. When I turned the machine back on it would not post, I had to force shutdown again, remove the battery pack and hold the power button down for 30 seconds before I could get it to boot.

    When I did get it to boot I went into the bios only to find that there was apparently no version of vbios installed. I thought maybe it had something to do with the drivers not being installed, so I continued with trying to reinstall them, but it would always hang when detecting the device so I went through HW Manager and HWINFO64 only to find the 5870m was not listed at all.

    I thought maybe the OS had screwed up something severe so I did a system recovery from the recovery dvds I made, and found that the bluray drive would randomly vibrate and make a horrible grinding noise, also the longer it stayed on the louder the fans got (not from ramping up, they almost sounded like the impellars were coming loose.

    The recovery seems to have made no difference what so ever, and I've currently got a notebook that is more screwed up than when I had it RMA'd. Really not impressed with the work that was done on it. Is there any way that I could get Asus to swap the unit over for a functioning one, I am currently unable to complete jobs at work due to it being out of action, the gaming side I can do without.

  2. #2
    TeamROG Notebook Member Array Chastity@ASUS's Avatar
    Join Date
    Oct 2010
    Reputation
    18
    Posts
    1,334

    http://vip.asus.com/eservice/cus_suggest.aspx

    Fill this out and ASUS Customer Care will contact you. They handle botched RMA service
    Kicking Ass Since Today

  3. #3
    Roach
    Guest
    Thanks for that chastity, I sent it off earlier today, hopefully I hear from them soon.

Similar Threads

  1. is F3-16000CL9D-4GBRM good?
    By darivo in forum Other Series Motherboards
    Replies: 3
    Last Post: 08-01-2011, 03:18 PM
  2. CH V Onboard Supreme X-FI 2 ... How good is it ?
    By vvulture in forum Other Series Motherboards
    Replies: 12
    Last Post: 08-01-2011, 09:10 AM
  3. Is the G73JH gone for good?
    By firstwardo in forum ROG Gaming Notebooks
    Replies: 1
    Last Post: 11-28-2010, 06:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •