Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    ROG Enthusiast Array Randomname's Avatar
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    70

    Linux Ubuntu and/or Slackware install help on G750JH

    Hi there,

    Just like the title says, I want to install Ubuntu and/or Slackware on my G750JH and I want it to be on Dual/Triple(?) boot with my Windows 8
    I've already setup the partitions for both of them (2x50Gb), a friend of mine tried to install Ubuntu on his laptop (Compaq) and he was successful until the part when he turns his computer on there is no dual boot option, the laptop only boots Win 8, so I don't want to run into some trouble like he did, so I thought about asking the experts

    It would be great if I could install Ubuntu and Slackware, since I'm a noob when it comes to computers, could you explain it so that I can understand
    Thanks
    ASUS G750JH-T4086D
    CPU: Intel Quad Core I7-4700HQ@ 2.4GHz
    GPU: Nvidia GeForce GTX 780M
    RAM: 16GB
    Memory: 1TB + 250GB SSD (Samsung 840 EVO 250GB)
    OS: Windows 8 64-bit
    Display: Anti-Glare (yup, I'm bragging about it :P)

  2. #2
    ROG Guru: Orange Belt Array
    Join Date
    Jul 2013
    Reputation
    41
    Posts
    325

    In the BIOS set Fast Boot = Off, and Secure Boot = Off (Launch CSM can be off too, modern Linux distros have no problems booting in UEFI mode). Install the Linuxes in their respective partitions, and when rebooting you can hold ESC to get a bios popup menu, which would ideally have auto-recognised your new UEFI linux installation and allows you to boot into it. It is likely that selecting the Linux option there will send you to the Grub boot menu, which can in turn load Windows. In any case, once you see what options you have with the ESC menu at bootup, you can head back into the bios and change the boot order as you wish (e.g. set the Linux bootloader to be first, due to it being able to also load Windows). Or you could just keep using ESC when restarting - up to you.

    These are just general instructions, anything more specific would require more info from you (e.g. I tried X, but Y happened, and I get Z error, what should I do).
    Last edited by villiansv; 11-07-2013 at 06:04 PM. Reason: added Launch CSM info

  3. #3
    ROG Enthusiast Array Randomname's Avatar
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    70

    Quote Originally Posted by villiansv View Post
    In the BIOS set Fast Boot = Off, and Secure Boot = Off (Launch CSM can be off too, modern Linux distros have no problems booting in UEFI mode). Install the Linuxes in their respective partitions, and when rebooting you can hold ESC to get a bios popup menu, which would ideally have auto-recognised your new UEFI linux installation and allows you to boot into it. It is likely that selecting the Linux option there will send you to the Grub boot menu, which can in turn load Windows. In any case, once you see what options you have with the ESC menu at bootup, you can head back into the bios and change the boot order as you wish (e.g. set the Linux bootloader to be first, due to it being able to also load Windows). Or you could just keep using ESC when restarting - up to you.

    These are just general instructions, anything more specific would require more info from you (e.g. I tried X, but Y happened, and I get Z error, what should I do).
    Thank you for replying to my question.

    Well, I've disabled the Fast Boot option (which was quite easy), what I couldn't find was the Secure Boot option. I entered the Windows Charms menu (Winkey+C) and then went to Settings pressed Shift key and then pressed the Power button + the Restart option, which led me to the all blue whatever menu (too lazy to look it up), went to Troubleshoot, Advanced option, there were no UEFI options (settings). Since I couldn't find the UEFI settings there, I powered off my laptop, and when it started to pressing the 'Esc' button (may I add, like a madman), when the blue-white screen appeared (I think it's referred to as the BIOS screen). I combed out all the tabs and options but nowhere to be found were the UEFI setting, so I went on to installing Ubunut, as I hoped it would go smooth. (well, to be frank, I really, really hopped that it would go smooth)

    Alright, I have installed Ubuntu first, I've formatted one of the partitions to Ext4, then installed it normally afterwards. I loaded it from a USB stick, went to Try without installing (something like that), when it prompted for restart, I naturally restarted it, and plugged out the USB stick, what happens next is quite interesting, it didn't give me a dual boot option, it went straight to Windows 8 and of course, my partition where it was installed disappeared, which even I knew was normal, since Windows doesn't recognize Ext4 format, so I thought it was to normal. I went to the BIOS screen (I hope that it's called that way) and Ubuntu (or even Linux) was nowhere to be found as a option, I couldn't even find a option to boot in Windows 8 (if it's relevant at all).
    Oh, I forgot to add when it asks if I want to erase all information on the HDD, I went to Something else, and from there on I installed it.

    If you need any more info for anything, please let me know, I hope that I'm able to resolve the issue with your help.
    Thank you very much

    P.S. I writing in a formal manner because I'm bored xD
    ASUS G750JH-T4086D
    CPU: Intel Quad Core I7-4700HQ@ 2.4GHz
    GPU: Nvidia GeForce GTX 780M
    RAM: 16GB
    Memory: 1TB + 250GB SSD (Samsung 840 EVO 250GB)
    OS: Windows 8 64-bit
    Display: Anti-Glare (yup, I'm bragging about it :P)

  4. #4
    ROG Guru: Orange Belt Array
    Join Date
    Jul 2013
    Reputation
    41
    Posts
    325

    BIOS --> Security tab --> Secure Boot Menu --> set it to disabled from there. I was under the impression that Ubuntu/OpenSuse etc (major Linux distros) have support for SecureBoot, but maybe not yet, or it's iffy. Try this, then when booting hit ESC and see if a bootable option other than your Windows/USB/DVD drive shows up in the popup blue screen.

    If that doesn't work, I'd suggest trying it a slightly different way - in addition to the old BIOS options, set the Launch CSM to ON in the BIOS, then reinstall Linux (make sure you format your ext4 partition from before during install, I'm sure you can figure that out). Something that >>may<< work is to also set up a separate boot partition in Linux - make it about 500mb-1gb max, and set its mount point to /boot (format as ext4). This is something I've done for ages when installing various distros, as I sometimes used file systems like XFS/JFS that GRUB couldn't boot from. In any case, it may make the recognition of GRUB as an extra boot option easier, but it may also have no effect whatsoever. Try it and GL.

  5. #5
    ROG Enthusiast Array Randomname's Avatar
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    70

    Ok, thanks

    Will try it out and give feedback
    ASUS G750JH-T4086D
    CPU: Intel Quad Core I7-4700HQ@ 2.4GHz
    GPU: Nvidia GeForce GTX 780M
    RAM: 16GB
    Memory: 1TB + 250GB SSD (Samsung 840 EVO 250GB)
    OS: Windows 8 64-bit
    Display: Anti-Glare (yup, I'm bragging about it :P)

  6. #6
    ROG Enthusiast Array Randomname's Avatar
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    70

    Quote Originally Posted by villiansv View Post
    BIOS --> Security tab --> Secure Boot Menu --> set it to disabled from there. I was under the impression that Ubuntu/OpenSuse etc (major Linux distros) have support for SecureBoot, but maybe not yet, or it's iffy. Try this, then when booting hit ESC and see if a bootable option other than your Windows/USB/DVD drive shows up in the popup blue screen.

    If that doesn't work, I'd suggest trying it a slightly different way - in addition to the old BIOS options, set the Launch CSM to ON in the BIOS, then reinstall Linux (make sure you format your ext4 partition from before during install, I'm sure you can figure that out). Something that >>may<< work is to also set up a separate boot partition in Linux - make it about 500mb-1gb max, and set its mount point to /boot (format as ext4). This is something I've done for ages when installing various distros, as I sometimes used file systems like XFS/JFS that GRUB couldn't boot from. In any case, it may make the recognition of GRUB as an extra boot option easier, but it may also have no effect whatsoever. Try it and GL.
    Hi, I've tried the first one and I can't find any of the options, including the 'set the Launch CSM to ON'.
    I don't know if it's relevant or not, but I've accidentally deleted FreeDos on my machine :S
    It was some time ago, when I got the laptop :S
    ASUS G750JH-T4086D
    CPU: Intel Quad Core I7-4700HQ@ 2.4GHz
    GPU: Nvidia GeForce GTX 780M
    RAM: 16GB
    Memory: 1TB + 250GB SSD (Samsung 840 EVO 250GB)
    OS: Windows 8 64-bit
    Display: Anti-Glare (yup, I'm bragging about it :P)

  7. #7
    ROG Guru: Orange Belt Array
    Join Date
    Jul 2013
    Reputation
    41
    Posts
    325

    BIOS should be the same for all G750s. Can you post pics of your BIOS tabs?

  8. #8
    New ROGer Array Zygomorphic's Avatar
    Join Date
    Mar 2012
    Reputation
    176
    Posts
    4,761

    separate /boot partition should not be necessary unless the guy plans on using XFS or ZFS partitions (which I don't recommend for the average user, due to their complexity, and lack of broad support). EXT4 is a very good filesystem since it supports journaling. It's also support by GRUB. The issue with /boot partitions is that they take up space (or are small, in which case kernel updates fill them up) that could be used for user programs if the boot and root partitions are in the same partition. However, I do recommend a separate /home partition, so that you can change distros without losing your personal files.
    I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
    http://rog.asus.com/forum/group.php?groupid=16
    We now have 178 people whose systems will not break! Yippee!
    LINUX Users, we have a group!
    http://rog.asus.com/forum/group.php?groupid=23

  9. #9
    ROG Enthusiast Array Randomname's Avatar
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    70

    Quote Originally Posted by Zygomorphic View Post
    separate /boot partition should not be necessary unless the guy plans on using XFS or ZFS partitions (which I don't recommend for the average user, due to their complexity, and lack of broad support). EXT4 is a very good filesystem since it supports journaling. It's also support by GRUB. The issue with /boot partitions is that they take up space (or are small, in which case kernel updates fill them up) that could be used for user programs if the boot and root partitions are in the same partition. However, I do recommend a separate /home partition, so that you can change distros without losing your personal files.

    What would you recommend me to do, since I can't disable the Secure Boot option?
    Or is there a way to disable it through cmd?
    Thank you for your answer
    ASUS G750JH-T4086D
    CPU: Intel Quad Core I7-4700HQ@ 2.4GHz
    GPU: Nvidia GeForce GTX 780M
    RAM: 16GB
    Memory: 1TB + 250GB SSD (Samsung 840 EVO 250GB)
    OS: Windows 8 64-bit
    Display: Anti-Glare (yup, I'm bragging about it :P)

  10. #10
    New ROGer Array Zygomorphic's Avatar
    Join Date
    Mar 2012
    Reputation
    176
    Posts
    4,761

    Quote Originally Posted by Randomname View Post
    What would you recommend me to do, since I can't disable the Secure Boot option?
    Or is there a way to disable it through cmd?
    Thank you for your answer
    The most recent versions of Ubuntu should have signing keys, which means that you shouldn't need to turn Secure Boot off. Why can't it be turned off, it should be one of the "Security" settings in the BIOS. If you can, please get into the BIOS menu again and post pictures of all the pages. That will really help.
    I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
    http://rog.asus.com/forum/group.php?groupid=16
    We now have 178 people whose systems will not break! Yippee!
    LINUX Users, we have a group!
    http://rog.asus.com/forum/group.php?groupid=23

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •