Results 1 to 5 of 5
  1. #1
    ROG Member Array
    Join Date
    Jun 2010

    Intel I217-V NIC (Network, Ethernet) adapter loses IP address upon resume from sleep


    I am having an issue w/ my Maximus VI Hero and the NIC. If I resume from sleep, it will lose the IP from time to time.

    My 1st board lasted 2 weeks before the issue begin. The replacement board also lasted 2 weeks and is now doing the same thing. Here's a picture:

    As you can see, it assigns an automatic private address. I can fix this simply by running the hardware diagnostics. Also, I'm running Windows 8.

    Does anyone have an idea on how to fix this? I've tried setting the link speed manually and changing drivers already.


  2. #2
    ROG Guru: Yellow Belt Array
    Join Date
    Feb 2012

    Hi jodiuh, welcome to ROG Forum.

    I do not like or use W8/W8.1, so my suggestions are based on W7, but i think they are also applicable to 8/8.1.

    First of all, i think the issue could be with the router / modem connected to the motherboard, so, if you have another one, you could try it and see the results.

    By the way, i’m also on a M6H and it is connected to a Cisco firewall ISA 570 and each time the mobo resumes from sleep, the Internet connection is always immediately on, a sign that NIC, IP addresses, etc, is all ok.

    To leave out any doubt, i suggest you go to Task Manager > Sevices Tab > Services...> DHCP Client > right click Proprieties > check if the service is config. as “Automatic” and it is running.

    Click image for larger version. 

Name:	Services.PNG 
Views:	4 
Size:	368.1 KB 
ID:	29867

    2. A workaround to this issue could be to assign an IP address to the NIC, and as in my case the firewall/router almost always automatically assigns the IP address, if i had this issue, the config would be:

    Click image for larger version. 

Name:	Local Connection.PNG 
Views:	7 
Size:	121.0 KB 
ID:	29868

    As you can see i’m not using TCP/IPv6, and if you use it, maybe you have also to config it.

    Sorry if you already have tried this, hope this could help.

  3. #3
    Tech Marketing Manager HQ Array Raja@ASUS's Avatar
    Join Date
    Apr 2011

    Also try disabling any low power states in the driver panel (allow windows to turn off this device checkbox etc).

  4. #4
    ROG Member Array
    Join Date
    Jun 2010

    Thanks for the tips guys. I will keep them in mind.

    I "think" I am good tho. I can't recall the exact name, but in device manager or the configure option on the NIC's properties, there's a bunch of "Wake on LAN" and other settings similar. I unchecked all of them and have been good for a few days now.

    When it happened, I could get it to fail every other sleep cycle. After unchecking all the options and rebooting, I lasted 10 sleep cycles and that was good enough for me.

    I hope that the issue is resolved now as it was quite annoying!

    Thanks and I will post a screenshot when I get home later tonight.

  5. #5
    ROG Member Array Nicholas Steel PC Specs
    Nicholas Steel PC Specs
    MotherboardASUS Crosshair Hero VIII WiFi
    ProcessorAMD Ryzen 3700X
    Memory (part number)16GB DDR4 3600Mhz
    Graphics Card #1Nvidia Geforce 1070Ti 8GB
    Sound CardIntegrated
    MonitorSamsung P2350
    CPU CoolerNoctua NH D-14
    CaseFractal Design Define R5
    Power SupplyCorsair AX760
    Keyboard DELL SK8110/Logitech Orion 610
    Mouse ASUS Gladius
    Headset Sennheiser HD380 Pro
    OS Windows 10 Pro x64

    Join Date
    Mar 2014

    I just had this exact same issue with my dads ASUS Sabertooth z87 (Not Mark 1 or 2) motherboard under Windows 7 x64. The network adapter just suddenly wanted to use IP Addresses in the completely wrong IP range and subnet mask which should've been impossible considering how everything else is configured. This caused us to lose network and internet connectivity on his computer, the computer couldn't even interact with the router via the web interface (My PC still worked fine though).

    I've tried the following to resolve the issue:
    - resetting the router
    - disconnecting and reconnecting the ethernet cable at both ends
    - manually assigning an IP address
    - turning off all wake-on-event settings
    - turning off all power saving settings
    - enabling manual negotiation of 100Mbps and also tried 1.0Gbps
    - Letting Windows attempt to resolve it
    - and Rebooting the PC

    None of those resolved it, it seemed to resolve when I went through and performed each diagnostic test when looking at the network adapter in Device Manager though o_O
    Last edited by Nicholas Steel; 01-10-2015 at 11:28 AM.
    Computer specifications:
    Windows 10 Pro x64|AMD Ryzen 3700X|ASUS Crosshair Hero VIII WiFi Motherboard|16GB DDR4 3600Mhz RAM|Integrated Audio|MSI Geforce 1070Ti|Corsair AX760 Platinum Power Supply|Fractal Define Design R5 Computer Case|Samsung P2350 Monitor

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts