Page 2 of 16 FirstFirst 1 2 3 4 12 ... LastLast
Results 11 to 20 of 152
  1. #11
    ROG Member Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    7

    Oh, there's a quirk all right...

    After initial testing it's clear that VT-d (found under Advanced/System Agent Config) indeed works. But it comes at the cost of losing onboard network connectivity.

    The good part:
    My IOMMU enabled Linux kernel reports VT-d as working. Did some quick testing by passing through a PCI soundcard to a Windows 7 guest and it worked flawlessly!

    Now, the drawback... The new BIOS seems to have killed off all onboard network connectivity. Both Linux and Windows 7 is able to detect the card just fine and there's nothing to suggest the card is faulty, but no traffic ever makes it out of the interface (I set up a packet dump on the other end of the cable - no output.) So, naturally I tried switching back to 4503 version using the BIOS switch. Sadly, onboard LAN is still dead.

    Checked Intel for newer firmware, grabbed the newest but it says it's up to date as is.

    For now, this isn't a big issue for me - I have a few 1GbE and 10GbE PCI cards lying around. I do, however, hope there's a way to fix this in the future.

    Mostlyharmless, I'd appreciate if you could keep me up to date with any newer BIOSes Falcon sends your way. Apparently, I'm in the mood for breaking stuff.
    Last edited by aewne; 11-26-2013 at 08:53 PM.

  2. #12
    ROG Guru: White Belt Array
    Join Date
    Oct 2013
    Reputation
    10
    Posts
    85

    Did it killed the card, or was it DNF from the beginning?

  3. #13
    ROG Member Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    7

    Hope not. It was working fine before I flashed.

  4. #14
    Super Moderator - Coderat Array Nodens PC Specs
    Nodens PC Specs
    Laptop (Model)ASUS GL702VW-GC004T
    MotherboardRampage V Extreme Edition 10
    ProcessorIntel 3930K C2
    Memory (part number)CMZ16GX3M4X2133C11
    Graphics Card #1ASUS STRIX-GTX970-DC2OC-4GD5
    MonitorASUS VG278H
    Storage #13x OCZ Vertex 3 240 (RAID5 - LSI 9361-8i)
    Storage #23x WD2003FYYS (RAID5 - LSI 9361-8i)
    CPU CoolerCorsair H100i + 4x Noctua NF-P12
    CaseCoolermaster HAF-X
    Power SupplySeasonic X-1250
    Keyboard Razer Anansi
    Mouse Logitech G502
    OS Windows 10 Pro x64
    Network RouterLinksys E4200v2 (running TomatoUSB/Toastman firmware)
    Nodens's Avatar
    Join Date
    Mar 2012
    Reputation
    266
    Posts
    4,389

    Technically it can't kill the NIC. Mind if you send me that UEFI image? It's probable that the flashing updated either the ME or GBE regions of the SPI flash. A downgrade will not overwrite a newer version of the firmware in those regions. Once I verify my theory I will tell you how to fix this. Can you also check if the MAC address of the NIC is set to 88:88:88:88:87:88?
    RAMPAGE Windows 8/7 UEFI Installation Guide - Patched OROM for TRIM in RAID - Patched UEFI GOP Updater Tool - ASUS OEM License Restorer
    There are 10 types of people in the world. Those who understand binary and those who don't!

    RealBench Developer.

  5. #15
    ROG Member Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    7

    Should be in your inbox right about now.

    Edit: Also, MAC address is unchanged after flashing and is not 88:88...

  6. #16
    ROG Member Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    7

    With a little help from Nodens, I was able to reflash the Descriptor, ME and GBE regions using FTK. Now the NIC is up and running again.

    So far I haven't encountered any other bugs or causes for instability with the 9502 BIOS. Then again I'm not running any insane clocks yet. I'll report back if I find any.

  7. #17
    Super Moderator - Coderat Array Nodens PC Specs
    Nodens PC Specs
    Laptop (Model)ASUS GL702VW-GC004T
    MotherboardRampage V Extreme Edition 10
    ProcessorIntel 3930K C2
    Memory (part number)CMZ16GX3M4X2133C11
    Graphics Card #1ASUS STRIX-GTX970-DC2OC-4GD5
    MonitorASUS VG278H
    Storage #13x OCZ Vertex 3 240 (RAID5 - LSI 9361-8i)
    Storage #23x WD2003FYYS (RAID5 - LSI 9361-8i)
    CPU CoolerCorsair H100i + 4x Noctua NF-P12
    CaseCoolermaster HAF-X
    Power SupplySeasonic X-1250
    Keyboard Razer Anansi
    Mouse Logitech G502
    OS Windows 10 Pro x64
    Network RouterLinksys E4200v2 (running TomatoUSB/Toastman firmware)
    Nodens's Avatar
    Join Date
    Mar 2012
    Reputation
    266
    Posts
    4,389

    Hehe enjoy VT-d and I'm glad I could help. If that version they sent you works properly it will probably get merged with the main branch of the UEFI.
    RAMPAGE Windows 8/7 UEFI Installation Guide - Patched OROM for TRIM in RAID - Patched UEFI GOP Updater Tool - ASUS OEM License Restorer
    There are 10 types of people in the world. Those who understand binary and those who don't!

    RealBench Developer.

  8. #18
    ROG Member Array
    Join Date
    Oct 2013
    Reputation
    10
    Posts
    19

    Odd about the network; I've experienced no problems with connectivity.

  9. #19
    Super Moderator - Coderat Array Nodens PC Specs
    Nodens PC Specs
    Laptop (Model)ASUS GL702VW-GC004T
    MotherboardRampage V Extreme Edition 10
    ProcessorIntel 3930K C2
    Memory (part number)CMZ16GX3M4X2133C11
    Graphics Card #1ASUS STRIX-GTX970-DC2OC-4GD5
    MonitorASUS VG278H
    Storage #13x OCZ Vertex 3 240 (RAID5 - LSI 9361-8i)
    Storage #23x WD2003FYYS (RAID5 - LSI 9361-8i)
    CPU CoolerCorsair H100i + 4x Noctua NF-P12
    CaseCoolermaster HAF-X
    Power SupplySeasonic X-1250
    Keyboard Razer Anansi
    Mouse Logitech G502
    OS Windows 10 Pro x64
    Network RouterLinksys E4200v2 (running TomatoUSB/Toastman firmware)
    Nodens's Avatar
    Join Date
    Mar 2012
    Reputation
    266
    Posts
    4,389

    Quote Originally Posted by mostlyharmless View Post
    Odd about the network; I've experienced no problems with connectivity.
    Somehow his SPI flash was corrupted during the flashing. It was not really a matter of the UEFI version so nothing to worry about. Once he reflashed Descriptor, ME and GBE regions the NIC worked properly
    RAMPAGE Windows 8/7 UEFI Installation Guide - Patched OROM for TRIM in RAID - Patched UEFI GOP Updater Tool - ASUS OEM License Restorer
    There are 10 types of people in the world. Those who understand binary and those who don't!

    RealBench Developer.

  10. #20
    ROG Guru: Grand Master Array HiVizMan's Avatar
    Join Date
    Dec 2011
    Reputation
    354
    Posts
    25,742

    Well done Nodens not sure I can rep you again so soon but the birthday boy is on a role.
    To help us help you - please provide as much information about your system and the problem as possible.

Page 2 of 16 FirstFirst 1 2 3 4 12 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •