Results 1 to 8 of 8
  1. #1
    ROG Guru: Yellow Belt Array Flea0's Avatar
    Join Date
    Jun 2013
    Reputation
    21
    Posts
    211

    the laptop is adjusting the brightness based on the color of what's on screen?

    I just started noticing this...whenever more than a certain amount of screen is taken up by something dark, like these forums or steam or a dark movie scene, the backlight OR the brightness settings (It's hard to tell) are instantly (a smooth 1 second transition) adjusted to make it even darker.

    Here's an experiment I did: on a dark grey background, I opened an empty folder (which is white) and the brightness/backlight of the screen was at maximum. I started shrinking the folder window and once it got about as small as a 2x2 windows 8 icon, the screen VISIBLY darkened, making the white of the folder and the fonts on the taskbar somewhat brown-greyish.

    This is a bit annoying because it's noticeable AND because it makes small white details darker, while I prefer high contrast. Does anyone have any clue what might be causing this? Adaptive screen brightness is disabled and there's nothing indicating this function on the nvidia control panel.
    ASUS G750JX -- i7-4700 - 16GB - 128GB 840 PRO SSD + 1TB HDD - Nvidia GTX 770M - 120Hz 3D glossy display

  2. #2
    ROG Guru: Orange Belt Array
    Join Date
    Jul 2013
    Reputation
    41
    Posts
    325

    This will probably help - http://www.eightforums.com/tutorials...ndows-8-a.html

    Not sure how it works if you're using asus's power4gear plans, but you can check if they have a relevant setting, see if the above works with them, or just uninstall it (it's useless).

    For me personally it still acts up on battery, but plugged in the brightness is constant.

  3. #3
    ROG Guru: Yellow Belt Array Flea0's Avatar
    Join Date
    Jun 2013
    Reputation
    21
    Posts
    211

    I already disabled adaptive brightness both in the power settings and in services, but besides that the issue isn't about brightness adapting to external lighting conditions, it's adapting to what I visualize on the screen.
    ASUS G750JX -- i7-4700 - 16GB - 128GB 840 PRO SSD + 1TB HDD - Nvidia GTX 770M - 120Hz 3D glossy display

  4. #4
    ROG Guru: Orange Belt Array
    Join Date
    Jul 2013
    Reputation
    41
    Posts
    325

    Yeah, but I always suspected that your screen's brightness may be affecting the ambient light sensor. The other settings you can try that may have an effect on this are:

    1. Nvidia control panel - Adjust desktop color settings. Set it to whatever isn't selected at the time (so probably set it to "use nvidia settings" and keep everything @default).
    2. Nvidia control panel - Adjust video color settings. Do the same spiel, and in particular check under Advanced to use full 0-255 dynamic range. The two checkmarks there should be unchecked (checking them would likely result in a similar behaviour to what you're seeing, based on their description).

    So basically try 1. and 2., or both, experiment with the settings (maybe set the wrong ones on purpose, then reset to default) and hope for the best.

  5. #5
    ROG Guru: Yellow Belt Array Flea0's Avatar
    Join Date
    Jun 2013
    Reputation
    21
    Posts
    211

    good hints (nvidia control panel was set to limited dynamic range) but it's still not fixing the issue :/ this is a headscratcher...
    ASUS G750JX -- i7-4700 - 16GB - 128GB 840 PRO SSD + 1TB HDD - Nvidia GTX 770M - 120Hz 3D glossy display

  6. #6
    ROG Guru: Orange Belt Array
    Join Date
    Jul 2013
    Reputation
    41
    Posts
    325

    No more ideas, unfortunately. As I said, I also have the issue on battery. Searched a lot, but couldn't find anything online other than the above. Problem is, this is a common issue with intel integrated gpus, and a solution is available to them via the intel control panel, and the majority of google results either talk about that, or the options I listed above. If you figure it out, do post, it is indeed a headscratchers.

  7. #7
    New ROGer Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    1

    Although it is not a solution, try simply setting the brigtness level via the Fn+F5/F6. I simply change the brigtness very slightly and the problem is gone. If that does not work for you, try to plug out and plug in the power cord and then change the brightness level.

  8. #8
    ROG Guru: Yellow Belt Array Flea0's Avatar
    Join Date
    Jun 2013
    Reputation
    21
    Posts
    211

    the brightness level shows up as set to maximum even when the screen is "dimmed" by whatever service is causing this behaviour. Which actually makes leads me to believe it's not adjusting the backlight but the color brightness and contrast on the fly.
    ASUS G750JX -- i7-4700 - 16GB - 128GB 840 PRO SSD + 1TB HDD - Nvidia GTX 770M - 120Hz 3D glossy display

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •