Results 1 to 9 of 9
  1. #1
    ROG Enthusiast Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    42

    From 60 fps to 59 fps - seeing a stutter

    Hello everyone,

    Since my build is finally done now and all is working, I am wondering if the following is normal, been playing on consoles for way to long haha

    I decided to buy and install Skyrim. Everything works, but I noticed a kind of stutter now and then. So I decided to use fraps to check my framerate, and I notice that when it stutters the frame rate drops from 60 to 59, just for a split second, but it seems this give the stutter.

    I have vsync enabled to keep 60 fps, if I turn it off I get like 150 fps. All settings are maxed out.

    Specs:

    i5 4670k
    asus gtx770 DCIIOC
    Asus maximus VI hero
    ssd 120 gig
    hdd 1 tb
    Dark rock pro 2 cpu cooler
    16 gig ram
    asus mx239h monitor
    seasonic g750 psu

    Thanks in advance!

    Rick
    Last edited by RickH89; 12-03-2013 at 06:36 PM.

  2. #2
    ROG Member Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    13

    I'm fairly certain this is normal. I get this in games I turn on V-sync with my 120hz monitor. It bounces between 119 and 120 in games like League of Legends and Most Source games. I wouldn't worry about it too much. I'm sure that you can't even see the difference when it happens without numbers telling you right? I know it's one of those things that can annoy someone. I'm the same way, I have learned to just shut off V-sync for the most part, but that's easier for me on a 120hz monitor. At 60hz you would get the screen tearing.

    Unless I'm wrong, I believe this is normal.

  3. #3
    ROG Enthusiast Array
    Join Date
    Sep 2013
    Reputation
    39
    Posts
    65

    No, it's not normal. And you can avoid stuttering (But not in skyrim...).
    In most cases stuttering happens when you use v-sync and can't get 60fps and more 100% of time. Whenever your fps drops at least to 59 fps stuttering happens. What you can do is:
    1. Buy newer video card to get stable 60+ fps.
    2. Lower some settings to get stable 60+ fps. (Run some benchmark with fraps and confirm you get 60 fps all the time)
    3. Turn off v-sync. (Not an option at all. Screen tearing is just as bad as stuttering)
    4. Wait for g-sync monitors.
    5. Overclock. (In some cases it's enough)
    6. See group three...
    Except for first group of games there are games which have broken in-game v-sync. You can confirm it by running game without v-sync and see if it runs 60+fps 100% of time, but with v-sync turned on there are stutters.
    What you can do:
    1. Turn off in-game v-sync.
    2. Go to Nvidia control panel.
    3. Manage 3D setting > Program Settings.
    4. Chose your game from list and change:
    4.1 Maximum pre-rendered frames to 1.
    4.2 Vertical sync to Adaptive.
    Play your game stutter-free now.
    Examples of these games: Source games (HL2, Episodes, Portal, Portal 2, CS:GO, etc.). In-game v-sync is totally broken now (it wasn't earlier). Adaptive v-sync is the solution.
    Mafia 2 sutters for me with in-game v-sync. Adaptive v-sync completely fixes stuttering.
    Many other games.
    Group three is the group of games which are horribly optimized. GTA4 is one of them.
    To play it smooth you have to overclock your CPU. In my case I oced it to 4.4 GHz to get 30+fps. Then, when you are sure your MINIMUM in-game fps is 31-32, go to Nvidia control panel, do steps 1-4 from last group of games, but change V-sync to Adaptive (half refresh rate).
    You can experience smooth gameplay now but get controller for these games since input lag is really heavy now. Playing with keyboard+mouse is the disaster... If you are ex-console player there is nothing wrong about 30fps gaming for you. Anyway it will be much smoother gameplay than you can experience on consoles.
    Group four. Totally broken games. Nothing can fix stutters. Yes, Skyrim IS in it.
    Nothing you can do about it...

    For this particular game (Skyrim) I spent months trying to solve problems. No solution. Bad coding...
    Hope it helps.

    Quote Originally Posted by Kross View Post
    I'm fairly certain this is normal. I get this in games I turn on V-sync with my 120hz monitor. It bounces between 119 and 120 in games like League of Legends and Most Source games. I wouldn't worry about it too much. I'm sure that you can't even see the difference when it happens without numbers telling you right? I know it's one of those things that can annoy someone. I'm the same way, I have learned to just shut off V-sync for the most part, but that's easier for me on a 120hz monitor. At 60hz you would get the screen tearing.

    Unless I'm wrong, I believe this is normal.
    You are totally wrong.
    And for you actually it is harder to get smoothest gameplay since you have 120hz monitor. It's much harder to get stable 120+ fps than 60+ fps. Or even 30+ fps...
    Last edited by Akreontage; 12-05-2013 at 11:06 AM.
    Corsair Carbide 500R | Asus Rampage IV Formula | i7-3930k 4.4Ghz | Corsair Vengeance 32Gb 1600Mhz 9cl | Gigabyte GTX 1080 G1 Gaming 8G | Samsung 850 Evo | WD1002FAEX | Antec HCP-1200 | NZXT Kraken x62

  4. #4
    ROG 師傅 Array Arne Saknussemm PC Specs
    Arne Saknussemm PC Specs
    Laptop (Model)Laptop?...No way! (Model?...Jun Amaki...yes way!)
    MotherboardROG ZENITH EXTREME
    ProcessorTHREADRIPPER 1920X
    Memory (part number)F4-3200C14Q-32GVK
    Graphics Card #1GTX Titan X
    Graphics Card #2SLI is dead to me
    Graphics Card #3Tri SLI is even dead to Nvidia
    Graphics Card #4Quad SLI is dead to everybody especially my credit card
    Sound CardXonar Essence STX
    MonitorASUS ROG Swift PG279Q
    Storage #1Samsung 950 PRO
    Storage #22x OCZ VERTEX 3/2x WD Caviar Black 500GB / 2x WD RED 2TB
    CPU CoolerCustom Loop: Dual D5s, Dual Alphacool Monsta 480s, XSPC Raystorm Neo TR4, EK TitanX WaterBlock
    CaseNope!...Phobya Bench...let it all hang out man!
    Power SupplySeasonic SS-1200XP3
    Keyboard Logitech G810 or Fender Rhodes Electric Piano (MKI 73)
    Mouse G502 or Speedy Gonzalez...not Mickey...don't do Disney!
    Headset ...firmly on neck
    Mouse Pad Mouse don't got his own pad man...lives with me
    Headset/Speakers Edifier Spinnaker...or you mean the speakers in my head...man too many voices to name them all
    OS Win XP, 7, 8, 8.1 and Windows 10 Spyware Edition
    Network Router56k modem
    Accessory #1 Umm...nice tie?
    Accessory #2 Err...belt?
    Accessory #3 3 accessories?! I'm not a girl!!
    Arne Saknussemm's Avatar
    Join Date
    Apr 2012
    Reputation
    481
    Posts
    13,400

    Nice post Akreontage +rep

  5. #5
    ROG Member Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    13

    Quote Originally Posted by Akreontage View Post
    You are totally wrong.
    From what you said then, I'm not completely wrong. IF there is nothing you can do about a broken game not utilizing V-sync correctly, then it's normal. That's all I meant. I didn't read the original post the right way. I thought he meant the fps counter just stutters, not the whole game. So for that, I apologize. I run dual 480's and don't stutter really in any games when the fps counter bounces from 119-120. I just see the numbers bounce really quickly so I attributed this to the way the counter calculates fps' by rounding a number based on the decimal place. e.g. 119.4 fps to 119. I don't feel or see any physical stutter on my screen. That's the only reason I stated my response the way I did.

    No need to be so harsh about my response.

  6. #6
    ROG Enthusiast Array
    Join Date
    Sep 2013
    Reputation
    39
    Posts
    65

    No-no. I said you are wrong that it is normal behavior. Games don't intend to stutter.
    Ideal scenario assumes fluid and solid game experience.
    Btw try running those games with adaptive v-sync and pre-rendered frames to 1. Most likely you'll see rock solid 120fps and not 119-120 jumps. And maybe you'll feel some improvements (maybe not, since you pointed absence of physical stuttering).
    I might be wrong since you are using sli.
    Good luck and hope it helps!
    Corsair Carbide 500R | Asus Rampage IV Formula | i7-3930k 4.4Ghz | Corsair Vengeance 32Gb 1600Mhz 9cl | Gigabyte GTX 1080 G1 Gaming 8G | Samsung 850 Evo | WD1002FAEX | Antec HCP-1200 | NZXT Kraken x62

  7. #7
    ROG Enthusiast Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    42

    Akreontage...Thank you!

    I have been searching for answers all over the internet and it could not have been better explained than what you posted
    Honestly I think it could help alot of people since I have seen alot of posts on the internet without anyone being able to give a detailed answer that actually made sense.

    +rep for you! Thanks alot, loving the ROG forum you guys are great! I keep learning every day

  8. #8
    ROG Enthusiast Array
    Join Date
    Sep 2013
    Reputation
    39
    Posts
    65

    Found the fix for stutters in Skyrim...
    Add iFPSClamp=60 under general tab into Skyrim.ini. Skyrim.ini is located in C:\Users\YOURNAME\Documents\My Games\Skyrim folder.
    This setting fixes Skyrim, Fallout New Vegas, Oblivion and probably other Bethesda games (don't have other games, can't really say).
    Corsair Carbide 500R | Asus Rampage IV Formula | i7-3930k 4.4Ghz | Corsair Vengeance 32Gb 1600Mhz 9cl | Gigabyte GTX 1080 G1 Gaming 8G | Samsung 850 Evo | WD1002FAEX | Antec HCP-1200 | NZXT Kraken x62

  9. #9
    ROG Guru: Grand Master Array HiVizMan's Avatar
    Join Date
    Dec 2011
    Reputation
    354
    Posts
    25,742

    Cheers for the effort Akreontage repped you too.
    To help us help you - please provide as much information about your system and the problem as possible.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •