Results 1 to 7 of 7
  1. #1
    ROG Member Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    12

    Wifi problems... weak

    Hey guys,

    just noticed today, that my Wifi just got worse.... The signal is 99% and im right next to the router and getting very slow/poor speed tests on this computer. I have done same tests on 2 others with a noticeably different results of this G55 getting 1mbps up to like 8mbps. The other computers are getting 19mbps and up to 25mbps on results. I especially noticed a difference when unplugged and AC plugged in. I would say 1mbps or less unplugged and 8mbps plugged in.

    The following have been checked.
    Power management for the wireless has been disabled.
    I also have uninstalled and reinstalled the Atheros Wifi driver as well as the intel driver. I used the newest drivers off the ASUS website.

    Still no improvement.

    What else can i do? this is really bothering my because this computer should be faster than the other devices. My router is almost new with N wireless (and verifying speed with other devices leads me to blame this G55 for the fault).

  2. #2
    ROG Enthusiast Array
    Join Date
    Aug 2012
    Reputation
    16
    Posts
    67

    The atheros card is the second most replaced item in the G series right after swapping to ssd. I don't know why asus went cheap on the wifi but I recently replaced mine with intel 6235 advanced-n and the improvement is fantastic. The connection is so much more stable and my throughput speeds are closer to my other devices.

    Alot of folks here opt for the bigfoot killer-n also a good card and can be had with or without the bluetooth.

    I have the G75vw and swapping cards involved about 30, warranty voiding screws but only took about 20mins. For me it was a worthwhile upgrade. Don't know if your G55 would be any more difficult.

  3. #3
    ROG Guru: Black Belt Array rewben PC Specs
    rewben PC Specs
    Laptop (Model)G55VW-3D
    MotherboardASROCK Z97 EXTREME 6
    ProcessorINTEL 4790K
    Memory (part number)G.SKILL RIPJAWZ 2400MHZ (F3-19200CL10Q-32GBZHD)
    Graphics Card #1ASUS STRIX-GTX980-DC2OC-4GD5
    Graphics Card #2ASUS STRIX-GTX980-DC2OC-4GD5
    MonitorDELL U2713HM
    Storage #1SAMSUNG SM843 480GB X2
    Storage #2WD GREEN 3TB X2
    CPU CoolerSWIFTECH H240-X
    CaseNZXT H440
    Power SupplyTHERMALTAKE TOUGHPOWER XT PLATINUM 1275W
    Keyboard CORSAIR K70 RGB
    Mouse STEELSERIES KINZU V3
    Headset STEELSERIES 9H
    Mouse Pad STEELSERIES QCK+
    Headset/Speakers LOGITECH Z506
    OS WINDOWS 10 PRO AU
    Network RouterASUS RT-AC66U

    Join Date
    Jun 2012
    Reputation
    178
    Posts
    2,229

    there is still one thing you can try: the latest driver released by the atheros website. (i believe it's under AR813X AR815X Family Drivers; the latest being 2.1.0.21)

    before i swapped my atheros card with intel 7260 .ac, it ran stably with 150mbps. my power plan is always at high performance.

  4. #4
    ROG Member Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    12

    what's involved in the swap to the intel card?

  5. #5
    ROG Guru: Black Belt Array rewben PC Specs
    rewben PC Specs
    Laptop (Model)G55VW-3D
    MotherboardASROCK Z97 EXTREME 6
    ProcessorINTEL 4790K
    Memory (part number)G.SKILL RIPJAWZ 2400MHZ (F3-19200CL10Q-32GBZHD)
    Graphics Card #1ASUS STRIX-GTX980-DC2OC-4GD5
    Graphics Card #2ASUS STRIX-GTX980-DC2OC-4GD5
    MonitorDELL U2713HM
    Storage #1SAMSUNG SM843 480GB X2
    Storage #2WD GREEN 3TB X2
    CPU CoolerSWIFTECH H240-X
    CaseNZXT H440
    Power SupplyTHERMALTAKE TOUGHPOWER XT PLATINUM 1275W
    Keyboard CORSAIR K70 RGB
    Mouse STEELSERIES KINZU V3
    Headset STEELSERIES 9H
    Mouse Pad STEELSERIES QCK+
    Headset/Speakers LOGITECH Z506
    OS WINDOWS 10 PRO AU
    Network RouterASUS RT-AC66U

    Join Date
    Jun 2012
    Reputation
    178
    Posts
    2,229

    first, i am sorry for giving you the WRONG info. my bad. (you needed atheros wifi driver, not the LAN driver :/)
    i used to get the drivers from here:
    http://www.atheros.cz/atheros-wireless-drivers.php
    http://www.atheros.cz/atheros-wirele...et=61&system=8

    to swap it, you basically disassemble the laptop, up to the keyboard. you might also need to take out the display panel, too. (the card is just under the display panel). however, you should be able to swap the card without doing that.

  6. #6
    ROG Enthusiast Array
    Join Date
    Aug 2012
    Reputation
    16
    Posts
    67

    Wish I could be of more help, but I don't have a G55 to take apart so I don't know what's involved specifically. If you had G75 I could do more. I've had mine open so many times I know where every screw goes.

  7. #7
    ROG Member Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    12

    Have you tried disabling the bluetooth? I've had this same problem on my G75 and it drove me crazy, I tried everything called multiple tech support. No one could help me, I was ready to send it off to Asus for repair. then I stumbled on a post here about the bluetooth interfering with the wifi. I turned off the bluetooth and now it works like a charm.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •