Results 1 to 6 of 6
  1. #1
    ROG Enthusiast Array
    Join Date
    Jul 2013
    52 - problems with drivers download page


    I'm trying to open Asus's driver download page, but i cannot get it to work since Asus changed the site layout.
    I know that Asus's site is slow and unresponsive as hell, but this is just ridiclius.

    I was wondering if anyone else is experience similar problems.
    I tried different browsers in my laptop, I tried different laptop, desktop and even a phone, and the problem still persists.

    When i go to the site, it loads slowly. I click on support, and it opens the page slowly, i write g750jx in search bar, and it opens the page. Everything works to this point. Then i click on "Please select OS" bar, and it does not open the list from wich u could choose OS type (win 8.1 64bit).

    I will paste some screenshoots...

    Click image for larger version. 

Name:	Screenshot (2).jpg 
Views:	17 
Size:	107.3 KB 
ID:	31876Click image for larger version. 

Name:	Screenshot (3).jpg 
Views:	21 
Size:	107.3 KB 
ID:	31877

  2. #2
    Banned Array
    Join Date
    Oct 2013

    it's not only you. it has been messed up and buggy and slow since the release of Windows 8.1 in October.

    Worst Driver Support Team = ASUS Drivers Team

    I posted a thread on these forums complaining that the Win 8.1 Drivers are not complete and empty since 2 months and so far only the G750JW got the drivers and they're not full yet. still missing the updated virtual camera and LifeFrame and many other things

  3. #3
    ASUS Reseller Array Shawnnepc's Avatar
    Join Date
    Jul 2012

    Have been seeing the same thing for the past few weeks.

    Might be due to the holiday season and people updating all their shiny new ASUS toys?
    USA ASUS Reseller

  4. #4
    ROG Guru: White Belt Array
    Join Date
    Aug 2013

    i have windows 8 and i have been experiencing the same problems..pages load very slow and then recently i noticed driver download page doesnt work i mean when you click the drop down arrow it won't open..i tried everything else too different laptops browsers etc. doesn't work..don't they give a crap about their website?

  5. #5
    ROG Guru: Platinum Belt Array hmscott PC Specs
    hmscott PC Specs
    Laptop (Model)Asus G750JH-DB71 (legacy)
    MotherboardAsus G750JH Intel HM87
    ProcessorIntel i7-4700HQ XTU Cores 36x/35x/34x/34x Cache 36x -50mV undervolt
    Memory (part number)Hyundai Electronics HMT41GS6AFR8A-PB 1.35v DDR3L-1600MHz
    Graphics Card #1Nvidia 780m Asus GPU Tweak OC 932mhz/6300mhz
    Sound CardRealtek v6.0.1.7469 driver
    MonitorAUO B173HW02 V1 Custom Refresh 85hz
    Storage #1RAID0 2x M.2 SATA Crucial MX200 512GB CT500MX200SSD6
    Storage #2Crucial 512GB 2.5" MX200 CT500MX200SSD1
    Power Supply230w AC Power Adapter 19.5v
    Keyboard Logitech k400 Wireless KB/Trackpad
    Headset Sony MDR-XB500 Wired and Sennheiser RS-220 Wireless TOSLINK
    OS Windows 8.1 + 8 Linux VM's + Windows 10 Technical Preview
    Network RouterAsus RT-AC68U DLINK DIR-655

    Join Date
    Jun 2013

    As I mentioned a few postings before, the error goes away if you keep trying, wait a few minutes if you get frustrated. Sometimes, like right now, it all just came right up cleanly the first time

  6. #6
    ROG Enthusiast Array
    Join Date
    Jul 2013

    Strange thing is that if i use the link that hmscott posted, and change the model to JX the page loads with no problems.

    Then i went to the page by google search, and it wont load, i have opend both pages in separate Chrome windows, the one that hmscott posted works and google search does not!

    I wil post the working link if anyone needs it:

    Maybe there is probems with differnet pages. Im from EU, and i think that the EU site isnt working, and the site that hmscott posted is from USA... Just a tought... I think this cause looking at the site form hmscoot clearly look different than mine...

    Thx for the link hmscoot!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts