Results 1 to 10 of 10
  1. #1
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    5

    computer boots into bios and not into ubuntu

    i built a pc and installed ubuntu 12.04 on it. when i power up the computer, it boots into bios and does not go into ubuntu. the Qcode LED on the mobo reads AE (Legacy boot event)

    i've tried changing boot order, disabled secure boot and even tried installing ubuntu 13.10, linux mint 16. with the same result. I am able to boot into the os through the disk. can someone please help?

    my components: i7 4770k asus z87-pro gskill ripjaws 16gb ram seagate 3tb hdd

  2. #2
    ROG Guru: Grand Master Array HiVizMan's Avatar
    Join Date
    Dec 2011
    Reputation
    354
    Posts
    25,742

    Please list all the devices connected to your system and could you tell me if your system is OC at all? I am especially interested in which SATA ports are used? For example are you sure your OS drive is connected to a Intel SATA port?


    I do know of some issues trying to boot to OS when overclocked and lynix based system.
    To help us help you - please provide as much information about your system and the problem as possible.

  3. #3
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    5

    thanks for your response.

    my system is not overclocked. i have the hdd and the dvd drive connected through sata. no other components.

    i used sata ports 1 and 2 for the hdd and dvd drive. there were 2 black sata ports and 6 yellow sata ports on the mobo. i skipped the black ports and used the first 2 yellow ports. i read something about not using the black ports ( i can look it up and let you know). this is my first build. so pardon my noob terms.

    i contacted asus support and they asked me to update the bios, restore defaults and then reinstall. i tried that today (went from version 1007 to 1707). i reinstalled ubuntu. same result.

    the support person asked me to try the boot override. when i click on the hdd, the screen blinks and comes back to the same screen.

    can you please help?

  4. #4
    ROG Guru: Grand Master Array HiVizMan's Avatar
    Join Date
    Dec 2011
    Reputation
    354
    Posts
    25,742

    The black ports are not the Native Intel 6G ports please use the yellow ones.
    To help us help you - please provide as much information about your system and the problem as possible.

  5. #5
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    5

    Thats what I did. Used first 2 yellow ports

  6. #6
    untouched Array Praz's Avatar
    Join Date
    Apr 2011
    Reputation
    137
    Posts
    4,038

    The system boots to UEFI when it does not see a properly configured bootable device. That you are able to boot using the disk confirms this. There is an issue with the UEFI boot/CSM settings or the install itself.

  7. #7
    ROG Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    6

    Try starting up the install disk and running boot-repair (https://help.ubuntu.com/community/Boot-Repair). Installs with UEFI are still less than fluid I've found...

  8. #8
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    5

    Thanks for your responses.

    I agree with Praz. I think the hdd is good. the fact that i see the drive and correct capacity is detected by the bios and that install is able to complete proves this. I think its not configured or recognized as the bootable drive. Problem is i dont know how to configure it as a bootable drive.

    morphemass, I tried that too. i let the default option find and fix problems. it completed and asked me to restart. same result.

    I don't know what else i can try next. Ideally i would like a setting that says, this drive is bootable, please boot to it. I just cant find that.

  9. #9
    ROG Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    6

    Try disabling the legacy boot option (so that you get a UEFI install) and run boot repair again or reinstall. In 13.10 (at least) Grub is installed onto the wrong partition by default. I recently had to reinstall myself it was a far from painless process and I suspect using 12.x *may* be part of the problem (hence why I'm on 13.10)

    That said, Grub on a legacy install should just install itself into the MBR....

    Have you tried the suggestions at : https://help.ubuntu.com/community/UEFI ?

  10. #10
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    5

    That worked. I set boot option to uefi and reinstalled 13.10...

    Thanks a lot for your help

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •