Page 1 of 67 1 2 3 11 51 ... LastLast
Results 1 to 10 of 670
  1. #1
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    R9 280x DirectCU II Top Artifacts!!

    HEllo i just upgraded from an 7870 to the R9280X-DC2T-3GD5

    I followed these steps for drivers

    1. Ran Catalyst control center from C:/ AMD and did a custom uninstall. Removed all
    2. Restarted computer
    3. Ran Driver Fusion and deleted everything from AMD
    4. Restarted computer
    5. Installed latest 13.12 R9 drivers from AMD site

    I get artifacts (shapes, lines , squares) flashing everywhere in screen , when in Chrome, in Dota 2 and Planetside 2. Haven't tested in more games , but I guess it will be the same.
    The card will need a replacement? I have a Corsair CX600 , AMD FX 8350, Corsair Vengeance 2x4gb 1600 mhz
    I read somewhere about GPU bios update. I ran the GPU ASUS TWEAK software that came in with the CD, and i tried to update something but i got a message ROM programming fail. But then it seemed to installed the update and forced me to restart the computer.
    But still i get artifacts.
    What do you suggest?

  2. #2
    ROG Guru: White Belt Array Ookami999's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    112

    I'm also getting artifacts in all the games I have tested. Although they are minor and did not acquire every time it's still bothers me if I have to RMA the card or not. I tried every driver that is available but the artifacts are still there.
    Less artifacts acquire with latest stable driver 13.12. I also managed to update the BIOS using GPU Tweak app with 13.30 Beta drivers because with the others the update failed. I hope the problem to be driver related cause I hate to RMA my card and wait to get a replacement.

    My build consists of:

    CPU: Intel i5 4670K
    MB: Asus Maximus VI Hero
    PSU: Coolermaster B700
    RAM: Corsair Vengeance 8GB

  3. #3
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    and what if drivers dont fix it and we miss our rma ?

  4. #4
    ROG Guru: White Belt Array Ookami999's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    112

    I don't think the RMA can fix it. They gonna run some benches and synthetics, which by the way I have run everything and no artifacts acquired, and they will sent you the same card back. I have search everywhere on the net and the info I have gathered concludes to the fact that we are not alone and something is wrong either with the drivers or the entire product line of R9 280x have defective VRAM

  5. #5
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    so what are we going to do... ?

  6. #6
    ROG Guru: White Belt Array Ookami999's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    112

    I'm personally waiting for the end of the month to AMD releasing the 13.35 drivers and see what happens. If still I'm getting artifacts I'm going to RMA the card or simple return it as defective getting a full refund and buy a "Green" one. I'm hoping for an official answer to this issue also.

  7. #7
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    what is a "Green" one ?

  8. #8
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    but the thing i dont get is , the others r9 280x models have no problems? how is that possible? i mean from different manufacturers.

  9. #9
    ROG Guru: White Belt Array Ookami999's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    112

    For "Green" one I mean Nvidia. Nope, I read about MSI and Sapphire both reference and Toxic have this issue but not to that point. Seems ASUS is the most affected manufacturer.

  10. #10
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    are you have artifacts everywhere? i am at the moment seeing many things here while typing using Chrome. Please god let it be a driver issue. But how is it possible for others to work with the same gpu. So i dont think its a driver issue..

Page 1 of 67 1 2 3 11 51 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •