Page 2 of 68 FirstFirst 1 2 3 4 12 52 ... LastLast
Results 11 to 20 of 671
  1. #11
    ROG Guru: White Belt Array Ookami999's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    112

    I did not see any artifacts on Chrome maybe because I have disabled hardware acceleration. Search the web and see for your self that the majority of the users have these kinds of issues and even worst. Clearly, there is no solution as of now, only to RMA and hope. Although I can't find a clue that whom RMA'ed cards got replaced with a good one.
    Last edited by Ookami999; 01-23-2014 at 10:11 PM.

  2. #12
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    RMA means they test it and they send it back?? i would just want to send it for replacement

  3. #13
    ROG Guru: White Belt Array Ookami999's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    112

    They test it and if they find an issue they send you another one. If they don't find, they send you back the same. The shipping costs is also on you. Depends on the country I think.

  4. #14
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    wait i send it to Asus or to the store i got it from ?

  5. #15
    ROG Guru: White Belt Array Ookami999's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    112

    Get in touch with the store you bought it. They will tell you the details about the RMA.

  6. #16
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    damn i updated the VBIOS... hope my guarantee is still on...

  7. #17
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    i just sent it back... you should do the same :P i dont think new drivers will fix this since its gotta be a problem with the VRAM. i hope they let me get a different gpu but i dont know if thereis a better one for this money

  8. #18
    ROG Guru: White Belt Array Ookami999's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    112

    I hope to be replaced with a good one. When you get the replacement please post if the issues are still present or not. As for me, to RMA or not to RMA, this is the question! :P

  9. #19
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    yeah go with it! ill post again when i get it back. Well if the i can change a different gpu , i might do it. im afraid of getting the same :P

  10. #20
    New ROGer Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    4

    I was thinking about buying this card, but it seems like everyone is having problems with it. Looks like a dud to me.

Page 2 of 68 FirstFirst 1 2 3 4 12 52 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •