Page 3 of 68 FirstFirst 1 2 3 4 5 13 53 ... LastLast
Results 21 to 30 of 671
  1. #21
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    yeah just dont . im going for an asus 770 probably. the only good with the r9s is that they are new and have 3gb of memory and 384 bit,
    but im not sure what those specs do, but they are better for sure.
    Future games will need memory i guess
    Last edited by d1versify; 01-24-2014 at 04:06 PM. Reason: typo

  2. #22
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    22

    It is interesting to read this post. First, I can verify the issue is not limited to Asus brand on the 280x. I order an Asus card during Christmas week. I really like the card overall, and the following week placed an order for a 2nd card. As I was using the first card during time off, I started seeing these artifacts during high useage. I RMA'd it back to Newegg the day I received the 2nd card. I have seen no issues with 2nd card. Due to inventory issues, Newegg gave me a refund instead of replacement. After a week with out of stocks, I ordered a Sapphire Toxic. It is the first none Asus gfx card in over 12 years. It has minor artifacts as well. I am thinking it is a driver problem myself. When the artifacts occur on the toxic, I can just refresh screen and it clears up. It does not happened very often. I am going to put it to some games this weekend to determine if I am going to RMA it as well. If I do, I am going to request cross ship, so I know that I have a card coming.
    Asus Maximus VI Formula LGA 1150
    Intel i7-4770K
    G.Skill Sniper Series 16GB (2x8GB) DDR3 2400
    Asus R9-280X DC2T-3GD5
    Corsair Force Series GT 120GB SATA III SSD
    Asus VE248Q Black 24" 2ms LED
    Cooler Master HAF Stacker Modular Tower
    OCZ ZX Series 1000W Fully-Modular 80Plus Gold

  3. #23
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    someone told me its cause of faulty VRAM and drivers cant fix it.. Well lets just hope...
    Well now that i sent it back im really scared. what if they test it and the artifacts wont appear at that time. They will send it back and ill be sad forever :P

  4. #24
    ROG Enthusiast Array Mineria PC Specs
    Mineria PC Specs
    MotherboardGigabyte X570 Aorus Xtreme
    ProcessorAMD Ryzen 5 3700X
    Memory (part number)64GB 3600Mhz G.Skill
    Graphics Card #1ASUS ROG Strix RTX2080 Super A8G
    Sound CardCreative SoundBlaster X3 + Zoom UAC-8
    MonitorGigabyte G32QC
    Storage #1Samsung 960 EVO
    Storage #2Samsung 970 EVO Plus
    CPU CoolerNZXT Kraken X73
    CaseLian Li PC-O11 Dynamic
    Power SupplyEVGA SuperNova 1000 G2
    Keyboard Corsair K95 RGB PLATINUM XT with PBT caps
    Mouse Logitech G602
    Headset Beyerdynamic Custom One Pro
    Mouse Pad Corsair MM300 Extended
    Headset/Speakers Yamaha HS-7
    OS Windows 10 Pro x64
    Network RouterASUS ZenWiFi CT8 AC3000 Mesh
    Accessory #1 Razer Tartarus Pro
    Accessory #2 DELL MS-VR Headset

    Join Date
    Aug 2013
    Reputation
    10
    Posts
    49

    I had artifacts too, and noticed pretty high temperatures, I then reseated the GPU on mine, it was literally drowned with paste.
    Also reduced GPU and Memory clock slightly and adjusted the fans to be more aggressive.
    Again another bad move from green to red -.-

    But at least it doesn't do any more artifacts.

  5. #25
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    22

    and now no artifacts at all ?

  6. #26
    New ROGer Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    4

    Looks like a new bios update was released http://support.asus.com/Download.asp...-3GD5&p=9&s=10

    R9280X-DC2T-3GD5 VBIOS update
    BIOS update to remove rare artifacting events during gaming, Please also update the Catalyst driver to 13.251 or above

  7. #27
    New ROGer Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    3

    Hi!

    I'm also having this issue.
    I have a ASUS R280x Matrix Platinum... I even recorded a video...



    Does the BIOS posted work on this card also?

    Thanks in advance for any help!

  8. #28
    ROG Guru: White Belt Array Ookami999's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    112

    So far I have updated the vBIOS, installed the latest driver from ASUS site and changed the fans manually to be more aggressive. I have yet to see artifacts playing Crysis 2 and Sniper Elite V2. I hope this fixed it cause I hate to RMA the card.

    Quote Originally Posted by sigterm View Post
    Hi!

    I'm also having this issue.
    I have a ASUS R280x Matrix Platinum... I even recorded a video...



    Does the BIOS posted work on this card also?

    Thanks in advance for any help!
    No, the vBIOS is only for the non-Matrix card.
    Last edited by Ookami999; 01-29-2014 at 11:53 AM.

  9. #29
    New ROGer Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    3

    Quote Originally Posted by Ookami999 View Post
    So far I have updated the vBIOS, installed the latest driver from ASUS site and changed the fans manually to be more aggressive. I have yet to see artifacts playing Crysis 2 and Sniper Elite V2. I hope this fixed it cause I hate to RMA the card.



    No, the vBIOS is only for the non-Matrix card.
    So that means I'm stuck... I guess RMA is my only option?

  10. #30
    ROG Guru: White Belt Array Ookami999's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    112

    Quote Originally Posted by sigterm View Post
    So that means I'm stuck... I guess RMA is my only option?
    I guess so. I had the same issues too but I will first try everything I can do to solve them, RMA is my last move.

Page 3 of 68 FirstFirst 1 2 3 4 5 13 53 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •