Results 1 to 4 of 4

Thread: Fed up

  1. #1
    ROG Enthusiast Array Spydyr's Avatar
    Join Date
    Nov 2012
    Reputation
    10
    Posts
    58

    Fed up

    Okay guys a little help because I still cannot find an answer to the problem. This started summer of last year.

    G75VW

    Under Win 7 my DVD drive works fine with CD's, DVD's, and all burnable media.

    Under Win 8 it works on CD-R's. Does not read factory CD's. Read's installer DVD's about 30% of the time. Reads half of my DVD movies.

    I cannot explain why either.

  2. #2
    ROG Enthusiast Array
    Join Date
    Aug 2012
    Reputation
    16
    Posts
    67

    Looks like you explained why just fine. Win8. It's like the new vista, so I'm holding out for 9.

    One thing that would help others help you, is to let us know a little more. anything in event viewer mentioning the problem when it fails?
    error message or the like? Drivers? firmware? is the drive itself damaged in anyway? Have you gone back to win7 and the issue went away?

  3. #3
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    105
    Posts
    4,108

    have you updated all your drivers Chipset IRST IME, What ever Burning program you are using? my G75VW works great on a clean install of 8.1 Reads and burns everything, I'm not sure about BD and I don't have any burnable disk. I burn with Roxio 2012 and Clone DVD, Clone CD.
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  4. #4
    New ROGer Array
    Join Date
    Oct 2012
    Reputation
    13
    Posts
    2,441

    please remove CD rom from device maager and rescan again then install driver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •