Results 1 to 10 of 10
  1. #1
    ROG Member Array
    Join Date
    Feb 2014
    Reputation
    10
    Posts
    5

    Problems with turbo mode under linux

    Hi,

    some Days ago I bought a Maximus VI Hero together with a Core i7 4770k. I have a dual boot system with Win 8 64bit and Linux Mint 16 64bit (Ubuntu 13.10).Under Windows I testet everything is working and the benchmarks running fine. AI Suite 3 is setting my CPU to 4.2 Ghz constantly and the CPU gets not warmer than 43°C. Thats fine and I want the CPU to use this frequency all the time.

    Than I started Linux (I'm just using Windows for gaming) and recognized that my new system is slower than my old system. A look in /proc/cpuinfo shows me that my CPU is running with 800 Mhz. I recognized this behavior at 8 am today. It's almost midnight and the only thing I found out is that with disabled Turbo and Speedstepping the CPU is running with 3.5 Ghz.

    I thought: "ok, fine. then I force the CPU to run at 4.2 Ghz and disable Speedstepping and Turbu"... setting the Core ratio to 42 automatically enables the turbo mode.

    Did you remember the time when you switched some jumpers to set the multiplier to 4 and no magic changed your CPU ever to a lower value than 133 Mhz?

    Any suggestions how to fix this issue?

    Running without turbo mode in linux is ok for me. But it is not ok to change the bios settings every time I want to play a game...

    Thanks for your help.

  2. #2
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Maximus IX Code
    Processori7-7700k 5.2GHz Delidded
    Memory (part number)16GB G.Skill Trident Z 4025MHz 17-17-17-39-2T
    Graphics Card #1Titan Xp - EKFC waterblock
    Graphics Card #2Titan Xp
    Sound CardROG SupremeFX 2015
    MonitorHP ZR30w
    Storage #1Toshiba OCZ VX500 256GB
    CPU CoolerSwiftech Apogee GTZ
    CaseThermaltake Armor+ VH6000
    Power SupplyEVGA Supernova 1600w Titanium
    Keyboard Cyberpower Skorpion K2
    Mouse Razer Basilisk
    Headset Sennheiser HD6XX / Modmic 5
    OS Windows 10 Home 64 bit
    Accessory #1 Asus optical drive
    Accessory #2 Koolance ERM-2K3U
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    308
    Posts
    16,359

    Hi IrascibleMan, Welcome to the ROG forum. Do you have the OC Panel connected?

  3. #3
    ROG Member Array
    Join Date
    Feb 2014
    Reputation
    10
    Posts
    5

    No, I don't own a OC Panel.

    Another solution is to fix my Linux. The problem themes to be in the Kernel Driver for speed stepping. The files /sys/devices/system/cpu/cpu0/cpufreq/bios_limit and /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq are showing 800 (or 801 - i'm running windows right now). I just figured out where to find the drivers. And my be this article brings a solution:
    https://wiki.archlinux.org/index.php...quency_Scaling

  4. #4
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Maximus IX Code
    Processori7-7700k 5.2GHz Delidded
    Memory (part number)16GB G.Skill Trident Z 4025MHz 17-17-17-39-2T
    Graphics Card #1Titan Xp - EKFC waterblock
    Graphics Card #2Titan Xp
    Sound CardROG SupremeFX 2015
    MonitorHP ZR30w
    Storage #1Toshiba OCZ VX500 256GB
    CPU CoolerSwiftech Apogee GTZ
    CaseThermaltake Armor+ VH6000
    Power SupplyEVGA Supernova 1600w Titanium
    Keyboard Cyberpower Skorpion K2
    Mouse Razer Basilisk
    Headset Sennheiser HD6XX / Modmic 5
    OS Windows 10 Home 64 bit
    Accessory #1 Asus optical drive
    Accessory #2 Koolance ERM-2K3U
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    308
    Posts
    16,359

    Enable turbo in the bios. If you have turbo disabled it won't ramp up to 3.9GHz.

  5. #5
    ROG Member Array
    Join Date
    Feb 2014
    Reputation
    10
    Posts
    5

    If turbo and or speedstepping is enabled linux detects the maximum frequency is 800 Mhz.

  6. #6
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Maximus IX Code
    Processori7-7700k 5.2GHz Delidded
    Memory (part number)16GB G.Skill Trident Z 4025MHz 17-17-17-39-2T
    Graphics Card #1Titan Xp - EKFC waterblock
    Graphics Card #2Titan Xp
    Sound CardROG SupremeFX 2015
    MonitorHP ZR30w
    Storage #1Toshiba OCZ VX500 256GB
    CPU CoolerSwiftech Apogee GTZ
    CaseThermaltake Armor+ VH6000
    Power SupplyEVGA Supernova 1600w Titanium
    Keyboard Cyberpower Skorpion K2
    Mouse Razer Basilisk
    Headset Sennheiser HD6XX / Modmic 5
    OS Windows 10 Home 64 bit
    Accessory #1 Asus optical drive
    Accessory #2 Koolance ERM-2K3U
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    308
    Posts
    16,359

    I'm not sure about Linux, but you can try setting windows to high performance power plan,open up cpu-z and see what cpu speed is, enabel turbo cpu-z should show 3900 MHz. stock.

  7. #7
    ROG Member Array
    Join Date
    Feb 2014
    Reputation
    10
    Posts
    5

    Please read the first post again. And don't write me anything about how to set up windows. Windows is running fine with 4.2 Ghz. Thanks for you advice.

  8. #8
    New ROGer Array Zygomorphic's Avatar
    Join Date
    Mar 2012
    Reputation
    176
    Posts
    4,761

    Quote Originally Posted by IrascibleMan View Post
    If turbo and or speedstepping is enabled linux detects the maximum frequency is 800 Mhz.
    Check your CPU governor, and make sure that you have the system loaded. It will attempt to reduce power consumption via speedstepping otherwise.
    I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
    http://rog.asus.com/forum/group.php?groupid=16
    We now have 178 people whose systems will not break! Yippee!
    LINUX Users, we have a group!
    http://rog.asus.com/forum/group.php?groupid=23

  9. #9
    ROG Member Array
    Join Date
    Feb 2014
    Reputation
    10
    Posts
    5

    I just installed a newer kernel (Linux 3.12.0) and now it's working corretly. Thanks

  10. #10
    New ROGer Array Zygomorphic's Avatar
    Join Date
    Mar 2012
    Reputation
    176
    Posts
    4,761

    Quote Originally Posted by IrascibleMan View Post
    I just installed a newer kernel (Linux 3.12.0) and now it's working corretly. Thanks
    Good. Yes, the newer kernels support newer CPUs better. It's kind of the nature of LINUX. Also, depending on where you got the kernel from, it very well could have worked because some default settings (compile flags) were different. Glad to hear you got it resolved!
    I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
    http://rog.asus.com/forum/group.php?groupid=16
    We now have 178 people whose systems will not break! Yippee!
    LINUX Users, we have a group!
    http://rog.asus.com/forum/group.php?groupid=23

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •