Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    1

    Asus G51V Scrren isn't working correctly

    Hello there, Today my friend gave me his old laptop (an Asus G51V) http://support.asus.com/Download.asp...&m=g51vx&os=30

    And he had told me of an issue that I thought I would be able to fix quickly. But it has stumped me. Sometimes when I turn on the laptop it flashes colors.

    Red>Green>Blue>Orange>Pink>Black>Grey etc and so on and just keeps going forever.

    Other times the laptop starts up and I can hear the OS starting up and it loading perfectly to the login screen but the screen is black and won't load..why is this?

    The only thing I would guess is that I need to take it to a repair shop and they fix it? I mean the only thing I can think is that it's his battery. He said it has about..2 minutes of power when it's not plugged in. But plugged in it should work fine.

  2. #2
    New ROGer Array Zygomorphic's Avatar
    Join Date
    Mar 2012
    Reputation
    176
    Posts
    4,761

    Hello, @Nimitz. Welcome to the forums.

    Yes, the battery is shot, and considering the age, that doesn't surprise me all that much. However, that shouldn't cause the problem with the screen that you are seeing. More than likely, the video card is bad, or the cable to the screen is bad. Trying booting attached to an external monitor, and see what happens.
    I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
    http://rog.asus.com/forum/group.php?groupid=16
    We now have 178 people whose systems will not break! Yippee!
    LINUX Users, we have a group!
    http://rog.asus.com/forum/group.php?groupid=23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •