Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 33
  1. #21
    ROG Enthusiast Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    45

    12 days is a long time if it's a simple Power Supply/AC Adapter swap...

    Just to clarify, is the POWER BOARD the board inside of the Power Supply/AC adapter brick, or the MOTHERBOARD?
    Last edited by QC_Desired; 04-04-2014 at 05:01 AM.

  2. #22
    ROG Member Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    9

    One of the reasons I am not satisfied with theit service, nobody cared to explain me about the problem, only answer I was getting was that power board is to be delivered from abroad. I did some checking on power board, and it seems to be the part that is connecting mother board with power adapted (that little hole where you plug adapter into is part of power board)

  3. #23
    ROG Member Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    9

    Again, I came to give you all a quick update on my situation! Today is the 15th day of waiting, and when I called and asked what is the repair status regarding my laptop, I got the info that part that was delivered is INCOMPLETE, and that they ordered a new part, which means another week or so pf waiting for delivery. I am slowly starting to lose my patience with the whole situation and how unprofessional they are.. Ill give them few more days to fix this "difficult" problem, then ill ask for a full refund.. Hope you all enjoy yours, and have no problems! p.s I wanted to buy new ROG smartphone to match the laptop, but after this, no way..

  4. #24
    New ROGer Array
    Join Date
    May 2014
    Reputation
    10
    Posts
    3

    Have completely same issue after some two months. And i'm afraid that this power supply will be underestimated.

  5. #25
    ROG Enthusiast Array
    Join Date
    May 2014
    Reputation
    10
    Posts
    25

    any updates to this ?

  6. #26
    New ROGer Array
    Join Date
    May 2014
    Reputation
    10
    Posts
    3

    In my case service identified as troubles source defective power supply. But to be honest i don't believe to that, because i already tested run laptop with other power supply and only think that has changed was occurence. Charger could be affected too, but i believe that there will be one more root cause - with high probability inside laptop.

  7. #27
    New ROGer Array
    Join Date
    May 2014
    Reputation
    10
    Posts
    3

    One more update to my case. Had a discussion with service yesterday and they informed me that they also preventive replaced whole motherboard and power board too to avoid possible issues in future. I smell that they already faced same issue on this laptop. I hope this replacement will end it otherwise this will be last ASUS product i bought.

  8. #28
    ROG Enthusiast Array
    Join Date
    May 2014
    Reputation
    10
    Posts
    25

    Well I really hoped that I would not have any more issues... But it seems that ASUS ROG really don't care about their customers anymore. AC Adapter die when my son was born in the hospital, had to wait till I got home to open RMA to get new AC Adapter only to find out that they won't send me one right away until I send mine and they receive it and process it..... I give up, Will get new AC adapter and sell the laptop and I will NEVER buy another
    ROG laptop until they change their business model. It seems they got too big for their own good and forgot the reason why they become popular in the first place....

  9. #29
    New ROGer Array
    Join Date
    Sep 2015
    Reputation
    10
    Posts
    1

    Hello, i have the exact same problem with my ROG G750JH

    I already tried the following:
    - changed AC adapter (my mother has the same laptop)
    - had the adapter replaced from ASUS Store with one from G751JY, it's the same
    - tried several drivers

    I'm convinced it's something inside the laptop, it used to happen when i was heavy gaming, but now it happens even using windows

    The screen fades out like it does when i plug in/out the ac adapter, and if i'm gaming the fram rate drops, i think because the graphic card goes on battery mode and reduces its performance...

    How did it work out for you? How long did you wait for the repair?

    Do you think i should try downgrading BIOS? I'm on 206, but i see some stuff related to throttling in 205 and 204 and i think that's what's happening...

    Thank you

  10. #30
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    15

    Quote Originally Posted by Selturus View Post
    Hello, I recently bought my G750JH, 1 month ago to be precise, and in the beginning I had no problems with it whatsoever. But in recent days, I encountered severe problems with power supply. My friend gave me advice that, when I'm home to remove my battery from notebook and connect it directly with cable in order to extend my battery life. After few days, I got sudden problems, my notebook would randomly switch off during work/gaming. It gave me quite a lot of trouble to be honest. Then, in order to stop that from happening, I started using battery/charger connection. While playing games or something else, I'd see that charger is losing connection with notebook for few seconds, then after I literally touch the place where charger is connected, it would get contact back. I reported the issue with ASUS support tech here, they will see what the problem is. I just wanted to see, if any of you got similar or same issue with your notebook, what did you do, and can you give me some advice on what to do about it?

    Thank you in advance, happy gaming to you all!
    I have the same issue and will be sending my laptop back on Monday to ASUS. Nothing I did fixed the issue. And it's getting worse all the time, I've actually depleted the battery while gaming.

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •