Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
  1. #11
    ROG Guru: Orange Belt Array
    Join Date
    Sep 2013
    Reputation
    11
    Posts
    320

    Quote Originally Posted by pokerface View Post
    I upgraded mine and it works perfectly, screw ASUS and their warranty
    thanks for the info.
    hopefully you dont need the warranty...
    Asus G750JX-CV050H||GTX770M||24GB ram||120hz 3D screen||
    1TB Samsung 840 EVO SSD||500GB Crucial M4 SSD||500GB Crucial M4 SSD in DVD Bay
    free bag and mouse
    win 8.1||win 7||win xp||server 2008||os x mavericks||linux mint 16

  2. #12
    New ROGer Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    2

    Thanks HomieOC! I am double checking because the current atheros card is only single stream and max out at 150mbps connection on 2.4ghz @ 40mhz.

    The atheros is a very sad card for a gaming notebook I paid USD 1.8k or € 1.3k equivalent for..

  3. #13
    Banned Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    185

    Just upgraded to the Broadcom BCM4352 802.11ac Wireless and now I get 866 mbps connection this thing even smokes the Wireless N Killer since it uses connects @ AC speed instead of N speed:


  4. #14
    ROG Guru: Orange Belt Array
    Join Date
    Sep 2013
    Reputation
    11
    Posts
    320

    @pokerface: thanks for the update. thats a cracking speed.
    did you have any problems installing the card?
    mines still in the box waiting for the warranty to finish
    also, what router do you have?
    Asus G750JX-CV050H||GTX770M||24GB ram||120hz 3D screen||
    1TB Samsung 840 EVO SSD||500GB Crucial M4 SSD||500GB Crucial M4 SSD in DVD Bay
    free bag and mouse
    win 8.1||win 7||win xp||server 2008||os x mavericks||linux mint 16

  5. #15
    Banned Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    185

    Quote Originally Posted by gazzacbr View Post
    @pokerface: thanks for the update. thats a cracking speed.
    did you have any problems installing the card?
    mines still in the box waiting for the warranty to finish
    also, what router do you have?
    warranty farranty, LOL I couldn't wait till I get rid of that Atheros card which only connected @ 72 MBPS, horrible for such a high end gaming laptop to put such low quality junk.

    I voided my warranty, to be honest, I never had to use warranty but I'm a risk taker so don't listen to me.

    My router is an ASUS RT-AC68U

    My WiFi speed now is almost as fast a a LAN Gigabit connection which is usually @ 1 GBPS

  6. #16
    ROG Guru: Orange Belt Array
    Join Date
    Sep 2013
    Reputation
    11
    Posts
    320

    Quote Originally Posted by pokerface View Post
    warranty farranty,...so don't listen to me.
    lol, yes, point taken.
    so i changed out mine last weekend and bought a new Belkin DS1750 dual band router
    i was going to (simply) replace the dvd drive with a hard disk but it just would line up properly so decided to take apart the laptop and do the wifi swap at the same time.
    30min job being ultra careful knowing how fragile (read cheap) the asus plastic tags are.

    now i have the same connection speed, 866, on 5Ghz.
    even works at 5Ghz on mavericks,
    and LInux Mint

    ticking the box on this one as a success
    Asus G750JX-CV050H||GTX770M||24GB ram||120hz 3D screen||
    1TB Samsung 840 EVO SSD||500GB Crucial M4 SSD||500GB Crucial M4 SSD in DVD Bay
    free bag and mouse
    win 8.1||win 7||win xp||server 2008||os x mavericks||linux mint 16

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •