Results 1 to 1 of 1
  1. #1
    ROG Member Array
    Join Date
    Apr 2014

    G60JX Charging Issue

    Howdy all

    I seem to be having a similar problem as the G70 series threads in regards to charging issues. My factory shipped adapter stopped working so I bought a universal charger from Fry's with exact specs as the factory but it does not charge the battery. I took it back and bought another one but had the same problem. The adapters work but just don't charge. Finally, I used a friends charger who has the same ASUS as me and it worked. I know Dell has had OEM compatibility issues with universal adapters, but haven't read much in relation to G Series notebooks. Any suggestions? If all else fails, I'm just going to get one from ASUS. But I don't really want to stomach the price tag if I don't have to.

    Charger specs
    Model: ADP-120ZB BB
    Input: 100-240V 2A
    Output: 19V 6.32A

    As a note, I ran an energy report and my battery status' full charge is 48945/51260
    Battery icon reads: 0% plugged in, chargin
    Last edited by Cantorie; 04-13-2014 at 12:13 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts