Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Apr 2014
    Reputation
    10
    Posts
    1

    Laptop keeps shutting down

    I just bought a G750jw, and I really like the laptop but ever since I updated windows to 8.1 it started to act weird.

    1. The laptop sometimes shuts down as if someone pulled out the powercord, while the battery is in the laptop and the powercord is plugged in. That happens randomly, even when I'm browsing or something.
    There seems to be nothing wrong with the powercord, because when the laptop is working normally I can see it charging.

    2. Also does it often shuts down immediately after I power the laptop on. The lights start flashing for a second and then nothing happens. If I just keep trying to turn it on, or wait a moment it starts up again as if nothing happened.

    How can I fix this?

  2. #2
    New ROGer Array Zygomorphic's Avatar
    Join Date
    Mar 2012
    Reputation
    176
    Posts
    4,761

    Check for any updated ASUS drivers. It could be that the ASUS drivers are not compatible with Windows 8.1 Also, check the system event logs and see if they say anything about it.
    I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
    http://rog.asus.com/forum/group.php?groupid=16
    We now have 178 people whose systems will not break! Yippee!
    LINUX Users, we have a group!
    http://rog.asus.com/forum/group.php?groupid=23

  3. #3
    ROG Member Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    9

    Please check my post on page 3, might be the same problem like mine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •