Results 1 to 2 of 2
  1. #1
    oao
    Guest

    Windows 7 SATA/AHCI driver for A53U

    We have recently bought a A53U laptop.

    It uses the Microsoft default SATA/AHCI driver and as far as I can tell Asus does not provide a driver. Its chipset don't include one.

    There is an AMD driver available for download which is newer than the Asus pre-installed driver. However, I cannot tell whether it is compatible with the A53U. I tried to match the drivers to the laptop chipset, but it's not clear: the driver refers to SB7xx and SB8xx and the laptop chipset is A40/A50.

    So:

    1. Can I use the AMD driver to update?

    2. If not, is an an Asus driver available or will be available?

    I am making a custom Windows 7 install disc with integrated drivers and the AHCI driver is the only one missing, I have all the others from the Asus website.

    Thanks.

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    318
    Posts
    7,751

    Try using the AMD driver. If it is not compatible with your hardware ID then it simply won't install. It's not uncommon to see drivers that are many months old on a system builder's website so if you want the latest drivers you should always go to the original hardware manufacturer's website.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

Similar Threads

  1. AMD AHCI Drive Sucks
    By CrazyMan212 in forum Other Series Motherboards
    Replies: 17
    Last Post: 10-06-2011, 02:57 PM
  2. Replies: 5
    Last Post: 09-16-2011, 06:50 PM
  3. Rampage III Black Edition AHCI Issues
    By xXToYeDXx in forum Other Series Motherboards
    Replies: 7
    Last Post: 08-20-2011, 04:12 PM
  4. SSD AHCI booting problems with RAID0 PCIe card
    By halcon11 in forum Other Series Motherboards
    Replies: 4
    Last Post: 08-16-2011, 04:37 PM
  5. R3BE: Marvell SATA 6G Issues, AHCI and RAID
    By dframeli in forum Other Series Motherboards
    Replies: 2
    Last Post: 07-17-2011, 10:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •