Results 1 to 5 of 5

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Jun 2014
    Reputation
    10
    Posts
    3

    Sabertooth Z87 New build - no integrated graphics output

    Hi all,

    I eventually bought new bits for a new build and I planned to add a couple fo new graphics cards with several monitors in a couple of months.

    I bought a Sabertooth Z87 mobo with an i7-4770k processer and 2 x 8GB RAM.

    So after various testing swapping out parts and many reboots it would seem that I have an iffy mobo that I need to send back but due to hassle and the time this would cause I thought I would ask you your thoughts. I setup the unit and plugged in the integrated HDMI port to the TV, I just cant get an output. I have also tried the same tv and cable through a HDMI to display port adapter which has the same results.

    When something is connected (HDMI, display port or even an old PCIe card) on the POST the VGA LED stays lit, with nothing connected the NO BOOT DEVICE LED stays lit which is fine as I have not installed an OS yet. Removing the RAM causes the RAM LED to be lit which is fine but I also tried moving the RAM stick to different slots (you never know).

    I plugged in my laptop to the same HDMI cable to the same TV and that came up straight away without issue.
    I have reset the BIOS via the jumper a few times
    Tried to flash the BIOS but I am not sure on the results of that as I still have no output.
    I display did actually come up on the PC upon 'one' reboot but never to be seen again.
    I have removed the CPU to see if there is any damaged to the pins on the motherboard but appears fine.


    Any thoughts would be greatly appreciated, if's been a long time since I bought a PC but I never had any issues before.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •