Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Jul 2014
    Reputation
    10
    Posts
    1

    Question Rampage IV Black Edition PCH Temp Concern

    Hi all!

    I recently just finished a water-cooled build using the Black Edition Motherboard. I have installed windows and other stuff at this point... But I've been going through BIOs and for some reason my PCH is idling between 39 - 45 degrees. Not sure if this is normal while using the water cooled profile. Just wanted to see if anyone had some insight on normal idle temps or tell me what they are currently getting.

    Thanks in advanced!

  2. #2
    ROG Guru: Brown Belt Array MeanMachine PC Specs
    MeanMachine PC Specs
    Laptop (Model)I enjoy my wife
    MotherboardCVI HERO + CVII Hero Wifi
    ProcessorRyzen 7 1800X + 2700X
    Memory (part number)CMD16GX4M2B3000C15 + F4-3200C14D-16GTZR
    Graphics Card #1EVGA GTX980 SC for CVFZ
    Graphics Card #2EVGA GTX 1080 hybrid
    Graphics Card #3GTX 770 for phys x
    Sound CardMB
    MonitorHP w2408h
    Storage #1Samsung 970 EVO 500GB M.2
    Storage #2Samsung 840EVO 500GB and 960 M.2 pro
    CPU CoolerCorsair H105, H110 and H115i
    CaseCorsair 750D and 780T
    Power SupplyCorsair AX-1200i and Antec 850 pro platinum
    Keyboard Logitech K800
    Mouse Razer Mamba
    Headset Corsair Vengeance 2100
    OS W7 Ultimate 64bit and W10 pro 64bit
    Network RouterNetcom Wireless NF18ACV
    MeanMachine's Avatar
    Join Date
    Apr 2014
    Reputation
    126
    Posts
    1,698

    Hi nnapior and welcome to ROG.

    That temp is a little high and should be ambient room temp +5 to +10c. It depends what cooling system you have (not listed).

    If it becomes a concern and temps rise to unacceptable levels under stress, you would be advised to re-seat your CPU with new thermal paste using the pea method or upgrade your cooler.
    We owe our existence to the scum of the earth, Cyanobacteria

    My System Specs:

    MB:ASUS ROG Crosshair VII Hero/WiFi GPU:EVGA GTX 1080 sc PSU:Corsair AX-1200i
    CPU:
    AMD R7 2700X Cooler: Corsair Hydro H115i Case: Corsair Carbide 780t

    Memory:G.Skill TridentZ F4-3200C14D-16GTZR SSD:Samsung 500GB 960 EVO M.2



  3. #3
    ROG Enthusiast Array RobSys PC Specs
    RobSys PC Specs
    MotherboardMaximus VIII Formula Z170
    Processori7-6700K
    Memory (part number)G.Skill Trident Z - F4-3200C16Q-32GTZB
    Graphics Card #1MSI GT980 Ti
    Sound CardAsus XONAR D2X
    MonitorAcer Predator XB271HU, Asus MX27AQ
    Storage #1INTEL SSDPEDMW400G4 (372 GB)
    Storage #2WDC WD4003FZEX (4 TB), ST33000651AS (3 TB)
    CPU CoolerEK Supremacy EVO Elite (Water)
    CaseBe Quiet Case dbp900
    Power SupplyCorsair HX1050
    Keyboard Corsair K95 Platinum
    Mouse Corsair Glaive RGB
    Headset Oppo PM-3 + iBasso D4 amp (no microphone)
    Mouse Pad Steel series
    Headset/Speakers Bowers & Wilkins
    OS Windows 10 Pro 64 bit
    Network RouterASUS DSL AC68U
    RobSys's Avatar
    Join Date
    May 2014
    Reputation
    10
    Posts
    32

    I also have a water cooled rig although I'm not running the water cooled profile (that crashes my system!) just running the CPU at 4.5 Gigs. I'm getting a PCH @ 40 oC. Seems to be fairly constant while idling. My CPU is at 33 oC and motherboard @ 31 oC. Doesn't appear to be presenting any issues...

    Cheers....
    Maximus VIII Formula, i7-6700K Clocked to 4.6+ GHz, EK EVO + XSPC Resevoir + D5 Water Cooling, 32GB G-Skill TridentZ F4-3200C160-32GTZB DDR4, Intel 750 NVMe 400G, 5, Seagate 3TB HDD + 4TB WD HDD, MSI GTX980 Ti Golden Edition.

  4. #4
    ROG Guru: Grand Master Array HiVizMan's Avatar
    Join Date
    Dec 2011
    Reputation
    358
    Posts
    25,742

    Those temps are well within what I would expect to see. You are good to go.
    To help us help you - please provide as much information about your system and the problem as possible.

  5. #5
    ROG Member Array
    Join Date
    Jul 2020
    Reputation
    10
    Posts
    5

    Temperature Concerns

    Hi,

    I've been currently having random freezing and pretty bad performance in general. I tried reseating all my ram, and GPU just in case that was a causing problems. They all seemed pretty good.

    I downloaded HWinfo to check the hardware, and Ive found 4 temp sensors showing anywhere between 92- 100 degrees C. I have attached a screenshot.

    Im not sure what the location of these sensors are.

    Any help would be greatly appreciated.

    Cheers,

    ~BS~
    Miniatura de Adjuntos Miniatura de Adjuntos HWinfo Temps.jpg  


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •