Results 1 to 2 of 2
  1. #1
    ROG Member Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    16

    are these dead pixels?

    Hello, i received my rog swift today but i noticed some problem on the screen.By looking at these pictures can you say are those dead pixels?
    Thanks.
    Miniatura de Adjuntos Miniatura de Adjuntos SAM_8677.jpg  

    SAM_8675.jpg  

    SAM_8669.jpg  

    SAM_8664.jpg  


  2. #2
    ROG Guru: Yellow Belt Array izzyreb02 PC Specs
    izzyreb02 PC Specs
    MotherboardRampage VI Extreme
    Processor9900X
    Memory (part number)32 GB G.Skill Trident Z RGB 32GB DRR4 3200Mhz/F4-3200C14Q-32GTZR
    Graphics Card #1Asus Strix 2080 OC
    Sound CardSound Blaster AE-5
    MonitorMG279Q
    Storage #1Samsung EVO 512 M.2
    Storage #22x 2TB WD HDD (DATA), 6TB WD (Games)
    CPU CoolerThermaltake Floe Riing 360mm
    CaseThermaltake View 71 Tempered Glass
    Power SupplySeasonic Prime Gold 1200Watt
    Keyboard Logitech G810 Orion Spectrum
    Mouse Logitech G900 Chaos Spectrum
    Mouse Pad Logitech PowerPlay
    Headset/Speakers Logitech Z906 5.1 Surround
    OS Windows 10 Pro
    Network RouterAsus RT-AC88U
    izzyreb02's Avatar
    Join Date
    Apr 2012
    Reputation
    17
    Posts
    241

    Quote Originally Posted by ozzy1925 View Post
    Hello, i received my rog swift today but i noticed some problem on the screen.By looking at these pictures can you say are those dead pixels?
    Thanks.
    That looks more like a dead pixel. I had a 1 dead pixel on my VG248QE had just where yours is close near the start button.

    On my ROG swift, I've been checking my screen on a white screen to see if I have any yet and so far none yet , I'd just hope I don't get any.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •