Results 1 to 3 of 3
  1. #1
    ROG Member Array
    Join Date
    Jul 2014
    Reputation
    10
    Posts
    10

    ROG Front Panel/Base LCD Display

    Hi All,

    Hoping you can advise me, I have the ROG Front Panel connect to my Hero vii Mobo. The issue I have is with the RPM fan display is that its only displaying 3 digits instead of 4, when first installed it displayed 4 but after flashing the mobo with updated FW and updating the front panel with the new FW it now only displays 3 digits.

    The digit thats missing is the last digit of the RPM, i have google'd this to no avail so i was hoping someone could shed some light on this.

    the panel was purchased on the 14/07 along with the mobo it was a bundle deal, so im just hoping its a FW issue i dont real want to send both items back for a replacement it was a hassle to tidy those cables lol

    any help would be much appreciated, thanks in advance
    Miniatura de Adjuntos Miniatura de Adjuntos photo.JPG  


  2. #2
    New ROGer Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    2

    I have the same motherboard and front panel,i did the same update but I don't have your problem,i think that is a hardware issue,you must return it....,mine doesn't close the display after pc shutdown,didnt find a solution yet.

  3. #3
    ROG Guru: Yellow Belt Array Deon017 PC Specs
    Deon017 PC Specs
    MotherboardASUS Rampage IV Extreme Black Motherboard
    ProcessorIntel Core i7 4960X Extreme Edition
    Memory (part number)Corsair Vengeance Pro CMY32GX3M4A2133C11 32GB
    Graphics Card #1Asus Poseidon GTX 980Ti
    MonitorAsus Rog Swift 27" 3D Monitor
    Storage #1ASUS RAIDR Express 240GB PCI-E SSD
    Storage #2HDD: Intel 520S 240GB SSD
    CPU CoolerEK Supremacy Elite CPU Waterblock for Intel 2011
    CaseCorsair Obsidian 900D Super Tower Case
    Power SupplyCorsair AX1200i Digital ATX Modular Power Supply
    Keyboard Logitech G19s Gaming Keyboard
    Mouse Asus ROG Gladius
    OS WIN 10
    Network RouterAsus RT-AC3200
    Deon017's Avatar
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    147

    Quote Originally Posted by abergonados View Post
    I have the same motherboard and front panel,i did the same update but I don't have your problem,i think that is a hardware issue,you must return it....,mine doesn't close the display after pc shutdown,didnt find a solution yet.
    You have to check your BIOS - and your powersupply has to be ERP ready - You will do it in APM section of your bios - it switches mine completely off - you just can't use the USB charging then. It will cold start.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •