Page 3 of 19 FirstFirst 1 2 3 4 5 13 ... LastLast
Results 21 to 30 of 181
  1. #21
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    7

    Thumbs up Disappointing

    I am reading forum after forum after forum about issues with this monitor. From these gray lines, to blurry text to gsync issues etc. My monitor is on the way and now I'm worried I have to go to trouble with RMA after a few weeks. I would like a quality product and I am getting more and more turned off due to these quality issues. I have been an ASUS motherboard fan among other products for over a decade probably closer to two. I have always associated Asus with quality. I pay more for a superior product. Just like my cars, I buy one that is deemed extremely reliable cause I don't want to deal with it. I don't care about warranties cause I want a car that doesn't really need to be used. Don't mind paying more for quality at the get go. In this case, it doesn't seem so.

    I even put my name in at Frye's electronics for when one comes in. They called me and both times they were for monitors that were returned but would give a discount. I said no. I am skeptical now.
    Last edited by shenook; 09-26-2014 at 03:34 AM.

  2. #22
    New ROGer Array
    Join Date
    Sep 2014
    Reputation
    10
    Posts
    1

    This happened to my third swift after a couple days of use. I posted a picture of what it looks like in the overclock.net thread.

    My first swift had the red and green lines with color banding problems on the right half. Then my second had a basketball sized circular backlight bleed that was noticeable and distracting in normal use. Now my third has an issue too. The smart thing to do seems to be to walk away.

  3. #23
    ROG Enthusiast Array BrNone's Avatar
    Join Date
    Sep 2014
    Reputation
    10
    Posts
    29

    Same here. Sometimes going in lower refresh rates make the text crisp again, at least in games. ULMB seems to fix issues with text too. Tried another DP cable to - all the same. Maybe monitor can't handle the input from 1440p144?

  4. #24
    ROG Member Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    9

    I'm having the same issue. After a few days with no issues, the screen suddenly went dark for half second and came back like the OP described it.
    Rebooting the PC fixes the issue for me, I'm still at 144Hz.

    I'd love to hear from ASUS if this is a driver, firmware or hardware issue.

  5. #25
    ROG Member Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    15

    Having the same or similar problem as OP (July Build Date)

    On my screen the far right hand side of the screen is clear as when I got it, the left, middle and middle right are blurry. I can clearly tell that there is an issue and can consistently replicate/demonstrate it by simply right clicking on different portions of the desktop and reading text in the prompt. It's clear on the right with great definition, the opposite on the left. Fonts are hard to read, fuzzy. Some letter like the "e" and "a" have the centers filled where as on the right hand side (Clear side) the centers a clearly visible and distinct.

    When I first noticed it, I thought I needed to go see an optometrist but upon further inspection it's the display.

    ASUS?

    Iv'e had the display since it came out in the US so past the time frame to return to vendor (Amazon).

    I have tried cables, different nvidia drivers (clean install and not), different refersh rates, connecting the display with the computer on, resetting the display to defaults etc. Nothing seems to fix the issue.

    Anybody else? Subscribed. Contacted ASUS for RMA.


    Left Edge



    Right Edge

    Last edited by Astro1; 10-28-2014 at 04:35 PM.

  6. #26
    ROG Member Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    21

    Damn, I have exact the same issue after about a month of problem free operation (and outstanding performance). I think i might just go for the refund seeing all these problems, i have also purchased this through Amazon and have to ship it back to god knows where...

  7. #27
    New ROGer Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    1

    Same issue. Will be RMAing soon.

    Very unimpressed given the premium cost of this monitor.

  8. #28
    New ROGer Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    2

    Just realized there's plenty of threads about this and similar issues

    Got stuck with the same issue today so I'll be calling Asus to get this one replaced. What's interesting is that this isn't the first time it happened. It's been an intermittent problem that until today disappeared when unplugging the monitor. This time it's not going away though.

    I did find a way to hide the problem. By setting the monitor to 120 hz and enabling ULMB the issue goes away. Any refresh rate other than that has various issues with 144 being the worst with both flicker, pulsing and blur. The main reason I got the monitor is of course G-Sync so this is in no way a solution. I hope I get a replacement ASAP because I really loved the monitor up to this point. It's a real shame stuff like this happens but that's life I guess.

  9. #29
    ROG Member Array
    Join Date
    Sep 2014
    Reputation
    10
    Posts
    5

    I can't believe how hard ASUS dropped the ball on this one. There's just so many problems. I'm sure there will be a new monitor that fixes everything up and to get that you'd have to fork over another $1k. Ugh. I'm mostly lucky with mine..for now.

  10. #30
    New ROGer Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    3

    These problems started appearing for me too.
    http://i.imgur.com/cIRszXp.jpg

    I would like an official statement to this from Asus. What is the problem? Some people have the same issue even on their second Swift. This is not something random. Looks like a major productionfail

Page 3 of 19 FirstFirst 1 2 3 4 5 13 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •