Results 1 to 5 of 5
  1. #1
    ROG Member Array
    Join Date
    Aug 2014

    Maximus Ranger VII and pcie SSD problems

    I'm not sure if this is the place to post this, if it's an asus issue or plextor, but here goes:

    I have a max' ranger VII installed with a plextor px-g256m6e OS drive in the M.2 connection onboard. Video card is a gigabyte amd R9 290 OC 4gb and PSU is seasonic 550w (gold).

    at random times, but more during long play times the SSD just disappears and the system BSOD with error code F4.
    i removed the intel RST like i saw on few forums. That helped me to prevent the SSD from returning to unformatted state, but the disappearing continues.

    I have the bios at version 1003, the plextor FW at 1.04, video card at F5 bios, all most current. but the crashes still happen.

    i disabled all power saving options for the pcie.

    i'm at a loss...

    can anyone advise?

  2. #2
    ROG Guru: Brown Belt Array MeanMachine PC Specs
    MeanMachine PC Specs
    Laptop (Model)I enjoy my wife
    MotherboardCVI HERO + CVII Hero Wifi
    ProcessorRyzen 7 1800X + 2700X
    Memory (part number)CMD16GX4M2B3000C15 + F4-3200C14D-16GTZR
    Graphics Card #1EVGA GTX980 SC for CVFZ
    Graphics Card #2EVGA GTX 1080 hybrid
    Graphics Card #3GTX 770 for phys x
    Sound CardMB
    MonitorHP w2408h
    Storage #1Samsung 970 EVO 500GB M.2
    Storage #2Samsung 840EVO 500GB and 960 M.2 pro
    CPU CoolerCorsair H105, H110 and H115i
    CaseCorsair 750D and 780T
    Power SupplyCorsair AX-1200i and Antec 850 pro platinum
    Keyboard Logitech K800
    Mouse Razer Mamba
    Headset Corsair Vengeance 2100
    OS W7 Ultimate 64bit and W10 pro 64bit
    Network RouterNetcom Wireless NF18ACV
    MeanMachine's Avatar
    Join Date
    Apr 2014

    Hi amnon23e and Welcome to ROG. As you have the latest Bios.
    Make sure UEFI is enabled in the BIOS, ensuring CSM is enabled.
    Make sure everything is set to either "Legacy and UEFI" or "UEFI only" (it should be in Legacy and UEFI by default).
    Then, make sure to boot to your install media using the correct boot device.

    When you boot to the media as a UEFI device, Windows will automatically install in UEFI mode.

    Also check temperatures as these cards run hot.

    Hope this helps.
    Last edited by MeanMachine; 08-06-2014 at 04:07 AM.
    We owe our existence to the scum of the earth, Cyanobacteria

    My System Specs:

    MB:ASUS ROG Crosshair VII Hero/WiFi GPU:EVGA GTX 1080 sc PSU:Corsair AX-1200i
    AMD R7 2700X Cooler: Corsair Hydro H115i Case: Corsair Carbide 780t

    Memory:G.Skill TridentZ F4-3200C14D-16GTZR SSD:Samsung 500GB 960 EVO M.2

  3. #3
    ROG Member Array
    Join Date
    Aug 2014

    the booting is ok, i use my SSD as MBR and not GPR - but i have not disabled the UEFI. i use win7 prefer to keep it MBR to enable me a multiboot to older OS ect.

    Can i rule out a MB problem? the disappearing happens during work not during bootup.
    and it seems totaly random - no event written on the event viewer that raises suspicion (i moved application and system logs to the HDD so even if the drive disappears the event is written)

    pagefile and dump files are on HDD too.

  4. #4
    ROG Guru: Blue Belt Array jab383 PC Specs
    jab383 PC Specs
    Motherboard24/7 rig : Maximus VI Extreme
    Processori7 4790K
    Memory (part number)16GB Mushkin Redline 2400 10-12-12-28 + 16GB Corsair Vengeance 2400 10-12-12-31
    Graphics Card #1AMD Firepro W5000
    Sound CardM6E Supreme FX
    MonitorDell U2413
    Storage #1Kingston SH103S3240G SSD
    Storage #2Seagate ST1000DM003 1TB
    CPU CoolerCustom water loop, Delidded, Liquid Metal TIM
    CaseCoolerMaster HAF XM
    Power SupplyCorsair HX-750
    Keyboard Logitech G710+
    Mouse Logitech M705
    OS Windows 7 64 Pro
    jab383's Avatar
    Join Date
    Feb 2014

    Hi, amnon23e.

    Legacy boot and MBR are your choice. They worked for me as well as the UEFI does.

    Dropping a PCI device after boot is unusual and you say that it happens more during long play times -- when the system is using lots of power. I think the PSU might be part of the problem. 550 watts is just at the limit of the power a 4-core CPU and R9-290x would need in games - at stock. If you have any overclock at all on either, I'm afraid the PSU would be past its capacity. Little power glitches as the PSU gets strained might make a fast device like PCIe SSD stumble. Do you have another PSU option to try?


  5. #5
    ROG Member Array
    Join Date
    Aug 2014

    Did you tried to clean up the contacts of the M.2 SSD?
    There is not the usual connector friction in the Socket 3 that helps the cleaning so, try to shine the gold contacts of the Plextor SSD with a eraser rubber for pencil.
    And check also if the SSD is correctly inserted in the mobo female and if that socket is not damaged.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts