Results 1 to 10 of 10
  1. #1
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    8

    Problems with Swift PG278Q

    Hi All

    I picked up a PG278Q recently, and it's great except for a few issues-

    1. There is very noticeable flickering in quite a few games that didn't occur on my previous monitor, mostly during loading screens or other transitions. Sometimes this only lasts for a few seconds then stabilizes. In most games while you are actually playing the image is stable. This occurs in both 120 and 144Hz with gsync on or off. When on the desktop or web browser the image is stable.

    2. The Turbo key only displays the current frequency and does not cycle.

    3. The screen will randomly revert to 120hz and 144hz will be removed as an option in NVidia control panel. I have a GTX 680 and windows 7, and read in a previous thread this may be an issue with this combo and current NVidia drivers though. I have reverted to the previous driver and will see if this happens again.

    My question is, are these all known issues that could be fixed with driver/software updates? Or do I need to exchange the monitor before my 30 days are up?

    Thanks

  2. #2
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    7

    Hi,

    Hopefully we can compare notes and I can put some of your worries at ease. I am also running a GTX 680 and received my ROG Swift PG278Q monitor yesterday. Comparing my experience so far with yours:

    1. I haven't noticed any flicker in my game testing (I have tested with both gsync on and off). So far, I have tested BF4, CS:Go, Skyrim, League of Legends.

    2. I have the same issue with the turbo key. It does not cycle and remains at 120hz when the 144 hz option disappears.

    3. As mentioned above, it seems persistent in wanting to revert to 120hz at 2560x1440 (native). I can set it to 144 in the custom resolution settings but that is only a temp fix.

    I was also looking around mainstream forums and have found a couple others beginning to post similar issues.

    Hope that helps. I will be interested to see if any Asus/Nvidia drivers will address these issues in the near future.

  3. #3
    ROG Enthusiast Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    57

    If you are running a 6-series card, the latest NVIDIA drivers has issues with 144 Hz. Roll back to 337.50 and you should be fine. That's what others have been reporting, anyway.

  4. #4
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    7

    Quote Originally Posted by NavasC View Post
    If you are running a 6-series card, the latest NVIDIA drivers has issues with 144 Hz. Roll back to 337.50 and you should be fine. That's what others have been reporting, anyway.
    Thanks for the info. I Just tried your advice and works perfectly. Still hope they address the issue with the next nvidia driver.

  5. #5
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    8

    Thanks for sharing your experience. After rolling back the driver it will stay at 144Hz consistently. The turbo button still doesn't work though and I still get flickering. The major flickering only happens with g-sync enabled now, although after using it for a bit I can detect a small amount of flicker on the desktop as well. It also shows up in the lagom inverstion test (http://www.lagom.nl/lcd-test/inversion.php). If you have starcraft 2 installed, it is very apparent in the loading screens with g-sync enabled. I'm wondering if I just got a monitor with the voltage slightly out of whack or something.

  6. #6
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    7

    I'll load up SC2 and run the linked test when I get home later and let you know, but I was paying pretty close attention during my first round of testing yesterday and didn't notice any flickering like what you have mentioned.
    Last edited by MetaRunner; 08-27-2014 at 09:14 PM.

  7. #7
    ROG Enthusiast Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    57

    What setting is your pixel response set to in the OSD? Maximum, Normal, or off? Try turning it off.

  8. #8
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    8

    I assume you're referring to the OD setting? It was set to normal, but I just changed it to off and it made no difference.

  9. #9
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    7

    Quote Originally Posted by jacoro1 View Post
    Thanks for sharing your experience. After rolling back the driver it will stay at 144Hz consistently. The turbo button still doesn't work though and I still get flickering. The major flickering only happens with g-sync enabled now, although after using it for a bit I can detect a small amount of flicker on the desktop as well. It also shows up in the lagom inverstion test (http://www.lagom.nl/lcd-test/inversion.php). If you have starcraft 2 installed, it is very apparent in the loading screens with g-sync enabled. I'm wondering if I just got a monitor with the voltage slightly out of whack or something.
    Just tested loading SC2 a couple times and didn't see any flickering.

  10. #10
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    8

    Thanks for checking. I must just have a bum unit then, will have to swap whenever frys gets more in stock

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •