Results 1 to 4 of 4
  1. #1
    ROG Enthusiast Array
    Join Date
    Apr 2014
    Reputation
    10
    Posts
    32

    ROG Swift and 144hz problem

    Ive got a gtx 760 running the rog swift at 120hz no problem. I tried to go up to 144hz but the option isnt there in the nvidia control panel. in win 7 options in the advanced settings I can choose 144hz, but every time i choose it it drops the color down to 256 colors, trying to change it back manually to 32 bit does nothing.

    Weird thing is, when i bouught this monitor i diddnt have a displayport gpu because i was waiting on the 980s to come out. So i took the monitor up to work and hooked it up to a gxt 760 and was able to get 144hz just fine, and switch between 60 120 and 144 on the fly with no problem. Downloaded the newest bioshock and played with gsync, 144hz, 1440p.

    I have a more powerful machine than he does, I cant understand whats going on.

    Im running
    i7 5930k Haswell-E
    Rampage V Extreme
    16GB Corsair DDR4


    whats going on?!?

  2. #2
    untouched Array Praz's Avatar
    Join Date
    Apr 2011
    Reputation
    137
    Posts
    4,038

    Hello

    nVidia drivers are having several issues with X99. What you are experiencing may be another. Rumor has it an updated driver is forthcoming.

  3. #3
    ROG Enthusiast Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    57

    Try reverting to Nvidia driver 337. That's solved the issue for a lot of people instead of the latest driver.

  4. #4
    ROG Enthusiast Array
    Join Date
    Apr 2014
    Reputation
    10
    Posts
    32

    newest driver fixed it for me released 9-19-14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •