Results 1 to 10 of 10
  1. #1
    New ROGer Array
    Join Date
    Sep 2014
    Reputation
    10
    Posts
    3

    G750JZ no power, I have no idea what happened.

    I'm actually considered computer-stupid and have no idea what I did wrong, it was fine when I was using it halfway then my g750 just turned off. Thinking it was a random restart, I tried to turn it back on, but I can't even press the power on button. Not even a sound or anything. I'm really confused and this laptop is only 2 months old. Did I do something wrong with it?

  2. #2
    AntiMatter Guru ROG Array chrsplmr's Avatar
    Join Date
    Jul 2011
    Reputation
    295
    Posts
    6,113

    Welcome to ROG.

    You didn't say what you were doing 'halfway' when it turned off.
    Does the 'brick' get warm ? Is there power to it ?
    Take the battery out with it unplugged and push the power button ..
    then plug it in and try to boot it.
    What were you doing ? Gaming ? Did it get real hot ? or was it (excuse me for asking)
    on a pillow or something ?
    I really think its a power issue.
    Best of Luck. Keep us 'Posted'. .c.

  3. #3
    ROG Guru: Platinum Belt Array hmscott PC Specs
    hmscott PC Specs
    Laptop (Model)Asus G750JH-DB71 (legacy)
    MotherboardAsus G750JH Intel HM87
    ProcessorIntel i7-4700HQ XTU Cores 36x/35x/34x/34x Cache 36x -50mV undervolt
    Memory (part number)Hyundai Electronics HMT41GS6AFR8A-PB 1.35v DDR3L-1600MHz
    Graphics Card #1Nvidia 780m Asus GPU Tweak OC 932mhz/6300mhz
    Sound CardRealtek v6.0.1.7469 driver
    MonitorAUO B173HW02 V1 Custom Refresh 85hz
    Storage #1RAID0 2x M.2 SATA Crucial MX200 512GB CT500MX200SSD6
    Storage #2Crucial 512GB 2.5" MX200 CT500MX200SSD1
    Power Supply230w AC Power Adapter 19.5v
    Keyboard Logitech k400 Wireless KB/Trackpad
    Headset Sony MDR-XB500 Wired and Sennheiser RS-220 Wireless TOSLINK
    OS Windows 8.1 + 8 Linux VM's + Windows 10 Technical Preview
    Network RouterAsus RT-AC68U DLINK DIR-655

    Join Date
    Jun 2013
    Reputation
    44
    Posts
    5,357

    Quote Originally Posted by alexophobia View Post
    I'm actually considered computer-stupid and have no idea what I did wrong, it was fine when I was using it halfway then my g750 just turned off. Thinking it was a random restart, I tried to turn it back on, but I can't even press the power on button. Not even a sound or anything. I'm really confused and this laptop is only 2 months old. Did I do something wrong with it?
    alexophobia, are you using your G750 on battery, or is it plugged in? Check to make sure the cord didn't get kicked / worked out at the laptop / adapter / wall - it almost sounds like you ran out of battery and the laptop shutdown.

    Which G750 do you have? I have a G750JH

  4. #4
    New ROGer Array
    Join Date
    Sep 2014
    Reputation
    10
    Posts
    3

    Quote Originally Posted by chrsplmr View Post
    Welcome to ROG.

    You didn't say what you were doing 'halfway' when it turned off.
    Does the 'brick' get warm ? Is there power to it ?
    Take the battery out with it unplugged and push the power button ..
    then plug it in and try to boot it.
    What were you doing ? Gaming ? Did it get real hot ? or was it (excuse me for asking)
    on a pillow or something ?
    I really think its a power issue.
    Best of Luck. Keep us 'Posted'. .c.
    Hi thanks for your reply.
    Yes I was gaming, the brick was warm in a sense, the same temperature it has always been whenever I use it.
    Yes there was power to it.
    Tried, no response at all.
    No the laptop was on top of a table.
    I'm not so sure either, am I the only one that experienced this?

  5. #5
    New ROGer Array
    Join Date
    Sep 2014
    Reputation
    10
    Posts
    3

    Quote Originally Posted by hmscott View Post
    alexophobia, are you using your G750 on battery, or is it plugged in? Check to make sure the cord didn't get kicked / worked out at the laptop / adapter / wall - it almost sounds like you ran out of battery and the laptop shutdown.

    Which G750 do you have? I have a G750JH
    Hey, it was both on battery and plugged in, the brick was untouched, it is definitely not "ran out of battery"
    G750JZ

  6. #6
    ROG Guru: Platinum Belt Array hmscott PC Specs
    hmscott PC Specs
    Laptop (Model)Asus G750JH-DB71 (legacy)
    MotherboardAsus G750JH Intel HM87
    ProcessorIntel i7-4700HQ XTU Cores 36x/35x/34x/34x Cache 36x -50mV undervolt
    Memory (part number)Hyundai Electronics HMT41GS6AFR8A-PB 1.35v DDR3L-1600MHz
    Graphics Card #1Nvidia 780m Asus GPU Tweak OC 932mhz/6300mhz
    Sound CardRealtek v6.0.1.7469 driver
    MonitorAUO B173HW02 V1 Custom Refresh 85hz
    Storage #1RAID0 2x M.2 SATA Crucial MX200 512GB CT500MX200SSD6
    Storage #2Crucial 512GB 2.5" MX200 CT500MX200SSD1
    Power Supply230w AC Power Adapter 19.5v
    Keyboard Logitech k400 Wireless KB/Trackpad
    Headset Sony MDR-XB500 Wired and Sennheiser RS-220 Wireless TOSLINK
    OS Windows 8.1 + 8 Linux VM's + Windows 10 Technical Preview
    Network RouterAsus RT-AC68U DLINK DIR-655

    Join Date
    Jun 2013
    Reputation
    44
    Posts
    5,357

    Quote Originally Posted by alexophobia View Post
    Hey, it was both on battery and plugged in, the brick was untouched, it is definitely not "ran out of battery"
    G750JZ
    alexophobia, it's not supposed to do that then

    You can file a Technical Inquiry with Asus with the details you provided here, and ask for an RMA to debug / fix the problem.

    It sounds like a part(s) failure while powered on. If it won't power back up, there isn't much you can do.

    You could try to find another power adapter and battery and swap them in to see if one of those two items failed, but it is likely problem is in the laptop motherboard - or some other internal component.

    You will most likely need to send it all in to Asus for debugging and repair.

    The only other thing I can think of to try, is to pull the battery, unplug the AC adapter, and press and hold down the Power Button for 30 seconds, and see if a power reset helps.

    You can create a login here, register your laptop, and file a Technical Inquiry for RMA here:

    https://vip.asus.com

    Please come back and let us know how Asus treats you and how long it takes to get RMA'd and back to you fixed.
    Last edited by hmscott; 09-22-2014 at 05:46 AM.

  7. #7
    ROG Enthusiast Array
    Join Date
    Dec 2012
    Reputation
    10
    Posts
    26

    I kind of had the same thing happen the day before. Laptop just turned off.

    I don't think it shutdown since it never did all of the "Shutting down" screens but just turned straight off when I was playing a game. When I pushed the power button a little bar of text came up (before the ROG logo) that said "Upgrading/Updating system" or something like that. It was not the normal windows update thing. After that it turned off (just dead) and then restarted and went through the normal windows update "configuring updates" stuff.

  8. #8
    ROG Guru: Brown Belt Array Darnassus PC Specs
    Darnassus PC Specs
    Laptop (Model)G752VS -=-=- G750JX
    MotherboardASUSTeK COMPUTER INC. G752VS (U3E1) -=-=- ASUSTeK COMPUTER INC. G750JX (SOCKET 0)
    Processori7 6700HQ @ 2.60GHz -=-=- i7-4700HQ CPU @ 2.40GHz - 3.40GHz
    Memory (part number)2x16gb (M471A2K43BB1-CRC) -=-=- 2x8gb (HMT41GS6AFR8A-PB)
    Graphics Card #1GTX 1070 (8GB) -=-=- GTX 770M (3GB)
    Sound CardRealtek High Definition Audio / NVIDIA High Definition Audio
    MonitorGSync IPS 75HZ -=-=- Chi Mei 60Hz (Overclocked to 85Hz)
    Storage #1Samsung SSD 960 EVO 250GB x2 -=-=- LITEONIT LCS-256M6S
    Storage #2HGST HTS721010A9E630 -=-=- ST1000LM024 HN-M101MBB
    CPU CoolerStock -=-=- Stock
    CaseStock -=-=- Stock
    Power SupplyStock -=-=- Stock
    Keyboard Stock -=-=- Stock
    Mouse Razer Naga Epic 1st Generation
    Headset SPH 2500
    Mouse Pad Razer Goliathus
    OS Winblows 10 Pro -=-=- Winblows 8.1 Pro
    Network RouterCG3000v2
    Darnassus's Avatar
    Join Date
    Dec 2013
    Reputation
    61
    Posts
    1,651

    Alex have you tried holding the power button down for 5 seconds+ (hard)? ;x

  9. #9
    ROG Guru: White Belt Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    98

    it happened with me but with sony vaio, and i found the solution like Darnassus said, but the difference is, Unplugged it, remove battery and hold down the power button for 1 minute, then insert the battery and plugged it then try power on, if it doesnt work then u have to hold the power button for 2 minutes, i worked with me many times, i hope u also get it worked,
    if 1 minute and 2 minute doesnt work then try power on on battery only if not then plugged in power on, this is what I know, if nothing works then u have to visit support center

  10. #10
    Banned Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    185

    happened to me as well on my previous G750JX, it just died, ASUS had to replace the motherboard for me which took 7 days to order

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •