Results 1 to 7 of 7
  1. #1
    New ROGer Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    2

    G550JK Keyboard Strokes Missing

    Hi all,
    I have a rather annoying issue with my G550JK. I have checked other topics and it seems like other RoG owners have the same issue. When I type, some random keystrokes are going missing. This issue does not happen if I uninstall the touchpad driver (if I do that, I can't disable the touchpad from Windows at all) or disable the touchpad from BIOS. Unffortunately if you disable the touchpad from the driver settings, the same thing happens, keystrokes go missing. Therefore I would like to inform ASUS about this problem, and hope for a BIOS or touchpad driver update. I bought ASUS for it's quality but this issue is very annoying. Thank you.

  2. #2
    ROG Guru: Brown Belt Array Darnassus PC Specs
    Darnassus PC Specs
    Laptop (Model)G752VS -=-=- G750JX
    MotherboardASUSTeK COMPUTER INC. G752VS (U3E1) -=-=- ASUSTeK COMPUTER INC. G750JX (SOCKET 0)
    Processori7 6700HQ @ 2.60GHz -=-=- i7-4700HQ CPU @ 2.40GHz - 3.40GHz
    Memory (part number)2x16gb (M471A2K43BB1-CRC) -=-=- 2x8gb (HMT41GS6AFR8A-PB)
    Graphics Card #1GTX 1070 (8GB) -=-=- GTX 770M (3GB)
    Sound CardRealtek High Definition Audio / NVIDIA High Definition Audio
    MonitorGSync IPS 75HZ -=-=- Chi Mei 60Hz (Overclocked to 85Hz)
    Storage #1Samsung SSD 960 EVO 250GB x2 -=-=- LITEONIT LCS-256M6S
    Storage #2HGST HTS721010A9E630 -=-=- ST1000LM024 HN-M101MBB
    CPU CoolerStock -=-=- Stock
    CaseStock -=-=- Stock
    Power SupplyStock -=-=- Stock
    Keyboard Stock -=-=- Stock
    Mouse Razer Naga Epic 1st Generation
    Headset SPH 2500
    Mouse Pad Razer Goliathus
    OS Winblows 10 Pro -=-=- Winblows 8.1 Pro
    Network RouterCG3000v2
    Darnassus's Avatar
    Join Date
    Dec 2013
    Reputation
    61
    Posts
    1,651

    Your hand is bumping the touchpad slightly most likely, and in Windows 8 / 8.1 there is a setting that 'halts typing' for a set amount of seconds if the touchpad is interacted with.

    To lessen the time, or stop the 'halt typing', just go to..

    CHARM BAR > Settings > Change PC Settings > PC and Devices > Mouse and Touchpad > Touchpad

    And set: Short Delay or No Delay

    I use Short Delay. Works for me.

  3. #3
    ROG Guru: Brown Belt Array GottiBoi55's Avatar
    Join Date
    Dec 2011
    Reputation
    22
    Posts
    1,117

    You can also use fn+f9 to disable the touchpad while typing, this should solve the issue for you.
    Many people have this issue, as you mentioned.

    PS: Welcome to the Asus ROG forum.
    Come back, and let us know how things work out.
    GottiBoi55
    Asus
    G750JZ-DS71 Windows 10 Pro (x64)
    Intel® Core™ i7 4700HQ (2.40GHz)
    Samsung
    24GB Memory DDR3 1600 MHz SDRAM
    SanDisk
    M.2 SSD 2x128GB in Raid 0 / WD-HGST-1TB HDD 7500-RPM
    NVIDIA® GeForce® GTX 880M 4 GB GDDR5 VRAM
    Second Monitor: Shar
    p Aquos 32"

  4. #4
    ROG Member Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    17

    The issue has been known for ages. If Asus gave a s*** they would've given us a new driver for the touchpad long ago. Disable in BIOS is the only solution for now.

  5. #5
    ROG Guru: Orange Belt Array Prostar Computer's Avatar
    Join Date
    Jul 2013
    Reputation
    11
    Posts
    462

    As others mentioned, make sure you are not gracing the touchpad with your hands as you type. A lot of people do this mistakenly, utterly unaware of it. You can disable the trackpad via the hotkey mentioned (doing so from Device Manager does not work on our systems nor other laptops either).
    We customize Asus, MSI, and Clevo laptops!

  6. #6
    New ROGer Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    2

    Disabling the trackpad via hotkey does not work actually. It disables the touchpad but I think touchpad is always on. You can try it with disabling the touchpad via hotkey, then turning the screen off via the hotkey. After it, if you touch the touchpad the screen will turn on, even if you disabled the touchpad before. So far the only solutions working for me are uninstalling the driver or turning it off via BIOS. I hope these information would help the people suffer from the same problem or ASUS, if they try to find a solution to this issue, which seems to affect a lot of ASUS laptops.

  7. #7
    ROG Guru: Brown Belt Array GottiBoi55's Avatar
    Join Date
    Dec 2011
    Reputation
    22
    Posts
    1,117

    Well, my G750JZ doesn't react in that manner, when I disable the touchpad via the (fn+f9) hotkey
    The only thing that will turn on the screen is touching any key, not the touchpad.
    Now I had a issue on my G75VW, where the touchpad would not disable.
    What worked for me was reinstalling the touchpad driver, for some odd reason the driver got corrupted, and the only solution was to reinstall the touchpad driver.
    This issue happened a couple of times, and each time the solution was to reinstall the driver.
    When you mentioned that your "touchpad' was still active after the hotkey, that reminded me about my G75VW issue I had in the past.

    PS: I hope this will work for you my friend.
    GottiBoi55
    Asus
    G750JZ-DS71 Windows 10 Pro (x64)
    Intel® Core™ i7 4700HQ (2.40GHz)
    Samsung
    24GB Memory DDR3 1600 MHz SDRAM
    SanDisk
    M.2 SSD 2x128GB in Raid 0 / WD-HGST-1TB HDD 7500-RPM
    NVIDIA® GeForce® GTX 880M 4 GB GDDR5 VRAM
    Second Monitor: Shar
    p Aquos 32"

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •