Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    1

    Unhappy G550JK Touchpad: disable touch for buttons

    I have problem with touchpad: when I click left or right button, cursor move to random position. I always keep thumb over left button area, but this prevents gesture recognition.
    I tried to find options for disable touch for button area, but I didn't find anything :(
    Can I configure touch area and disable touch for buttons?

  2. #2
    ROG Guru: Platinum Belt Array hmscott PC Specs
    hmscott PC Specs
    Laptop (Model)Asus G750JH-DB71 (legacy)
    MotherboardAsus G750JH Intel HM87
    ProcessorIntel i7-4700HQ XTU Cores 36x/35x/34x/34x Cache 36x -50mV undervolt
    Memory (part number)Hyundai Electronics HMT41GS6AFR8A-PB 1.35v DDR3L-1600MHz
    Graphics Card #1Nvidia 780m Asus GPU Tweak OC 932mhz/6300mhz
    Sound CardRealtek v6.0.1.7469 driver
    MonitorAUO B173HW02 V1 Custom Refresh 85hz
    Storage #1RAID0 2x M.2 SATA Crucial MX200 512GB CT500MX200SSD6
    Storage #2Crucial 512GB 2.5" MX200 CT500MX200SSD1
    Power Supply230w AC Power Adapter 19.5v
    Keyboard Logitech k400 Wireless KB/Trackpad
    Headset Sony MDR-XB500 Wired and Sennheiser RS-220 Wireless TOSLINK
    OS Windows 8.1 + 8 Linux VM's + Windows 10 Technical Preview
    Network RouterAsus RT-AC68U DLINK DIR-655

    Join Date
    Jun 2013
    Reputation
    44
    Posts
    5,357

    Quote Originally Posted by Igorious View Post
    I have problem with touchpad: when I click left or right button, cursor move to random position. I always keep thumb over left button area, but this prevents gesture recognition.
    I tried to find options for disable touch for button area, but I didn't find anything
    Can I configure touch area and disable touch for buttons?
    Igorious, the touchpad L/R buttons aren't directionally sensitive, so if you are getting jumping around due to pressing them, you might have a grounding problem at the location you are running from. Try running without the AC power adapter plugged in to your laptop - run on battery - and disconnect any peripherals that need plugging in - like external disk enclosures, and see if the jumping around goes away.

    If it is a grounding problem, you need to get that fixed, but in the interim you could use a ground cheater plug like this (or the equivalent for your location), to break the ground connection and stray charge that is appears to be bring to you:

    Click image for larger version. 

Name:	Cheater_plug_edited.jpg 
Views:	4 
Size:	130.2 KB 
ID:	42079

    Some people have found that disabling the touchpad in the BIOS, or using Asus Smart Gesture to disable the touchpad when a mouse is plugged in makes their keyboard experience better - no character drops or lagging in typing. So you could move to an external pointing device.

    Click image for larger version. 

Name:	disable touchpad when external mouse connected.JPG 
Views:	13 
Size:	84.1 KB 
ID:	42078
    Last edited by hmscott; 10-13-2014 at 10:15 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •