Results 1 to 10 of 10
  1. #1
    thumper64
    Guest

    AC Power Supply Problem

    I recently purchased a refurbished G73jh from Tigerdirect.com. I expected it to show up with minor dings or dents and issues, but now I have a rather large problem.
    The power cord, where it attaches to the computer, is not connecting to provide power for charging the battery and the system itself. I've ordered a new Universal Charger (Targus 180w) to see if this solves my issue.
    I was wondering if anybody else has had an issue similar to this or can offer some advice on how to resolve this problem.

    Thanks!
    Thumper

  2. #2
    ROG Member Array
    Join Date
    Sep 2010
    Reputation
    10
    Posts
    16

    Hello Thumper,

    Does the connector fit into the opening? Is the connector inside the notebook loose in any way?

    If the connector doesn't fit and the connector is loose, I suggest you do an RMA with either Tiger (if available) or with ASUS - Most refurb devices only have a 90 day warranty - you don't have much time if there is a problem that is covered by the warranty.

    Good Luck...
    In Peace and Agape,
    Trav...

  3. #3
    Brian@ASUS
    Guest
    the adapter light is on right? if you take the battery off, does the computer turn on? could be a battery issue but like travelor said it might be a connector issue, might want to ask tiger to swap it.

  4. #4
    thumper64
    Guest
    Got my computer back up and running, I had ordered the targis power supply on a suggestion and got it today, charges the battery just fine.

  5. #5
    Brian@ASUS
    Guest
    have you tried to RMA the power adapter?

  6. #6
    AgentArrow
    Guest
    Hello, I recently (around May 1st, give or take a few days) purchased a G73JH. This computer was never put into circumstances that would cause damage to the system. It is usually on my desk, with the exception of occasionally taking it to robotics for CAD work. About 48 hours ago, under normal use, my supplied Asus power supply spontaneously died. I ensured that it was, in fact, the power supply and not my computer by trying to boot the computer without the battery, which it did not do. The green light is on on the supply, but no power is delivered to the computer. To be absolutely sure, I swapped power supplies with a friend who has a G71. His power supply was able to charge my battery and generally power my computer, whilst my power supply did not charge his computer. I tried contacting Asus customer to find out if the power supply could be replaced under warranty, but the website did not include power supply information, and the e-mail from Asus customer support provided no answers, as it was just a link to the sales page. After a major google search which also turned up no useful answers, I have come to the Republic of Gamers forum do request an answer to my questions; Is the power supply covered under warranty? if so, how do I go about replacing it by warranty?

    Edit: oh my, I somehow missed the notebook warranty info at the bottom of the forum. I'm going to check that right now.

  7. #7
    Brian@ASUS
    Guest
    agent, i would call in to our RMA service team. they should be able to get you a replacement if its broken.

  8. #8
    AgentArrow
    Guest
    I apologize for missing what was right in front of my face the whole time, I was able to solve the problem on my own about ten minutes after posting. That was quite embarrassing. On another note however, I shipped out the power supply to ASUS today and i am hoping that it will be replaced by the time I get back from my trip next week. Other than the power supply failure, I am very satisfied with the G73JH-A2, it is a beautiful machine and with the power to match. As of now, the best mobile gaming machine I have ever owned. I look forward to more successful ASUS RoG products in future years.
    Thank you for taking the time to put up with my idiocy.

  9. #9
    atzkilcher
    Guest
    Hello, I have been experiencing a similar situation as stated in this thread. It started about a week ago when I had to manuever my power cord so it would charge my laptop. I usually leave my laptop on so one morning when I woke up the laptop was dead because the power cord was not inserted properly to keep the computer on. So obviously the problem is the power adapter but I am afraid that it may have messed up the connection on the motherboard.

    I have been trying to get a RMA number to get this problem fixed but here is where the problem lies: I am currently overseas in Honduras but I have a military APO box. From past experience in different locations where I had to use a military APO box, everyone had no problem sending it to me. But I just keep getting resplies saying they will not send it to a PO Box. I do not think the individuals helping me know that there is a vast difference between a PO Box and a military APO box.

  10. #10
    TeamROG Notebook Member Array Chastity@ASUS's Avatar
    Join Date
    Oct 2010
    Reputation
    18
    Posts
    1,334

    Quote Originally Posted by AgentArrow View Post
    I apologize for missing what was right in front of my face the whole time, I was able to solve the problem on my own about ten minutes after posting. That was quite embarrassing. On another note however, I shipped out the power supply to ASUS today and i am hoping that it will be replaced by the time I get back from my trip next week. Other than the power supply failure, I am very satisfied with the G73JH-A2, it is a beautiful machine and with the power to match. As of now, the best mobile gaming machine I have ever owned. I look forward to more successful ASUS RoG products in future years.
    Thank you for taking the time to put up with my idiocy.
    As a suggestion, the Targus 180w APA05US Power Supply makes for a great second powerbrick. You can find it here for $38.75 + s/h. I personally have 2 of them, one for my backpack, and one for the livingroom, and the OEM one in my bedroom.
    Kicking Ass Since Today

Similar Threads

  1. G71GX-RX05 Problem
    By Pmadison in forum GX/GM/GU Series Gaming Notebooks
    Replies: 6
    Last Post: 03-30-2011, 03:20 AM
  2. Problem with overclocking programs with R3E
    By AnthonyLackey in forum Overclocking & Tweaking
    Replies: 3
    Last Post: 08-05-2010, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •