Page 4 of 4 FirstFirst ... 2 3 4
Results 31 to 31 of 31
  1. #31
    ROG Enthusiast Array
    Join Date
    May 2015
    Reputation
    10
    Posts
    56

    "BIOS is updating" loop on Prime X399-A

    I know this thread is quite old, but just in case anyone needs to solve this: I encountered this problem on Asus Prime X399-A. I tried to downgrade BIOS from 0807 to 0601 via Flashback feature, but it would always freeze at the "BIOS is updating" screen afterwards. Flashing back the 0807 version didn't help. After several failed experiments (including clearing CMOS etc.), I tried flashing version 0301 which was on the mainboard's DVD and... success! It went to the "BIOS is updating" screen again, but after a few seconds it rebooted itself and prompted me to enter BIOS via F1 key. I then upgraded it to 0601 via EZ Flash menu inside BIOS.

    Keep in mind that the Flashback function is very sensitive to the type of flash drive you use, it refused to work with most drives I've tried. Eventually, I settled for prehistoric 2GB USB 2.0 drive which I wiped clean with Diskpart and formatted as old FAT16. Make absolutely sure the drive has only one partition, otherwise Flashback will not work.

    Oh, and just in case you're wondering: I downgraded the BIOS beacuse my G.Skill Ripjaws memory sticks wouldn't run stably at 3200/CL14 under 0807, whereas they worked fine under 0601.
    Last edited by bugme-not; 09-03-2018 at 08:44 PM.

Page 4 of 4 FirstFirst ... 2 3 4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •