Page 1 of 25 1 2 3 11 ... LastLast
Results 1 to 10 of 263

Hybrid View

  1. #1
    ROG Guru: Yellow Belt Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    153

    G751 - Problem with USB3.0 ports (left side) and external HD... anyone else?

    So, I am now experiencing a problem whereby when I attach my external 3.5" WD HDD to the USB ports on the left side of the ASUS G751 and copy large amounts of data, the throughput will drop and then the HDD will disconnect. I verified this multiple times in both ports. In the ports on the right side, it works fine.

    I did some reading and found a forum post where someone stated: http://forum.notebookreview.com/asus...ml#post9836352

    next.... USB 3.0 problems..

    basically, I had to connect my USB drives to the right ports and the left ones were kept for my mouse and printer? why? because ASUS cannot produce a piece of hardware that functions right! they claim all ports are USB 3.0 and they are all in blue color...BIG LIE! it wasn't only me, I posted this on the ROG forums and every single one of the members verified the same!
    My question is what the hell is causing this, and how can it be fixed? I do not want a laptop where 2x USB ports are essentially useless, and this seems to be a widespread issue dating back to earlier models like the G750. Why has this not been addressed and fixed?

    If anyone else has this issue please post here...
    Last edited by Richdog; 12-08-2014 at 02:15 PM. Reason: Typo

  2. #2
    ROG Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    13

    Man, I just made thread about this. Left port (the one closer to me, the other one is OK) keeps dropping connection every 10 seconds or so. I can't copy anything to my HDD because it keeps closing and opening it, and my mouse when connected to that port keeps getting DC'd. I am "glad" I am not alone in this, but it freaking sucks. I paid $2000 for the laptop and it has problems right out of the box. That's not what I experienced with G75VW I had previously.

  3. #3
    ROG Enthusiast Array
    Join Date
    Sep 2014
    Reputation
    10
    Posts
    58

    C'mon same problem here!! The one closer to me is bugged as hell..
    WTF with those ROGs? There's a new bug every day.

  4. #4
    ROG Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    13

    I won't be keeping mine. Going to bring it back tomorrow. I really loved my G75VW and I really like this one if it wasn't for all this sh*t. Sure, keyboard layout is highly questionable and keyboard without backlight is really hard to read, but that's about all the things I don't like. I can live with these. But I can't live with the fact that $2000 gaming laptop doesn't have working USB ports, has sound problems and keeps giving me BSODs while playing 3 year old games. Meh.

  5. #5
    ROG Guru: Yellow Belt Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    234

    I thought it may have been just a little error or something with my drive...

    Go figure - I've got two massive problems with this machine.

    Anyone know when/if HP will release an OMEN 17 laptop? (HP laptops are the only ones that have never crapped out on me.)

  6. #6
    ROG Guru: Black Belt Array toronto699 PC Specs
    toronto699 PC Specs
    Laptop (Model)G752-VY-DH78K , G751-JYDH72X
    MotherboardRog Tytan G30AB
    Processori7-4770K
    Memory (part number)32GB
    Graphics Card #1Asus Gold20th GTX980Ti
    Sound CardDell X-Fi Audigy SoundBlaster
    Monitor3 Acer K272HL
    Storage #1118 GB/OS
    Storage #22.72 TB
    CPU CoolerIntegrated Liquid-Cooled CPU
    CaseG30AB
    Power SupplyAsus 700 Watt
    Keyboard Razer BlackWidow Ultimate
    Mouse Razer Diamond Back
    Headset Sony Studio Professional , Razer Seiren Mic
    Mouse Pad Razer FireFly
    Headset/Speakers Logittech 5.1 Z-5500
    OS W 10
    Network RouterSagemon Fast 5250 Hub 2000

    Join Date
    Aug 2014
    Reputation
    74
    Posts
    2,416

    BSRxlgnition I refused the G751JT from Canada Computes "audio from sub only" thank goodness for "Corporate American Express" I can just walk away , As For HP , I Miss MY HP HDX 18 , Canada Computes spent almost a week trying to fix the "Sub Only Audio Issue" NO FIX , No Solution" They tried all kinds of solutions they said. But I have A G751-JY-DH72X with some modifications that works perfectly .
    Last edited by toronto699; 11-20-2014 at 07:35 PM.

  7. #7
    ROG Guru: Yellow Belt Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    234

    Yeah - for the first time in forever, I think I rather actually be without a computer for a while and just wait. I've had it with all the issues this thing has, and I'm looking up an alternative 970m or equivalent computer.

    Thing is, for me, I have to go back across the border to return mine - unless Amazon.com (US) accepts returns from across the border. (Canada)

    They have a week to issue a patch for the "Sub-only-Sound" and Lower Left USB port issues, or I'm returning my computer and swearing off Asus for good, regardless.

  8. #8
    ROG Guru: Yellow Belt Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    153

    These are annoying issues, but for me not yet a complete dealbreaker... the price I got for this machine was simply too good and so I am willing to wait it out for a bit.

    However, ASUS need to achknowledge and fix these issues... and the moderators here need to do their part to raise awareness too!

  9. #9
    ROG Guru: White Belt Array andreacos92 PC Specs
    andreacos92 PC Specs
    Laptop (Model)Asus ROG G751JY-T7134H
    MotherboardAsus G751JY (Intel HM87 Chipset) with Custom BIOS
    ProcessorIntel Core i7-4710HQ @ 3.9 GHz (all 4 cores active)
    Memory (part number)16 GB DDR3L @ 1600 MHz 9-9-9-28
    Graphics Card #1NVIDIA GTX 980M 4GB with Custom VBIOS @ 1410/6020 MHz (1150 mV)
    Storage #1Samsung SSD 960 EVO 500 GB (OS)
    Storage #2SanDisk SSD 128 GB - Hitachi HDD 1 TB 7200 rpm
    CPU CoolerStock cooler with IC Diamond
    Power SupplyStock 230 W
    OS Windows 10 Pro
    andreacos92's Avatar
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    85

    Similar problem on G750 here

    Some fixed the issue disabling Asus USB Charger Plus, other updating chipset drivers.

  10. #10
    ROG Guru: Yellow Belt Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    153

    Quote Originally Posted by andreacos92 View Post
    Similar problem on G750 here

    Some fixed the issue disabling Asus USB Charger Plus, other updating chipset drivers.
    I can confirm that uninstalling ASUS USB charger plus does NOT work.

    Which chipset drivers did people update, the ASUS ones or other specific ones? Thanks.

Page 1 of 25 1 2 3 11 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •