Results 1 to 7 of 7
  1. #1
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    28

    G751JY - random beeps from the HDD, anyone else?

    Howdy,

    Just went and upgraded my G75VW into a G751JY and mostly I'm super happy with it. Only small stupidities like the useless ROG button shoving num lock behind fn-combo and the default fan speed of 2300RPM which is more loud than with G75VW.

    I've stumbled upon two problems, if you have had similar, please tell:

    1) The Seagate HDD randomly beeps twice when it resumes from sleep. I noticed this after the windows power saving had turned the HDD off after a while before the HDD spun up again. As there are no speakers on the mobo nor on the HDD, it must be mechanically produced. Funnily the beeping does not occur when cold booting, only when the computer is already on and the HDD spins back up. I solved this temporarily by removing HDD sleep entirely, but I'm going to get this checked anyway. Never trusted Seagate that much after they removed their 60 month warranty... Has anyone else had this?

    2) A few times after resuming from sleep the screen backlight has turned on but nothing has appeared on the screen. The computer needed to be put back to sleep and resumed again to get the picture back. Also, sometimes (perhaps once in a hour) there is a very short flicker which looks similar to screen tearing, I have not found out what might cause it. I have upgraded to 344.75 drivers, don't know if they might have something to do with it.

    Overall as a short review to anyone considering buying the G751JY a quick "review" or comparison to my trusty G75VW:

    Pros:
    - Vastly better display, G75 was always a bit crap. This one has way better gamut and viewing angles.
    - Finally better working sound drivers, G75 never worked well, often needing pulling out headphones and reloading pages to switch e.g. Youtube sound from the speakers to headphones. Also, the subwoofer never worked correctly either. This one FINALLY works at least adequately with the realtek drivers
    - Wireless and LAN have worked well for me without any problems (Intel Wifi, Realtek LAN)
    - Better working card reader, though i'm not sure if my G75 had a problem with it
    - The charger is a little smaller and lighter, though not much
    - Under heavy load this is much quieter than G75

    Cons:
    - There is no way to clean the fans easily anymore without removing the entire back cover, this is crap.
    - The ROG key is useless, and I also notice pressing accidentally the camera key constantly when i'm trying to hit ESC (I don't look at the keyboard when using it but work from finger memory so I just have to relearn it)
    - At idle, the fans are louder than in G75
    - The power plug is crap! It is very loose compared to G75 and easily falls off. Also some other review sites noted this problem, so it's just not only me
    - The DVD bay is still flimsy and crappy as with G75, When lifting the computer it is very easy to open it by accident. I would ditch it but then I'd need to buy something to replace it with a similar shaped exterior. A third HDD though would be nice to add...
    - There is no way to access the bottom 2 ram slots without opening the whole computer
    - The Seagate SSHD is the obvious Seagate quality, I would have preferred WD and I'm probably going to change it anyway
    - ASUS is still lacking in quality control, they clearly don't check their products all that much before shipping

    Overall for the price, this is a great package but next time I might choose something else unless ASUS steps up their QC

  2. #2
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    220

    I share some of your experience with the G751JY.

    The thing with the screen going Black is really strange.. I have the exact same problem with mine

    I also noticed the fan seems louder then my G75VX was .. Anyway, I'm shipping my laptop off to RMA tomorrow, I just hope that will fix some of mu issues. The list is starting to get bigger and bigger!
    The King of the north!

  3. #3
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    28

    The screen problem was fixed with nvidia's new update: "System hang up and black screen after power on with some monitors (DP1.2 & 4K/60Hz) + GTX980"! i have not received the problem after installing the hotfix (knock on wood), even though it is meant for other monitors.

    The hdd failed today so I just removed it and bought a WD RED 1TB which i know are a reliable model (have had numerous in the past) and also adequately fast for storing Steam games (I run W8.1 pro on an intel ssd).

    Just of curiosity, what kind of issues have you had?
    Last edited by Mublur; 11-25-2014 at 07:04 PM.

  4. #4
    ROG Enthusiast Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    33

    Mublur, are you saying your G751JY came with a Seagate HDD and it has already failed?
    I was under the impression that (most) G75x laptops came with a HGST HDD.

  5. #5
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    28

    Yep, mine is Seagate 1TB SSHD (ST1000LM014), also my previous G75 had a Seagate hdd (750gb)

  6. #6
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    28

    Quote Originally Posted by Sagi View Post
    I share some of your experience with the G751JY.

    The thing with the screen going Black is really strange.. I have the exact same problem with mine

    I also noticed the fan seems louder then my G75VX was .. Anyway, I'm shipping my laptop off to RMA tomorrow, I just hope that will fix some of mu issues. The list is starting to get bigger and bigger!
    Hey Sagi, have you got your G751 from service yet? I noticed that my blank screen problem has returned. The computer boots normally, everything runs fine, backlight is on - but no picture appears (no post, nothing). I will have to shut it down and restart, then everything is fine. Also, a couple of times the computer has hung up in the bios post screen forcing me to reboot it.

  7. #7
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    220

    My G751JY is still in for repair - It's been 10 days since they recieved it and they are currently still waiting for spare parts. I called ASUS today, they told me that LetMeRepair was still waiting for the 17'3 lcd screen.

    They had to change a lot it seems.. GPU / CPU fans, new keyboard layout and the screen.. Not sure if there was anything else I missed

    They said I could give them a call later this week if my status didn't change on the RMA site. They even said, that if I didn't have it back this week - They could try and speak to a guy @ service level 2.. But I should expect the repair time to be between 2-4 weeks, depending on the delivery time for the spare parts.

    I hope I will get it back this week, but I'm not getting my hopes up yet.. Since they haven't recieved the new screen yet
    The King of the north!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •