Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    New ROGer Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    4

    G751JY RMA Experience!

    I bought the Asus G751JY-DH73-CA about month ago and everything was performing great when I bought it, unfortunately after 5 days I had it I found two problems:

    -The "x" key was off centered and was causing it to stick on the frame when pressed.
    -Bezel on the right side of the screen was slightly loose. You only could notice it by pressing the bezel on this area.

    I could live with the bezel issue, but the x key problem was annoying me a little bit. So I talked to an Asus rep and he said I would have to send the notebook for repair, which I did. I was following my RMA status on the website and it had changed to Waiting-[WB1] Wait for Material/Spare Parts After a week or so I contacted Asus again to know if they could tell me why the part was taking so long to arrive, but I basically was told what I already knew. Even though the Asus reps couldn't tell me too much about my status they were always very polite and tried to help me the best they could. So I received my unit back this Friday. They changed the entire keyboard area and the bezel. Since then it's been a pleasure to type on this keyboard. The bezel issue remained, have no idea why. But I won't rma it again since this is not causing me any problems at all and is only present in the middle of the bezel on the right side.

    All in all I can say I had a positive experience with the RMA process and I've got my notebook back performing great as when I bought it, running cool, silent and very fast.

    Good job Asus.

  2. #2
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    52

    Thanks for sharing that mate!.. and I'm glad you you got your notebook back. It really sucks when you buy something, and have to send it in to be fixed.

  3. #3
    New ROGer Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    4

    Yes, I just thought you guys should know. This was my first RMA process and I'm glad everything worked out.

  4. #4
    ROG Guru: Brown Belt Array Darnassus PC Specs
    Darnassus PC Specs
    Laptop (Model)G752VS -=-=- G750JX
    MotherboardASUSTeK COMPUTER INC. G752VS (U3E1) -=-=- ASUSTeK COMPUTER INC. G750JX (SOCKET 0)
    Processori7 6700HQ @ 2.60GHz -=-=- i7-4700HQ CPU @ 2.40GHz - 3.40GHz
    Memory (part number)2x16gb (M471A2K43BB1-CRC) -=-=- 2x8gb (HMT41GS6AFR8A-PB)
    Graphics Card #1GTX 1070 (8GB) -=-=- GTX 770M (3GB)
    Sound CardRealtek High Definition Audio / NVIDIA High Definition Audio
    MonitorGSync IPS 75HZ -=-=- Chi Mei 60Hz (Overclocked to 85Hz)
    Storage #1Samsung SSD 960 EVO 250GB x2 -=-=- LITEONIT LCS-256M6S
    Storage #2HGST HTS721010A9E630 -=-=- ST1000LM024 HN-M101MBB
    CPU CoolerStock -=-=- Stock
    CaseStock -=-=- Stock
    Power SupplyStock -=-=- Stock
    Keyboard Stock -=-=- Stock
    Mouse Razer Naga Epic 1st Generation
    Headset SPH 2500
    Mouse Pad Razer Goliathus
    OS Winblows 10 Pro -=-=- Winblows 8.1 Pro
    Network RouterCG3000v2
    Darnassus's Avatar
    Join Date
    Dec 2013
    Reputation
    61
    Posts
    1,653

    This might lift a few scares of the bad experiences.

  5. #5
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    220

    May I ask how long it took for the RMA?

    I had to use the RMA as well.. Currently it says:

    Arrived: 2014/11/28

    Esitmated time for repair: 2014/12/12 09:00:00

    Product repair is in progress.-[WB1] Wait for Material/Spare Parts.

    It's been shipped off to repair @ LetMeRepair in Sweden (they handle all the nordic countries) So I'm aware it might not be the same

    This is what I sent it back for:

    1. Green glow @ the left side of the screen
    2. V button was stuck
    3. Enter key slightly stuck and was making a sqweeking noise when I used it
    4. CPU / GPU running slightly hot at times
    6. Sqweeking noise from the right side (it's coming from the fans @ high load) definitely not something it should be doing!
    7. The speaker issue (sound only coming from left side + the sub)

    Hope they fix everything, so I won't have to sent it back once again.. I even add'd a list with picture etc. explaining with circles and stuff, so they knew where to locate the problems
    Last edited by Sagi; 11-30-2014 at 09:53 PM.
    The King of the north!

  6. #6
    New ROGer Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    4

    Quote Originally Posted by Sagi View Post
    May I ask how long it took for the RMA?

    I had to use the RMA as well.. Currently it says:

    Arrived: 2014/11/28

    Esitmated time for repair: 2014/12/12 09:00:00

    Product repair is in progress.-[WB1] Wait for Material/Spare Parts.

    It's been shipped off to repair @ LetMeRepair in Sweden (they handle all the nordic countries) So I'm aware it might not be the same

    This is what I sent it back for:

    1. Green glow @ the left side of the screen
    2. V button was stuck
    3. Enter key slightly stuck and was making a sqweeking noise when I used it
    4. CPU / GPU running slightly hot at times
    6. Sqweeking noise from the right side (it's coming from the fans @ high load) definitely not something it should be doing!
    7. The speaker issue (sound only coming from left side + the sub)

    Hope they fix everything, so I won't have to sent it back once again.. I even add'd a list with picture etc. explaining with circles and stuff, so they knew where to locate the problems
    It sucks when you experience problems like this with a new system. Well, the whole process from the day I sent it for repairing to get it back took 23 days. It stayed under the "Product repair is in progress.-[WB1] Wait for Material/Spare Parts" status for 15 days. I forgot to say that Asus did next day shipping to my home which was a good point too. I hope they can fix everything for you

  7. #7
    ROG Guru: Platinum Belt Array hmscott PC Specs
    hmscott PC Specs
    Laptop (Model)Asus G750JH-DB71 (legacy)
    MotherboardAsus G750JH Intel HM87
    ProcessorIntel i7-4700HQ XTU Cores 36x/35x/34x/34x Cache 36x -50mV undervolt
    Memory (part number)Hyundai Electronics HMT41GS6AFR8A-PB 1.35v DDR3L-1600MHz
    Graphics Card #1Nvidia 780m Asus GPU Tweak OC 932mhz/6300mhz
    Sound CardRealtek v6.0.1.7469 driver
    MonitorAUO B173HW02 V1 Custom Refresh 85hz
    Storage #1RAID0 2x M.2 SATA Crucial MX200 512GB CT500MX200SSD6
    Storage #2Crucial 512GB 2.5" MX200 CT500MX200SSD1
    Power Supply230w AC Power Adapter 19.5v
    Keyboard Logitech k400 Wireless KB/Trackpad
    Headset Sony MDR-XB500 Wired and Sennheiser RS-220 Wireless TOSLINK
    OS Windows 8.1 + 8 Linux VM's + Windows 10 Technical Preview
    Network RouterAsus RT-AC68U DLINK DIR-655

    Join Date
    Jun 2013
    Reputation
    44
    Posts
    5,357

    Quote Originally Posted by Demike View Post
    ...I forgot to say that Asus did next day shipping to my home which was a good point too...
    Demike, Asus usually ships the same speed back to you as you shipped to them.

  8. #8
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    220

    Demike may I ask which country your laptop was repaired at ?

    23days sounds oki, as long as they fix all the problems.
    The King of the north!

  9. #9
    ROG Guru: Yellow Belt Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    153

    Quote Originally Posted by Demike View Post
    I bought the Asus G751JY-DH73-CA about month ago and everything was performing great when I bought it, unfortunately after 5 days I had it I found two problems:

    -The "x" key was off centered and was causing it to stick on the frame when pressed.
    -Bezel on the right side of the screen was slightly loose. You only could notice it by pressing the bezel on this area.
    I also have the loose bezel issue on the right side, so I guess this is another common manufacturing fault. it feels like you could "click" it into place, but sadly that's not possible, it's just not fixed properly. This, in combination with the strong IPS glow, is making me consider an RMA.

  10. #10
    New ROGer Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    4

    Quote Originally Posted by hmscott View Post
    Demike, Asus usually ships the same speed back to you as you shipped to them.
    Well, I shipped to them in 2 days, so they went beyond my expectations in that matter

    Quote Originally Posted by Sagi View Post
    Demike may I ask which country your laptop was repaired at ?

    23days sounds oki, as long as they fix all the problems.
    It was in Canada.

    Quote Originally Posted by Richdog View Post
    I also have the loose bezel issue on the right side, so I guess this is another common manufacturing fault. it feels like you could "click" it into place, but sadly that's not possible, it's just not fixed properly. This, in combination with the strong IPS glow, is making me consider an RMA.
    That's exactly my case with the bezel, but as long as it doesn't give me any problems in the future I'm fine. I'm glad that my screen there is no noticeable glow. Can't you exchange you unit for another one? If not it's better to send it for repair.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •