Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
  1. #11
    ROG Enthusiast Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    33

    Quote Originally Posted by Sagi View Post
    This is what I sent it back for:

    1. Green glow @ the left side of the screen
    4. CPU / GPU running slightly hot at times
    7. The speaker issue (sound only coming from left side + the sub)
    I'm having same issues. Actually they all can be according to specification. The green glow on the very left might be an IPS screen side effect - at the right i have some more bluish tone for example and green on the right - although it is clearly visible only on solid background. CPU/GPU hot - they will be hot when under stress. Not sure about speaker issue, haven't tested them.

    Please let me know if they will send you back and you wont notice any glows on the screen - i will consider then sending back mine too!

    I actually could noticed it at the very beginning when i was looking for faults in the screen but after a while i got used to it, and you don't notice it that much if you don't have solid background on the screen.

  2. #12
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    220

    I will give a feedback once I know more.. i called them again yesterday (they are still waiting on the screen) they got everything else they need to replace.

    I told them I wasn't happy about sending a brand new laptop back for repair, which I had just paid 3000$ for - So they told me, that if it's not been fixed by the 17.12.2014 they will credit me and I will get my money back (or order a new one) which I doubt I will.

    I'm not going to risk ending up with another faulty laptop that needs to be shipped off to RMA straight away
    The King of the north!

  3. #13
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    220

    Here is an update on my RMA:

    Status: Not been fixed yet (still waiting on spare parts - the 17'3 screen) it's been 2 weeks since they ordered the spare parts for the repair.

    Estimated time for repair and delivery was set for the 12.12.14, which is today.


    So.. I've been in contact with both ASUS and the retailer (Dustin.dk) the past few days.

    ASUS couldn't offer me ANY support or help other then "sorry for the delay" .. Dustin.dk on the other hand, they handled this like I would expect any professional retailer would.

    They told me that they would contact ASUS and try to follow up on this - And today I recieved an email from Dustin.dk, that confirmed ASUS would credit the laptop and I was able to get a new one instead.

    So if everything goes well, I will have a brand new G751JY @ monday

    However, I'm not getting my hopes up yet with the new one.. I will test it in anyway possible once I get it!

    At least something good (hopefully) came out of all this hassle.
    Last edited by Sagi; 12-12-2014 at 10:38 AM.
    The King of the north!

  4. #14
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    65

    Received my second laptop after sending the first back, which had bad ips glow on the right side, the subwoofer issue and some issue with the left fan. The second laptop has the same problems, except for the fan problem, and has also hair under the screen (dafuq?)
    I'm gonna ask for a replacement of the screen this time, and also ask if there is already something they can do about the subwoofer, a warranty for a fix would be nice.
    If the screen isnt fixed the third time i give up and ask for a refund.

  5. #15
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    65

    i also noticed the touchpad buttons are a bit loose, is this normal? didnt pay attentiton to it with the first laptop.

  6. #16
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    220

    I finally got my replacement and I'm currently installing various stuff on it..

    There is no screen bleed or anything like that.. Now I just have to test it and see, if it actually stays cool and quiet like it should

    I will update it later or tomorrow.
    The King of the north!

  7. #17
    ROG Guru: Yellow Belt Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    234

    Quote Originally Posted by Sagi View Post
    I finally got my replacement and I'm currently installing various stuff on it..

    There is no screen bleed or anything like that.. Now I just have to test it and see, if it actually stays cool and quiet like it should

    I will update it later or tomorrow.
    Let us know if all your issues are fixed, especially the speaker issue.

  8. #18
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    220

    So.. This is a small feedback on my RMA experience.

    A few weeks ago I shipped my G751JY off to repair using the RMA service - After 2 weeks nothing had happend, so I contacted the retailer and told them about my situation. After a few emails back and forward, they agreed to give me a new replacement.

    I got it yesterday and I was actually happy to see, that there was NO SCREEN BLEED at all - The only way to see it, is when you close / open the lid (because of the flex) So that was perfect!

    Everything ran like it should and once I had done the BIOS / driver update I did a recovery backup using ASUS backtracker.

    After that I decided to replace the 7200rpm HDD with my SSD (like I did on my previous G751JY) AND THEN THE SAME GOD DAMN THING HAPPEND!
    ... Again one of those screws holding the HDD bay was impossible to get out. I had to remove the "arm" from the bay again, like I did on the previous one.

    And like this wasn't bad enough, as I was removing the screws holding the bay - 1 of them slipped of the screwdriver and fell down in the small opening there is next to it.. I tried everything to get it out!

    NO LUCK WITH THAT..

    I shacked it a bit, to see if I could get it out somewhere else.. But instead it just ended up getting stuck somewhere (got no clue where) And now I'm not sure if I should return it for ANOTHER rma.. Just to get that fixed?!

    I didn't do any prime95 or furmark tests.. Instead I raided for 3 hours and had MSI afterburner / HWinfo64 tracking the temperatures.

    GPU was running at 66-75c with a max peak of 84c.
    CPU was running at 60-70c with a max peak of 80c.

    My only concern atm is that stupid screw.. I don't know what I should do about it - When I shake the laptop I can't hear it anymore, so it's stuck somewhere inside of the laptop.

    Anyway, I'll run some BF4 later to check up on the temperatures .. But it actually seems like I got a perfectly fine laptop this time (except for low quality on the screws they use).


    A little sidenote:

    Touchpad is slightly loose (there was a gap in the corner) However, I pushed it down and I hope it will stay there for now. The reponse time wasn't great either - The previous G751Jy had a waaaaay better touchpad.
    Not to mention the keys.. They seem loose as well and don't always respond when clicking it.. This is not an major issue, since I hardly ever use it.



    PS. Speakers seems to be oki (still a lot of sound coming from the sub) but the left and right speakers are playing as well.
    Last edited by Sagi; 12-16-2014 at 10:39 AM.
    The King of the north!

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •